TLS support broken in mozilla

VERIFIED FIXED

Status

P1
blocker
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: mscott, Assigned: javi)

Tracking

1.0 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Sometime within the last week or so the TSL socket provided by PSM broke. This
prevents users from sending mail using SSL (which is currently the default in
mailnews so we are getting tons of complaints about this because people can't
send their email). 

Necko is properly invoking the TSL socket. However, we never receive an
OnStartRequest from the tsl socket. 

Also, it appears that mozilla is incapable of any networking activity after we
create a TLS socket. Something is causing everything to get blocked. Seems
strange that psm could cause the necko threads to block.
(Reporter)

Comment 1

18 years ago
Adding appropriate keywords
Severity: normal → blocker
Keywords: nsbeta1
Priority: -- → P1

Comment 2

18 years ago
Is this happening on the branch or trunk builds?
(Reporter)

Comment 3

18 years ago
trunk only. 

Comment 4

18 years ago
Adding Javi to cc-list.

Javi,

Is there any chance that your TLS fix may be causing this problem on the trunk?
(Assignee)

Comment 5

18 years ago
Someone remind me how to modify my SMTP SSL settings.  I can't find it in the
UI.
(Reporter)

Comment 6

18 years ago
Edit / Mail And News Settings.

Then click on Outgoing Server. 
Check the radio button for "Try SSL when available"

thanks for looking into this javi. 
(Assignee)

Comment 7

18 years ago
Here's what I'm seeing:

nsSSLIOLayerNewSocket gets called with the argument to set up a TLS socket. 
After I return from that function, neither nsSSLIOLayerWrite nor
nsNSSSocketInfo::TLSStepUp get called.  

These are supposed to get called, right?

Updated

18 years ago
Keywords: mailtrack
(Reporter)

Comment 8

18 years ago
I'm not sure whose supposed to call nsNSSSocketInfo::TLSStepUp
but from the smtp protocol's point of view, we never try to right anything to
the socket until necko proxies a OnStartRequest to us. This lets us know that
the connection has been established. 
(Assignee)

Comment 9

18 years ago
This is caused by my patch to dumb down SSL connections if the handshake fails
after a connect when SSL v3.1 is enabled.  Some thread blocks on a read because
I left the socket in blocking mode after a connect.

I'm working on a patch to not leave the socket in blocking mode after a connect.
Assignee: ddrinan → javi
(Reporter)

Comment 10

18 years ago
good catch Javi! I was just about to say that it looks like the regression
happended the same day 64888 was fixed (June 7th). 

Let me know if you still need me to call you to work this out. I can also test
any patches you've got for us. 
(Assignee)

Comment 11

18 years ago
Created attachment 38008 [details] [diff] [review]
Patch to reset non-blocking value after connect
(Assignee)

Comment 12

18 years ago
mscott: The patch worked for me.  Could you guys beat on it a little more to
make sure it works for you guys as well.

Thanks.
(Reporter)

Comment 13

18 years ago
it works like a champ for me!
(Assignee)

Comment 14

18 years ago
Created attachment 38091 [details] [diff] [review]
Updated patch.
(Assignee)

Comment 15

18 years ago
wtc, please review my latest patch.  Thanks.
(Reporter)

Comment 17

18 years ago
*** Bug 85584 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
*** Bug 85598 has been marked as a duplicate of this bug. ***
sr=blizzard
(Reporter)

Comment 20

18 years ago
*** Bug 85618 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 21

18 years ago
*** Bug 85607 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

18 years ago
*** Bug 82970 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
Blocks: 83989
(Assignee)

Comment 24

18 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 25

18 years ago
*** Bug 85816 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 26

18 years ago
*** Bug 85892 has been marked as a duplicate of this bug. ***

Comment 27

18 years ago
Verified on WinNT and Linux.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 28

18 years ago
*** Bug 85970 has been marked as a duplicate of this bug. ***

Comment 29

18 years ago
Fixed for me on Win 98 - you guys are good!

Comment 30

18 years ago
*** Bug 86648 has been marked as a duplicate of this bug. ***
*** Bug 85338 has been marked as a duplicate of this bug. ***

Comment 32

18 years ago
*** Bug 86675 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm1.01 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.