Closed Bug 854 Opened 22 years ago Closed 21 years ago

{sink} content sink needs to support nested incremental reflow

Categories

(Core :: DOM: Core & HTML, defect, P4)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: angus, Assigned: vidur)

References

()

Details

This test case is a document with a <UL> followed by 500 <LI>s followed by a
</UL>.

If you load this URL in IE, you'll see that it lays out list items
incrementally.

We don't show anything until we hit the </UL> - you'll notice that the same set
of list items broken up into 25 UL groups renders much faster (see test case at:
http://www.mozilla.org/nglayout/testcases/stress/500in25uls.html )

We should lay out long lists incrementally. We'll need to do this in order to
support an Aurora Front End in HTML.
Status: NEW → ASSIGNED
Summary: We aren't incrementally laying out large lists → content sink needs to support nested incremental reflow
Currently the content sink only allows the body to respond to incremental
(appended) reflow. This is a somewhat arbitrary limitation that needs repair.
*** Bug 1026 has been marked as a duplicate of this bug. ***
Setting all current Open/Normal to M4.
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
QA Contact: 4015 → 4144
It doesn't look like a DOM issue. QA contact re-assigned to Layout owner.
Severity: normal → minor
Priority: P2 → P4
Summary: content sink needs to support nested incremental reflow → {inc} content sink needs to support nested incremental reflow
*** Bug 6008 has been marked as a duplicate of this bug. ***
*** Bug 5847 has been marked as a duplicate of this bug. ***
Assignee: kipp → peterl
Status: ASSIGNED → NEW
Since you are going to work on it, you can hold the open bug...
Assignee: peterl → vidur
This should fall out of the content sink cleanup work...
Summary: {inc} content sink needs to support nested incremental reflow → {sink} content sink needs to support nested incremental reflow
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fixed by content sink changes on 10/26/1999. Stress away, Angus!! :-)
Status: RESOLVED → VERIFIED
Fixed in the Nov 15th build.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.