Closed Bug 854762 Opened 9 years ago Closed 9 years ago

Motion JPG flashes severely instead of drawing smoothly + Firefox process hangs on exit when bug encountered

Categories

(Core :: Graphics: ImageLib, defect)

22 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 856486
Tracking Status
firefox21 --- unaffected
firefox22 - ---

People

(Reporter: fehe, Assigned: seth)

References

()

Details

(Keywords: crash, regression, reproducible)

Crash Data

As a consequence of bug 716140, motion JPEGs flash severely instead of being drawn smoothly as was the case before.  Additionally, once this bug is encountered, the Firefox process no longer exits on browser shutdown and has to be forcibly terminated.

Regression first showed up here: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c9c29cc97af0&tochange=1407288d820b

Although subsequent patches have fixed the issue of the video not painting fully, it flashes with every paint and the browser hang still remains.

Some people have even reported browser crashing.  I have not myself experience that -- maybe because I don't leave it on that page for long.
OS: Windows 7 → Windows 8
against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130326 Firefox/22.0 ID:20130326030941 CSet: 456cb08f8509 I can confirm getting a Crash with given URL:

bp-4c3fee79-82f2-435b-88ea-ab3ac2130326 ->  [@ mozilla::image::RasterImage::DecodePool::RequestDecode(mozilla::image::RasterImage*) ] -> Bug 854835?
Me too: bp-a73a0094-9e73-4c0c-a6a9-c79582130326.

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Aimage%3A%3ARasterImage%3A%3ADecodePool%3A%3ARequestDecode%28mozilla%3A%3Aimage%3A%3ARasterImage*%29
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Aimage%3A%3ARasterImage%3A%3ADecodePool%3A%3ADecodeJob%3A%3ARun%28%29
Blocks: 854835
Severity: normal → critical
Crash Signature: [@ mozilla::image::RasterImage::DecodePool::RequestDecode(mozilla::image::RasterImage*)] [@ mozilla::image::RasterImage::DecodePool::DecodeJob::Run()]
Keywords: hangcrash, reproducible
OS: Windows 8 → Windows 7
Hardware: x86 → All
Version: Trunk → 22 Branch
Seth, is this something we know about?
Assignee: nobody → seth
Yeah, there are a lot of bugs along these lines since OMTD went in. I'll be trying to get these taken care of over this week.

If you encountered any that I'm not CC'd on, please add me.
Is it as same as bug 853811 which was opened by myself a week ago?

The cam page:
http://whitecity.dvrdns.org/cgi-bin/guestimage.html
No longer blocks: 854835
I can reproduce the process hangs on exit with clean profile.

Reproducible: very often

Steps To Reproduce:
1. Open http://www.shioda-dcom.co.jp/shiocame/ [Tab A]
2. Open New Tab
2. Close [Tab A]
3. Exit browser

bp-abc24a92-86a8-40eb-ac86-0d8fd2130402
(Stack using http://benjamin.smedbergs.us/crashfirefox.exe)
I believe that this is a dupe of two bugs. I suspect the hang of being fixed by bug 857367, and the mJPEG issues are definitely resolved by bug 856486. (Just to be sure we're all comparing the same stack of patches, I also have the fixes in bug 854803 applied.) I am leaving this open because, although I can't reproduce the hang, I'm not on Windows and it'd be good to confirm that the problem is fixed once those patches hit m-c.
No longer blocks: 856486
Depends on: 856486, 857367
So all of the patches I mentioned have hit m-c. Can anyone reproduce this on a build based on the current m-c?
I cannot reproduce the high CPU usage problem.
And also I cannot reproduce the hang up problem on exit browser.

Test URL:
http://www.shioda-dcom.co.jp/shiocame/
http://www.oadm.cat/en/content/61/live-webcams.htm
http://192.171.163.3/view/view.shtml?id=4755&imagePath=/mjpg/video.mjpg&size=1

Test Build:
http://hg.mozilla.org/mozilla-central/rev/139b6ba547fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130405 Firefox/23.0 ID:20130405131405
Thanks so much, Alice! Marking this as a dupe of bug 856486, since that's the most similar of the two bugs.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 856486
(In reply to Mikel from comment #6)
> Is it as same as bug 853811 which was opened by myself a week ago?
> 
> The cam page:
> http://whitecity.dvrdns.org/cgi-bin/guestimage.html

filed Bug 861604
You need to log in before you can comment on or make changes to this bug.