UX - customize is not populated

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Landis Reed, Unassigned)

Tracking

(Blocks: 1 bug)

22 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P1])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20130329 Firefox/22.0
Build ID: 20130329040204

Steps to reproduce:

right click or click 'menu' icon > customize


Actual results:

ui 'shrinks' and customize sheet appears, but except for the edit tools <cut, paste, zoom, share, etc> there are no applets to add, not even spacer.
This is the case Every Time, but one.
Once, after adding my 'restartffbutton' addon, the second time i tried customize, icons appeared.
I've right-clicked > customized OR 'menu' icon (far right) > customized more than 40 times and only once was there icons in the customize sheet.


Expected results:

applet icons should be in 'customize' window.

*again, once in 40 tries was there any icons in 'customize' window. that was the first or second time I tried, After i installed a small 'restartffbutton' addon i made.
(Reporter)

Comment 1

5 years ago
after another 10 tries, customize came up populated.
I added, just for fun, the Group Tabs icon to the toolbar.
Closed customized, clicked on GroupTabs button (10x) and Nothing happened.
I clicked the 'New Tab' + on tab bar and it opened a new tab, but in Tab Groups View.
I could Not close tab groups, could not choose a tab (page).
Clicking on previous page (in tab group, as iconnized page) animated page as if it were enlarging to 'open' or become the page i am viewing, but only reduced back to an icon.
Over and Over.
I could Not get out of Tab Groups. I had to kill firefox.
(Reporter)

Comment 2

5 years ago
Created attachment 731336 [details]
could not get out of tab group

I could not get out of 'Tab Group' view after clicking 'New Tab'

Comment 3

5 years ago
WFM with 2013-04-01-03-08-17-mozilla-central-firefox-22.0a1.en-US.linux-x86_64

Comment 4

5 years ago
Oh, it's about the ux branch…
Component: Untriaged → Toolbars
Hello Landis, can you still reproduce the problem?
Blocks: 872617
Flags: needinfo?(landis)
Any luck reproducing, Landis?
Whiteboard: [Australis:P1]

Comment 8

4 years ago
Per bug 940559, I'm guessing this was eventually solved in terms of getting into Customize Mode. As there was a third-party theme involved there, I'm hopeful the fixes for bug 941321, bug 918782 and bug 938995 will fix the difficulty getting into and out of customize mode. Those will be in a Nightly tomorrow. Landis, please reopen this bug if you can still reproduce at that point. Thank you!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Flags: needinfo?(landis)
You need to log in before you can comment on or make changes to this bug.