When using private browsing, personas are disabled

RESOLVED DUPLICATE of bug 852295

Status

()

Toolkit
General
RESOLVED DUPLICATE of bug 852295
5 years ago
5 years ago

People

(Reporter: theflyingmave, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

I run firefox in private browsing mode by default.  When updating to 20, my persona theme will not show unless I turn private browsing off


Actual results:

Upgraded, personas are now disabled when using private browsing


Expected results:

persona should be enabled unless user specifies otherwise.

Comment 1

5 years ago
I can confirm this. Using a persona, then opening a private browsing window or session removes the persona and reverts to default (classic or aero).

There shouldn't be a need to disable lightweight themes on purpose, just an indicator of the App button or window title is indication enough.

Comment 2

5 years ago
Perhaps related to Bug 852295 - although there should be no need to disable personas in private browsing tabs/windows at all (which is still being done after that patch, it only fixes permanent PB mode)

Comment 3

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

I think this issue is related to Bug 853426.
I was able to reproduce it only on Firefox 20.

Updated

5 years ago
Component: Untriaged → General
Product: Firefox → Toolkit

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 852295

Comment 5

5 years ago
Not really a duplicate - it disables personas in all private browsing windows, the other bug is about permanent private browsing mode.

In the PB windows you already have a clear indicator that it's a PB window, so it should not disable the personalization.

Comment 6

5 years ago
As originally filed, this bug is a duplicate: "I run firefox in private browsing mode by default."

Comment 7

5 years ago
Want me to file a separate bug for this then? I can do that.

Comment 8

5 years ago
Filed bug 860803
You need to log in before you can comment on or make changes to this bug.