Display error in TB 22 using personas

RESOLVED FIXED in Thunderbird 23.0

Status

Thunderbird
Theme
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: LEOXD, Assigned: Paenglab)

Tracking

22 Branch
Thunderbird 23.0
x86_64
Windows 7

Thunderbird Tracking Flags

(thunderbird22+ fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 733274 [details]
The Screenshot. The red marked areas are the ones which SHOULD be affected by themes.

The Mail-Toolbar is no longer affected by Personas in TB22. That should be changed.

Updated

4 years ago
Component: Untriaged → Theme
(Assignee)

Comment 1

4 years ago
Bug 817468 regressed this. I think I need to set the background color directly on the attachment bar.
Blocks: 817468
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

4 years ago
Created attachment 734021 [details] [diff] [review]
proposed fix

Sorry Mike, I forgot to check Bug 817468 with personas. This patch sets now directly a background color on attachmentBar which looks like setting the -moz-appearance: toolbox; on mailContent or messengerBox. For this I gave under Win7 the background-image.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #734021 - Flags: ui-review?(mconley)
Attachment #734021 - Flags: review?(mconley)
tracking-thunderbird22: --- → +
Comment on attachment 734021 [details] [diff] [review]
proposed fix

Sorry for the crazy wait on this. Code looks good, and testing shows that this does indeed fix the problem. Thanks Richard!
Attachment #734021 - Flags: ui-review?(mconley)
Attachment #734021 - Flags: ui-review+
Attachment #734021 - Flags: review?(mconley)
Attachment #734021 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 4

4 years ago
Comment on attachment 734021 [details] [diff] [review]
proposed fix

[Approval Request Comment]
Regression caused by (bug #): 817468
User impact if declined: Wrong appearance with LW-themes
Risk to taking this patch (and alternatives if risky): small, there are only CSS changes.
Attachment #734021 - Flags: approval-comm-aurora?
https://hg.mozilla.org/comm-central/rev/ebc5dba345c4
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 23.0
Attachment #734021 - Flags: approval-comm-aurora? → approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/a02b40a24fec
status-thunderbird22: --- → verified
status-thunderbird22: verified → fixed
You need to log in before you can comment on or make changes to this bug.