Closed Bug 858556 Opened 8 years ago Closed 8 years ago

Defect - Double clicking text with the mouse displays the selection grippers in Immersive mode

Categories

(Firefox for Metro Graveyard :: Browser, defect, P1)

x86
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 23

People

(Reporter: virgil.dicu, Assigned: jimm)

References

Details

(Whiteboard: [selection] feature=defect u=metro_firefox_user c=content_features p=1 status=verified)

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #850673 +++

Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130404 Firefox/23.0

I can reproduce every time -clean profile Metro. Considering last comments in the cloned bug, I'll file this for:

1. launch Nightly in immersive mode.
2. Select text (double click).

Actual results: grippers displayed above the selection.
This is happening here - 

http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/input.js#145

we should check if we are in precise mode here before firing the event.
Attached patch fixSplinter Review
Assignee: nobody → jmathies
Summary: Defect - Selecting text displays the grippers in Immersive mode → Defect - Double clicking text with the mouse displays the selection grippers in Immersive mode
Comment on attachment 733854 [details] [diff] [review]
fix

confirmed this fixes the problem.
Attachment #733854 - Flags: review?(netzen)
Attachment #733854 - Flags: review?(netzen) → review+
Attached patch export patchSplinter Review
Attachment #733859 - Flags: checkin?
QA Contact: jbecerra
Attachment #733859 - Flags: checkin?
Keywords: checkin-needed
Whiteboard: feature=defect u=metro_firefox_user c=content_features p=1 → [selection] feature=defect u=metro_firefox_user c=content_features p=1
Target Milestone: Firefox 24 → Firefox 23
thanks!
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e27ce27cd6e1
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Flags: needinfo?(jbecerra)
Tested on 2013-04-08 using a Nightly built from http://hg.mozilla.org/mozilla-central/rev/b0d842380959
- Double-clicking on text in content does not bring up the grippers.
- Reopening bug 848494 because text selection in input boxes isn't bringing up the grippers or monocle.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jbecerra)
Whiteboard: [selection] feature=defect u=metro_firefox_user c=content_features p=1 → [selection] feature=defect u=metro_firefox_user c=content_features p=1 status=verified
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.