java.lang.NoSuchMethodError: java.lang.String.getBytes at org.mozilla.gecko.ANRReporter.fillPingHeader(ANRReporter.java) on Froyo

RESOLVED FIXED in Firefox 22

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Assigned: jchen)

Tracking

(Blocks: 1 bug, {crash, regression})

22 Branch
Firefox 23
ARM
Android
crash, regression
Points:
---

Firefox Tracking Flags

(firefox21 unaffected, firefox22+ fixed, firefox23 fixed)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
It first showed up in 22.0a1/20130328. Here is a crash report: bp-689987de-585c-4f58-af37-b6f112130404.

java.lang.NoSuchMethodError: java.lang.String.getBytes
	at org.mozilla.gecko.ANRReporter.fillPingHeader(ANRReporter.java:316)
	at org.mozilla.gecko.ANRReporter.processTraces(ANRReporter.java:482)
	at org.mozilla.gecko.ANRReporter.processTraces(ANRReporter.java:522)
	at org.mozilla.gecko.ANRReporter.onReceive(ANRReporter.java:586)
	at android.app.ActivityThread$PackageInfo$ReceiverDispatcher$Args.run(ActivityThread.java:920)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:143)
	at org.mozilla.gecko.ANRReporter$1.run(ANRReporter.java:102)
	at java.lang.Thread.run(Thread.java:1096)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NoSuchMethodError%3A+java.lang.String.getBytes+at+org.mozilla.gecko.ANRReporter.fillPingHeader%28ANRReporter.java%29
Created attachment 734755 [details] [diff] [review]
Use String version of getBytes to accommodate Froyo (v1)

Froyo only has the String version of String.getBytes()
Attachment #734755 - Flags: review?(blassey.bugs)
Attachment #734755 - Flags: review?(blassey.bugs) → review+
(Reporter)

Updated

5 years ago
Summary: java.lang.NoSuchMethodError: java.lang.String.getBytes at org.mozilla.gecko.ANRReporter.fillPingHeader(ANRReporter.java) → java.lang.NoSuchMethodError: java.lang.String.getBytes at org.mozilla.gecko.ANRReporter.fillPingHeader(ANRReporter.java) on Froyo
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d5134b3cc6c
Assignee: nobody → nchen
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/4d5134b3cc6c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
(Reporter)

Updated

5 years ago
status-firefox23: affected → fixed
Comment on attachment 734755 [details] [diff] [review]
Use String version of getBytes to accommodate Froyo (v1)

[Approval Request Comment]

Bug caused by (feature/regressing bug #): N/A

User impact if declined: Crash when the App Not Responding dialog appears in Fennec

Testing completed (on m-c, etc.): Locally, m-c

Risk to taking this patch (and alternatives if risky): Very small; patch only fixes the crash case

String or IDL/UUID changes made by this patch: None
Attachment #734755 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Same question as https://bugzilla.mozilla.org/show_bug.cgi?id=858960#c5
tracking-firefox22: --- → ?
setting need-info, on jim to help with comment# 5.
Flags: needinfo?(nchen)
(In reply to Alex Keybl [:akeybl] from comment #5)
> Same question as https://bugzilla.mozilla.org/show_bug.cgi?id=858960#c5

From bug 858960,

(In reply to Alex Keybl [:akeybl] from comment #5)
> (In reply to Jim Chen [:jchen :nchen] from comment #4)
> > Bug caused by (feature/regressing bug #): N/A
> 
> Hard to believe this is n/a - 21 was unaffected.

Sorry, the crash was caused by the ANR feature introduced in 22 (tracking bug 833990) 

> > User impact if declined: Crash when the App Not Responding dialog appears in
> > Fennec
> 
> Have we confirmed that the crash volume fell off on Nightly? I don't see STR
> here that could have been verified.

There were only 2 crash reports before the fix landed, and none since then. This is difficult to reproduce because it requires Fennec hanging on Froyo devices, which is not a common scenario.

Thanks!
Blocks: 833990
Flags: needinfo?(nchen)

Updated

5 years ago
Attachment #734755 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
tracking-firefox22: ? → +
https://hg.mozilla.org/releases/mozilla-aurora/rev/2671c422e082
status-firefox22: affected → fixed
You need to log in before you can comment on or make changes to this bug.