Show general requests status in relation to onload and DOMContentLoaded events

RESOLVED DUPLICATE of bug 1353057

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1353057
6 years ago
10 months ago

People

(Reporter: vporof, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Something like "{$1} requests, {$2}kb transferred in {$3}s (onload: {$4}s, DOMContentLoaded: {$5}s)"
(Reporter)

Comment 1

6 years ago
Moving into Developer Tools: Netmonitor component. Filter on NETMONITORAMA.
Component: Developer Tools → Developer Tools: Netmonitor
Summary: [netmonitor] Show general requests status → Show general requests status
(Reporter)

Updated

6 years ago
Priority: -- → P3
(Reporter)

Updated

6 years ago
Priority: P3 → P2
(Reporter)

Updated

6 years ago
Duplicate of this bug: 865751
(Reporter)

Comment 3

6 years ago
Current implementation displays everything except onload and DOMContentLoaded markers. Updating the bug description accordingly.

Bug 859042 is about displaying this in the waterfall.
See Also: → 859042
Summary: Show general requests status → Show general requests status in relation to onload and DOMContentLoaded events
See Also: → 1226566

Comment 4

3 years ago
Chrome does this one better, see screenshot. And having DOMContentLoaded string in blue and Load in red also means that it's easier to understand what the blue and read lines are about (what's also the problem of bug 1226566).

Comment 5

3 years ago
Very often I use the netmonitor when looking at Caching issues. Just for quickly checking if caching (browser cache) works. Hence the total 'Transferred' vs. the total 'Size' would be of interest, same for total number of requests transferred vs. served from cached. 

At the moment the whole size and all requests are show, although what's actually transferred is of much more interest.

So looking at Comment 0 I would propose:

{$1} requests ({$2} transferred, {$3} from cache}), {$4}kb ({$5}kb transferred, {$6}kb from cache) in {$7}s (DOMContentLoaded: {$8}s, Load: {$9}s)

where $2 + $3 = $1 
and  $5 + $6 = $4

Also "DOMContentLoaded" should be listed before "Load" because it's triggered earlier.

This very quickly allows to see if caching methods (e.g. cache all images in browser cache etc. are effective).

This information should also make it into the "performance analysis" which opens when clicking there. 

And it should collapse to "{$1} requests ... Load: {$9}s)" in case there's not enough horizontal space while still showing the whole string as mouseover tooltip.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1353057

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.