Closed Bug 859218 Opened 7 years ago Closed 7 years ago

[MMS] The received MMS message is shown as empty message

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 845173
1.1 QE1 (5may)
blocking-b2g leo+

People

(Reporter: sasikala.paruchuri8, Unassigned)

Details

(Whiteboard: [TD-8973] [NO_UPLIFT])

1. Title : The received MMS message is shown as empty message in Thread.
2. Precondition : Messageing app should be working.
3. Tester's Action : Receive an MMS message 
4. Detailed Symptom (ENG.): The received MMS message is shown as empty message.
5. Expected : The received MMS message should not be shown as empty message.
6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Revision: 8e7262e3d98ea9574d7f79c1e890ad80cfa40c27
blocking-b2g: --- → leo?
Joe - do you think this is an issue found in the middle of landing MMS? Adding regressionwindow-wanted if this reproduces for QA.
blocking-b2g: leo? → leo+
Flags: needinfo?(jcheng)
Whiteboard: [TD-8973]
Assignee: nobody → kchang
Gene, I think this bug has same root cause with bug 860693. Assign to you.
Assignee: kchang → gene.lian
Whiteboard: [TD-8973] → [TD-8973] [NO_UPLIFT]
Actually, it's not. There is no MMS handling code in Gaia at all. Of course the MMS message is shown as empty message because it's not a SMS message.
Assignee: gene.lian → nobody
I was able to reproduce this issue, the Unagi device displays an empty message when an MMS is received.

Unagi Build ID: 20130412070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/950db80b82cb
Gaia: 54ab4ce3f9107d1624c18bed2a09ace6bbc6601f

However, AFAIK, MMS features are not implemented
MMS feature is not landed yet, we should revisit this once it happens. 
Clearing ni?jcheng
Flags: needinfo?(jcheng)
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
But we should ensure that receiving a MMS on a non-MMS-enabled phone (ie: 1.0.1 phone) does not show an empty message. I wonder if we could send a SMS message explaining how to see this MMS (I know I've seen that on other phones already). I don't know how difficult this could be though.

Sharaf told me he tested this on v1.1 and we have no MMS code at all on v1.1 yet.
Paul, could you please test this on v1.0.1 with both Mozilla RIL and Commercial RIL ?
Flags: needinfo?(pyang)
Keywords: qawanted
Julien, I believe the scenario you mentioned is not a phone feature, but rather the operator does this to phones/SIMs that are recognized by the network as non-MMS enabled.

>  I wonder if we could send a SMS
> message explaining how to see this MMS (I know I've seen that on other
> phones already). I don't know how difficult this could be though.


MMS is not on v1.1 yet, but it should be eventually. I think we should only do further work on this bug once the landings for MMS have happened.

> Sharaf told me he tested this on v1.1 and we have no MMS code at all on v1.1
> yet.
Target Milestone: --- → Leo QE1 (5may)
Julien:
I've tried reproduced steps on both latest v1.0.1 RIL and commercial RIL, unagi
message app doesn't show any incoming MMS message at all.
Flags: needinfo?(pyang)
Keywords: qawanted
Without bug 845173, there won't be anything in a MMS bubble. I thought it's a Gecko problem, but it's not.
No longer blocks: b2g-mms
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Component: DOM: Device Interfaces → Gaia::SMS
Product: Core → Boot2Gecko
Resolution: --- → DUPLICATE
Duplicate of bug: 845173
You need to log in before you can comment on or make changes to this bug.