FN and SHIFT keys not working on Desire Z

RESOLVED FIXED in Firefox 23

Status

()

defect
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: jchen, Assigned: jchen)

Tracking

({regression})

unspecified
Firefox 23
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

From Bug 685537 comment 49:

It's appear again 2 update ago.

The FN and SHIFT keys works in address bar but not in website form.

If in a website form I press sym key to show special characters and press back (soft touch key) then the FH/SHIFT keys work
.
If I select another form, also in the same page FN key or Shift key doesn't work again.
Good build: 01.11.2012
Bad build:  02.11.2012
Pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5bd5bb168eb1&tochange=556b9cfb269f	

The tinderbox inbound builds are missing since the issue is older than one month.
Bug 805162 stands out like a sore thumb.
Blocks: 805162
Duplicate of this bug: 859703
(In reply to Teodora Vermesan (:TeoVermesan) from comment #1)
> Good build: 01.11.2012
> Bad build:  02.11.2012
> Pushlog: 
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=5bd5bb168eb1&tochange=556b9cfb269f	
> 
> The tinderbox inbound builds are missing since the issue is older than one
> month.

Hi Teodora, since you have a Desire Z, can you get the logcat of this Nightly while trying to use Fn and Shift keys? Thank you!

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/nchen@mozilla.com-bef374b207fd/try-android/fennec-23.0a1.en-US.android-arm.apk
Flags: needinfo?(teodora.vermesan)
Posted file Logs
I saved the logs while I was reproducing the bug. Please let me know if you need additional info regarding this bug.
Flags: needinfo?(teodora.vermesan)
(In reply to Teodora Vermesan (:TeoVermesan) from comment #5)
> Created attachment 735668 [details]
> Logs
> 
> I saved the logs while I was reproducing the bug. Please let me know if you
> need additional info regarding this bug.

Can you get the logs using the Nightly in comment 4? It has more logging than a normal Nightly.

Thanks!
Flags: needinfo?(teodora.vermesan)
Posted file Log
I've attached the logs with the given build. Please let me know if you need another information regarding this.
Flags: needinfo?(teodora.vermesan)
(In reply to Teodora Vermesan (:TeoVermesan) from comment #7)
> Created attachment 735750 [details]
> Log
> 
> I've attached the logs with the given build. Please let me know if you need
> another information regarding this.

Thank you! That was very useful. Can you try again using this build?

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/nchen@mozilla.com-0e920791009e/try-android/fennec-23.0a1.en-US.android-arm.apk
Flags: needinfo?(teodora.vermesan)
I'm not able to reproduce the bug on the given build, but I'm able to reproduce it on the latest Nightly(2013-04-10). Please let me know if I can I try using another build.
Flags: needinfo?(teodora.vermesan)
HTC Touch Input has the weird (and IMO wrong) behavior that, even if meta keys are pressed, the IME will call InputConnection.commitText() with the base character (i.e. without meta keys applied). In that case we have to convert the character back to a key event and let the TextKeyListener take care of applying meta keys.
Attachment #738533 - Flags: review?(cpeterson)
Comment on attachment 738533 [details] [diff] [review]
Send characters as keys when using HTC Touch Input (v1)

Review of attachment 738533 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!

::: mobile/android/base/GeckoInputConnection.java
@@ +637,5 @@
> +        if (InputMethods.shouldCommitCharAsKey(mCurrentInputMethod) &&
> +            text.length() == 1 && newCursorPosition > 0) {
> +            // mPluginInputConnection is a BaseInputConnection that commits text as keys;
> +            // here we are borrowing its ability to send keys
> +            return mPluginInputConnection.commitText(text, newCursorPosition);

As we discussed in IRC, let's rename mPluginInputConnection to something related to sending key events instead of IME events, such as mKeyInputConnection or mKeyEventInputConnection.
Attachment #738533 - Flags: review?(cpeterson) → review+
Attachment #738533 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/a520eb3b34ae
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Depends on: 864666
You need to log in before you can comment on or make changes to this bug.