Work - Auto-complete data quickly appearing/disappearing when selected from another text area

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: kjozwiak, Assigned: sfoster)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [forms] feature=work)

(Reporter)

Description

6 years ago
When you have several text area's with auto-complete information stored in them, tapping between them will quickly show the auto-complete box and then it will disappear (this happens very quickly and it can be easy to miss)

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to http://autofillforms.mozdev.org/test.html
3) Fill something in both the "Username" and "E-Mail" text area's
4) Select "Submit" at the bottom of the page
5) Once the data has been cleared, tap on "Username" and you should see the data that you entered in the auto-complete box
6) Once the auto-complete data is being displayed for "Username", tap on "E-Mail". (You will notice the auto-complete box will quickly flash and then disappear)
7) Tap on the "E-Mail" again and it should display the auto-complete box with your data that has been inserted previously
8) Tap on "Username" and you will notice it will quickly appear and then disappear (Same as Step # 6)

Defect - Auto-complete data quickly appearing/disappearing when selected from another text area

Current Behavior:

- When tapping between two text area's you will notice that the auto-complete data will quickly appear and then disappear

Expected Behavior:

- When tapping on text area's, the auto-complete data should appear and not disappear instantly
(Reporter)

Comment 1

6 years ago
consideration for Iteration #6
Flags: needinfo?(mmucci)
For consideration in upcoming iterations.
Blocks: 859003
No longer blocks: 855905
Flags: needinfo?(mmucci)
QA Contact: jbecerra

Updated

6 years ago
Whiteboard: feature=defect c=Content_features u=metro_firefox_user p=0 → [forms] feature=defect c=Content_features u=metro_firefox_user p=0

Updated

6 years ago
Depends on: 861853

Updated

6 years ago
No longer depends on: 861853

Updated

6 years ago
Blocks: 861853
p=2

Updated

6 years ago
Blocks: 855434

Updated

6 years ago
Priority: -- → P3

Updated

6 years ago
No longer blocks: 859003
Summary: Defect - Auto-complete data quickly appearing/disappearing when selected from another text area → Work - Auto-complete data quickly appearing/disappearing when selected from another text area
Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=0 → [forms] feature=work

Updated

6 years ago
No longer blocks: 801121, 861853
(Assignee)

Comment 4

5 years ago
Yeah it looks like the auto-complete container is shown and then populated. It is fractions of a second, but you can see whatever was in there last time it was shown before it gets replaced. We could populate and then show, or maybe better, show the container with contents set visibility:none or opacity:0 (at whatever its current dimensions are) then populate, fade in and resize once we have that data.
(Assignee)

Comment 5

5 years ago
I can't reproduce this today on my X1 Carbon. Possibly fixed by Bug 919232? Updating the lower-spec dell tablet to confirm though...
Assignee: nobody → sfoster
(Assignee)

Comment 6

5 years ago
I think this was fixed along the way, at least I can't reproduce any more with the given STR.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

5 years ago
Went through this with the latest build and couldn't reproduce it either, used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-11-10-03-02-05-mozilla-central/

- Went through the original test case from comment #0 without any issues
- Filled out a lot more fields then just email & username and went back and forth between them without seeing the issue

I did however run into a few other issues that are not related to this ticket. Will create new issues if there's none already created.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.