Defect - arrow keys not working in form autofill popup

VERIFIED FIXED in Firefox 28

Status

Firefox for Metro
General
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: motiosnv22, Assigned: rsilveira)

Tracking

unspecified
Firefox 28
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [block28] feature=defect c=tbd u=tbd p=3)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130921004001

Steps to reproduce:

Went to site for login
Typed in my username which i had logged in with on earlier
Username appeared in context menu after first letters
Cannot use arrows to select name (menu disappears)

When right clicking on highlighted text/a link, the context menu also disappears with usage of arrows


Actual results:

Context menu disappears


Expected results:

The arrows should have made an option highlighted/changed which option was highlighted
(Reporter)

Updated

4 years ago
Version: 26 Branch → unspecified

Updated

4 years ago
Blocks: 838081
Summary: context menu arrows not working → Defect - context menu arrows not working
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0
Summary: Defect - context menu arrows not working → Defect - arrow keys not working in form autofill popup
Tested on 2013-09-30 using the latest nightly, and I can confirm that you cannot use the arrow keys to go through the form autofill list.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 924148

Updated

4 years ago
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0

Updated

4 years ago
Assignee: nobody → rsilveira
Blocks: 925788
No longer blocks: 838081
Status: NEW → ASSIGNED
QA Contact: jbecerra
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=3

Updated

4 years ago
Priority: -- → P2
Created attachment 822580 [details] [diff] [review]
919232.patch

Fixed keyboard navigation for autofill and dropdown menus.
Attachment #822580 - Flags: review?(mbrubeck)

Updated

4 years ago
Whiteboard: feature=defect c=tbd u=tbd p=3 → [block28] feature=defect c=tbd u=tbd p=3

Updated

4 years ago
Blocks: 931976
No longer blocks: 925788
Attachment #822580 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/integration/fx-team/rev/602cf7b9f336

Updated

4 years ago
Depends on: 927238

Comment 5

4 years ago
https://hg.mozilla.org/mozilla-central/rev/602cf7b9f336
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Mozilla/5.0 (Windows NT 6.2; rv:28.0) Gecko/20100101 Firefox/28.0
Build ID: 20131114030204

This issue is just partially fixed, I still encounter the following issue:

- right clicking on highlighted text/link, the context menu will disappear if using arrows
Hi Cornel, can you file a separate bug for the issue you are encountering.  Thanks.
Flags: needinfo?(cornel.ionce)
Marking this as verified as I have logged bug 939705 for the remaining issue.
Thank you!
Status: RESOLVED → VERIFIED
Flags: needinfo?(cornel.ionce)
Depends on: 950075
No longer depends on: 950075
You need to log in before you can comment on or make changes to this bug.