Closed Bug 860524 Opened 7 years ago Closed 7 years ago

Regression painting some gaia controls

Categories

(Core :: Layout: Form Controls, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla23

People

(Reporter: fabrice, Assigned: roc)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image gaia toggle
I'm not sure which CSS is used there, but what was nice rounded corners are now more square.
Attached image gaia checkbox
They look fine, but should be circles...
mask layers regression? I'll look into this once I've finished the Android bug I'm looking at...
Assignee: nobody → ncameron
(In reply to Jeff Muizelaar [:jrmuizel] from comment #3)
> This also happens on OS X nightly:
> http://buildingfirefoxos.com/building-blocks/switches/

and also on linux nightly for the switches (but the checkboxes and radio buttons are ok).
I can also reproduce this in a Nightly from 8th before the layers refactoring.
No longer blocks: layers-refactoring
Good: http://hg.mozilla.org/mozilla-central/rev/905671d954c5
Bad: http://hg.mozilla.org/mozilla-central/rev/1e958f7224a7

I blame bug 841192, and this is logically feasible because this looks like a rounded rect clipping issue (see comment 2, although it turns out this is a layout, not mask layers issue).
Blocks: 841192
Component: Graphics: Layers → Layout: Form Controls
Assignee: ncameron → roc
Attached patch fixSplinter Review
Attachment #737356 - Flags: review?(matt.woodrow)
Attachment #737356 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/d13fc07e67af
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Depends on: 868187
You need to log in before you can comment on or make changes to this bug.