Closed Bug 862025 Opened 8 years ago Closed 8 years ago

Defect - Dragging a text input selection monocle downward can cause selection to reverse

Categories

(Firefox for Metro Graveyard :: Input, defect, P1)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 23

People

(Reporter: jimm, Assigned: jimm)

References

Details

(Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=2 status=verified)

Attachments

(2 files)

Attached file testcase
STR:

1) tap in the text input
2) drag left or right to select some text
3) drag right-hand monocle to the right for a bit
4) drag same monocle left and down

result: about ~75px below the edit, the selection (which is contracting to the left) will start advancing to the right.
Summary: Dragging a text input selection monocle downward can cause selection to reverse → Defect - Dragging a text input selection monocle downward can cause selection to reverse
Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=0
Attached patch fixSplinter Review
Assignee: nobody → jmathies
Attachment #737909 - Flags: review?(netzen)
Attachment #737909 - Flags: review?(netzen) → review+
Hey Jim.  Looks like this is ready for Iteration #6.  Can you provide a point estimate.
Flags: needinfo?(jmathies)
Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=0 → [forms] feature=defect c=Content_features u=metro_firefox_user p=1
Blocks: metrov1it6
No longer blocks: metrov1defect&change
Point Estimate = 1
Blocks: metrov1defect&change
No longer blocks: metrov1it6
Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=1 → [forms] feature=defect c=Content_features u=metro_firefox_user p=0
Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=0 → [forms] feature=defect c=Content_features u=metro_firefox_user p=1
Flags: needinfo?(jmathies)
Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=1 → [forms] feature=defect c=Content_features u=metro_firefox_user p=0
Blocks: metrov1it6
No longer blocks: metrov1defect&change
Priority: -- → P1
QA Contact: jbecerra
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/cf09749bb5b1
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
For Raymond to test and verify.
Flags: needinfo?(mozbugs.retornam)
I can reproduce  the defect using the  steps in comment 0 on today's build. 
http://hg.mozilla.org/mozilla-central/rev/64d6d002e888 (2013-04-19). I'm re-opening this bug.
Status: RESOLVED → REOPENED
Flags: needinfo?(mozbugs.retornam)
Resolution: FIXED → ---
(In reply to raymond [:retornam] from comment #8)
> I can reproduce  the defect using the  steps in comment 0 on today's build. 
> http://hg.mozilla.org/mozilla-central/rev/64d6d002e888 (2013-04-19). I'm
> re-opening this bug.

Hmm, I'm not able to. In the attached testcase, I can drag the monocle anywhere down the page and the selection boundary stays parallel to where the drag point is.
This seems to be fixed for me as well. Testing on today's nightly build on my Aspire S7 13" in fill and full screen views.
For Kamil to confirm results - please see comments #8 - #10 for background.
Flags: needinfo?(kamiljoz)
I cannot reproduce this problem on the latest nightly, but I am experiencing problems dragging the monocles or having them show when I drag up or down. I will file a follow up bug.
This is fixed on http://hg.mozilla.org/mozilla-central/rev/50d25e083421 ( 2013-04-22)
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Flags: needinfo?(kamiljoz)
Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=0 → [forms] feature=defect c=Content_features u=metro_firefox_user p=2
For Virgil to test and verify.
Flags: needinfo?(virgil.dicu)
I won't be able to verify this, as I don't have access to a Win8 tablet. Adding Juan.
Flags: needinfo?(virgil.dicu) → needinfo?(jbecerra)
Tested on 2013-04-24 using a nightly built from http://hg.mozilla.org/mozilla-central/rev/fef5f202b2dc
- Tested with steps on comment #0 and that seems to work now, when the text selection works.
- Filing a follow up bug that relates to how it's very difficult to select the text you intend to in the field: Bug 865356
- I'm verifying the original story because I don't see reverse selection due to dragging of the monocles, but it may need to be re-opened because the defect I filed is closely related.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jbecerra)
Whiteboard: [forms] feature=defect c=Content_features u=metro_firefox_user p=2 → [forms] feature=defect c=Content_features u=metro_firefox_user p=2 status=verified
Depends on: 865356
Blocks: 831985
No longer blocks: 862162
Verified for it8
Went through the following "Defect" for iteration #9 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-07-10-03-02-05-mozilla-central/

- Went through the original test case from comment 0 without any issues
- Watched the video from comment 1 to see the issue and ensure its not occurring
- Dragged the monocles back and forth and everything worked without any issues
- Went through the test cases in "Filled" view and ensured that worked without any issues
I went through this for iteration #10 and I didn't see any problems. I used the test cases in comment #18. I tried this on a couple of machines.
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130807030216
Built from http://hg.mozilla.org/mozilla-central/rev/1fb5d14e8348

WFM
Tested on windows 8 using latest nightly for iteration-11. Followed steps provided in comment 0 and 18,and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130826074752
Built from http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.