Closed Bug 831985 Opened 7 years ago Closed 7 years ago

Story - Touch Text Selection in Content

Categories

(Tracking Graveyard :: Metro Operations, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: asa, Assigned: jimm)

References

Details

(Whiteboard: feature=story c=Content_features u=metro_firefox_user p=8)

Attachments

(1 file)

No description provided.
Priority: -- → P2
Whiteboard: c=Content_features u= p= → c=Content_features u=metro_firefox_user p=
Whiteboard: c=Content_features u=metro_firefox_user p= → c=Content_features u=metro_firefox_user p=8
Assignee: nobody → jmathies
OS: Windows 8 → Windows 8 Metro
Summary: Touch text selection in content → Story - Touch Text Selection in Content
Whiteboard: c=Content_features u=metro_firefox_user p=8 → feature=story status=for_sprint c=Content_features u=metro_firefox_user p=8
Status: NEW → ASSIGNED
Depends on: 788000
No longer depends on: 788000
Depends on: 781487
Blocks: metrov1it1
Depends on: 834370
Depends on: 832957
No longer blocks: metrov1it1
Whiteboard: feature=story status=for_sprint c=Content_features u=metro_firefox_user p=8 → feature=story c=Content_features u=metro_firefox_user p=8
Blocks: metrov1it2
No longer blocks: metrov1backlog
Depends on: 782679
Depends on: 843014
Blocks: 831952
Blocks: metrov1backlog
No longer blocks: metrov1it2
No longer blocks: metrov1backlog
Depends on: 845122
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
No longer depends on: 845122
Blocks: metrov1it3
No longer blocks: metrov1backlog
Depends on: 846685
this should be held up by tests landing.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jbecerra)
Resolution: --- → FIXED
(In reply to Jim Mathies [:jimm] from comment #1)
> this should be held up by tests landing.

s/should/shoudn't
Tested on 2013-03-05 using a Nightly built from http://hg.mozilla.org/mozilla-central/rev/015da7030aab

- Note: It would be nice to be able to tap once on a word to select text, like in IE. Instead I have to long-tap and release, but that is as specified in the story.
- Tested text selection using plain text, long-tapping on words, expanding the grippers, sharing the selected text. This scenario works.
- Tested trying to select text from links. I was not able to do this. On IE I can. After dismissing the context menu the grippers appear.
- Tested trying to select text within text boxes. Here you need to double tap to get the grippers. On IE you only need to tap once to get the grippers.

I need clarification from Asa to make sure the above is OK.

You can use the following to compare plain text selection, link text selection, and text box text selection:

http://techslides.com/sample-webm-ogg-and-mp4-video-files-for-html5/
Flags: needinfo?(jbecerra) → needinfo?(asa)
Text inputs are currently working more like content text. There's a separate story on context behavior for those and also a bug on getting caret selection working in text inputs - bug 845122.
Juan, I think you can verify this one. Can you file bugs on single tap word selection and link text selection? Neither of those are high priorities for v1 but I'd like to have them on file for things we look into in v2.
Flags: needinfo?(asa)
Depends on: 845122
See Also: → 850348
Verifying and filing two bugs for single tap word selection and link text selection:

* https://bugzilla.mozilla.org/show_bug.cgi?id=850348
* https://bugzilla.mozilla.org/show_bug.cgi?id=850354
Status: RESOLVED → VERIFIED
Depends on: 850348
Depends on: 850354
Depends on: 850398
No longer depends on: 850348
No longer depends on: 850354
No longer depends on: 845122
Depends on: 859175
Found a "Defect" that is related to the following story when going through it4 testing. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-07-03-08-41-mozilla-central/

- Attached the "Defect" to this ticket.
Depends on: 865093
Duplicate of this bug: 862162
Verified for it7.

Reproduced bug 860248.
Reproduced bug 865093.
Reproduced bug 872620.
Went through the following "Story" for iteration #8 testing with some issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-17-03-11-12-mozilla-central/

- Went through the original "Story" that has been attached above without any issues
- Ran into several issues when tapping and selecting text, monocles appeared laggy, not clearing, jumped all around the place etc.. These issues have already tickets created for them

Notes:

- Reproduced Bug 860248 while going through iteration #8
- Reproduced Bug 865093 while going through iteration #8
- Reproduced Bug 872620 while going through iteration #8
User Agent:Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:25.0) Gecko/20130724 Firefox/25.0
Build ID: 20130724030204

WFM.

Tested on Windows 8.1 preview for iteration 10 using latest nightly from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-24-03-02-04-mozilla-central/

I followed user story and got expected result.
Depends on: 888521
Depends on: 896022
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130808030205
Built from http://hg.mozilla.org/mozilla-central/rev/fd4cf30428b0

WFM
Tested on windows 8 using latest nightly  for iteration-11. Followed steps provided in user story and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130825030201
Built from http://hg.mozilla.org/mozilla-central/rev/01576441bdc6

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in user story  and got expected result.
No longer depends on: 888521
No longer depends on: 864457
No longer depends on: 872620
Depends on: 960886
Depends on: 960889
OS: Windows 8 Metro → Windows 8.1
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.