Update SeaMonkey installer package-manifest.in

RESOLVED FIXED in seamonkey2.20

Status

SeaMonkey
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Tracking

Trunk
seamonkey2.20
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.19 fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
The package-manifest.in file in suite/installer/package-manifest.in is currently not up-to-date. A few changes need to be ported to fix test errors (and possibly other problems, too?).
(Assignee)

Comment 1

5 years ago
Created attachment 738396 [details] [diff] [review]
Patch

This patch fixes a few bugs (adds/removes files from those bugs):
Bug 859601 Proper implementation when mozContacts API is not implemented
Bug 525444 SpeechSynthesis files (#ifdef MOZ_WEBSPEECH)
Bug 648407 Allow folding of NSPR, NSS and sqlite library (should be considered for SeaMonkey, too)
(Assignee)

Comment 2

5 years ago
Created attachment 738402 [details] [diff] [review]
Patch v2

Added Bug 767944 (quota handling of integrated storage)
Attachment #738396 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Blocks: 858639
(Assignee)

Comment 3

5 years ago
Landed patch as bustage fix (after all I think quite a few tests are broken by missing files): https://hg.mozilla.org/comm-central/rev/56d6207a6bf5 I also included the dom_gamepad.xpt change from Bug 858639

Comment 4

5 years ago
Other possible packaging:

Package captivedetect.xpt
(From Bug 752982 - Part 1, implement captive portal detection service)

Bug 604039 - Add DOM Gamepad APIs

Bug 854468 - Part 2: Package command line recording code

Include AppProtocolHandler in desktop Firefox packages (bug 850421)
This allows the JavaScript debugger to properly present script URLs when remotely debugging Firefox OS.

... optional? ...
Bug 808219 - Firefox Health Reporter service
Bug 828829 - Refactor Health Report policy out of services/healthreport.
Bug 830626 - Add HealthReportComponents.manifest to package manifest.

Package PageThumbs.jsm (from  Bug 811548 - Move PageThumbs.jsm)

Comment 5

5 years ago
Comment on attachment 738402 [details] [diff] [review]
Patch v2

rs=me :P
Attachment #738402 - Flags: review+

Updated

5 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → seamonkey2.20
(Assignee)

Comment 6

5 years ago
Created attachment 739312 [details] [diff] [review]
comm-aurora version of Patch

[Approval Request Comment]
Regression caused by (bug #): Various new files added by mozilla-central
User impact if declined: Broken tests on comm-aurora tree, possibly also broken interfaces (as in code interfaces)
Testing completed (on m-c, etc.): More tests pass than before
Risk to taking this patch (and alternatives if risky): I think rather low risk, but hard to tell
String changes made by this patch: -
Attachment #739312 - Flags: review+
Attachment #739312 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #739312 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 7

5 years ago
Actually we would also need to port the MOZ_GAMEPAD configure.in changes to comm-aurora, too :/ (was not required for comm-central as the comm-central configure.in system fixed this via Bug 846540).
(Assignee)

Updated

5 years ago
Depends on: 863672
(Assignee)

Comment 8

5 years ago
(In reply to Philip Chee from comment #4)
> Package PageThumbs.jsm (from  Bug 811548 - Move PageThumbs.jsm)

For reference: PageThumbs.jsm is in modules/, that directory already gets packaged. What does net get packaged is PageThumbsProtocol.js and BrowserPageThumbs.manifest. Currently a few page thumb tests fail, but that is because the heads.js file for these tests imports a Firefox-only file:
Cu.import("resource:///modules/sessionstore/SessionStore.jsm", tmp);
(Assignee)

Comment 9

5 years ago
Comment on attachment 739312 [details] [diff] [review]
comm-aurora version of Patch

Pushed to comm-aurora: https://hg.mozilla.org/releases/comm-aurora/rev/35b2907e98c3
(Assignee)

Updated

5 years ago
status-seamonkey2.19: --- → fixed
(Assignee)

Comment 10

5 years ago
Created attachment 747321 [details] [diff] [review]
comm-aurora patch, part 2

It turned out dom_webspeech.xpt was missing in the aurora patch, on comm-central dom_webspeech.xpt does not exist anymore, it has another name there. And in Bug 863672 I actually ported the MOZ_WEBSPEECH configure.in changes for this patch... landing this with original review and approval as it basically should have belonged to that patch :)
(Assignee)

Comment 11

5 years ago
Comment on attachment 747321 [details] [diff] [review]
comm-aurora patch, part 2

Pushed: https://hg.mozilla.org/releases/comm-aurora/rev/6f3e04b408ba
Attachment #747321 - Attachment is patch: true
(In reply to Frank Wein [:mcsmurf] from comment #2)
> Created attachment 738402 [details] [diff] [review]
> Patch v2

Isn't this patch missing its related part in
http://mxr.mozilla.org/comm-central/source/suite/installer/removed-files.in
?
Component: Installer → Build Config
Flags: needinfo?(bugzilla)
(Assignee)

Comment 13

5 years ago
Only when we decide to actually define MOZ_FOLD_LIBS... ;) good catch, I forgot about that. I'll write a patch to fix this. And also file a bug to possibly define this then if everything is working.
Flags: needinfo?(bugzilla)
(Assignee)

Comment 14

5 years ago
Created attachment 795194 [details] [diff] [review]
Fix removed-files.in
Attachment #795194 - Flags: review+
(Assignee)

Comment 16

5 years ago
Closing this bug now, if other package issues appear, we can open new bugs for this (I won't this to become some kind of meta-bug :).
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Attachment #795194 - Attachment description: Fix removes-files.in → Fix removed-files.in
Comment on attachment 795194 [details] [diff] [review]
Fix removed-files.in

Review of attachment 795194 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, and NavigatorPropertyHelper.js should be added to MOZ_OMNIJAR case.

::: suite/installer/removed-files.in
@@ +325,5 @@
> +@DLL_PREFIX@plc4@DLL_SUFFIX@
> +@DLL_PREFIX@ssl3@DLL_SUFFIX@
> +@DLL_PREFIX@smime3@DLL_SUFFIX@
> +@DLL_PREFIX@nssutil3@DLL_SUFFIX@
> +@DLL_PREFIX@mozsqlite3@DLL_SUFFIX@

Nit: I would have liked them to be alpha. sorted. Next time...
Attachment #795194 - Flags: feedback-
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 18

5 years ago
Serge: At least my opinion here is that installer manifest/removed-files.in only needs to support the default build config as used by the releases. And in this case there is no need to add NavigatorPropertyHelper.js to the removed-files.in as we build with omnijar for quite some time now. So I'm calling this fixed.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.