Last Comment Bug 862917 - Remove window.defaultStatus
: Remove window.defaultStatus
Status: RESOLVED FIXED
: dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla23
Assigned To: Boris Zbarsky [:bz] (TPAC)
:
Mentors:
Depends on:
Blocks: 864256
  Show dependency treegraph
 
Reported: 2013-04-17 09:53 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2013-05-17 14:00 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove the non-standard window.defaultStatus and the propagation of window.status values to the UI. (8.79 KB, patch)
2013-04-17 22:16 PDT, Boris Zbarsky [:bz] (TPAC)
no flags Details | Diff | Splinter Review
Remove the non-standard window.defaultStatus. (8.74 KB, patch)
2013-04-17 22:18 PDT, Boris Zbarsky [:bz] (TPAC)
bugs: review+
gavin.sharp: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2013-04-17 09:53:15 PDT
Setting them has had no effect in Firefox since the aviary days (dom.disable_window_status_change has been true). Recently, the Firefox UI dropped support for enabling that pref (bug 842017).

These attributes aren't specified in HTML5, so we should just completely remove support for the feature from the DOM (and simplify the relevant nsIWebBrowserChrome2/nsIXULBrowserWindow APIs and client implementations).
Comment 1 Olli Pettay [:smaug] (TPAC) 2013-04-17 09:57:05 PDT
I'd rather just make these no-ops. window.status has been mentioned in many docs, so removing would
probably lead to some obscure problem in some page.
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-04-17 13:33:55 PDT
What kind of compat problems do you foresee? Since it's just a simple property I'm not really sure what kind of issues removing it could cause. Unqualified references to "status"?
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-04-17 13:37:29 PDT
Oh, I was wrong about window.status not being specced:
http://www.whatwg.org/specs/web-apps/current-work/multipage/browsers.html#dom-window-status

That seems like a fine compromise.
Comment 4 Boris Zbarsky [:bz] (TPAC) 2013-04-17 22:16:25 PDT
Created attachment 738895 [details] [diff] [review]
Remove the non-standard window.defaultStatus and the propagation of window.status values to the UI.
Comment 5 Boris Zbarsky [:bz] (TPAC) 2013-04-17 22:18:07 PDT
Created attachment 738897 [details] [diff] [review]
Remove the non-standard window.defaultStatus.
Comment 6 Boris Zbarsky [:bz] (TPAC) 2013-04-17 22:21:09 PDT
I didn't change the guts of .status because there are Gecko-based apps that in fact have UI for it...  The decision to drop it should probably have somewhat more public input than this bug.
Comment 7 Olli Pettay [:smaug] (TPAC) 2013-04-18 05:22:03 PDT
Comment on attachment 738897 [details] [diff] [review]
Remove the non-standard window.defaultStatus.

Tiny bit scary. I guess we can try and put back dummy .defaultStatus if 
there are problems.
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-04-18 10:11:42 PDT
(In reply to Boris Zbarsky (:bz) from comment #6)
> I didn't change the guts of .status because there are Gecko-based apps that
> in fact have UI for it...  The decision to drop it should probably have
> somewhat more public input than this bug.

What apps? We can CC a SeaMonkey representative to a bug, I don't see this needing much more input than that given the state of the feature.
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-04-18 10:26:22 PDT
Now I filed bug 863339 :) I'll propose a patch on top of these ones.
Comment 10 Boris Zbarsky [:bz] (TPAC) 2013-04-18 12:21:55 PDT
SeaMonkey was the obvious one, yes.
Comment 11 Boris Zbarsky [:bz] (TPAC) 2013-04-19 20:05:50 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/fc6404ba7c74
Comment 12 Phil Ringnalda (:philor) 2013-04-21 09:38:13 PDT
https://hg.mozilla.org/mozilla-central/rev/fc6404ba7c74
Comment 13 Kohei Yoshino [:kohei] 2013-05-17 13:12:56 PDT
I've added this bug to the compatibility doc. Please correct the info if wrong.
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_23

Note You need to log in before you can comment on or make changes to this bug.