Closed Bug 864478 Opened 8 years ago Closed 8 years ago

[Mac] Unable to upload receipt to our Health and Wellness provider

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox20 --- unaffected
firefox21 - unaffected
firefox22 + fixed
firefox23 --- fixed

People

(Reporter: potch, Assigned: mounir)

References

Details

(Keywords: qawanted, regression, Whiteboard: [fixed by bug 52500])

Haven't gotten to pinpoint the issue quite yet, not sure whose side the issue is on.

STR:
https://enrollonline.com/mozilla
Sign in, Click on "Spending Account Activity"
Click "File Claim", then "Upload Receipt"
When you click "Browse" to select a file, nothing happens.

Following these STR in Release (20) works fine. Saw no errors in the logs to suggest anything fishy, confirmed in a clean profile.
WFM in nightly on Linux x86_64:
  Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20130422 Firefox/23.0
("Browse" button spawns a file-picker)

What version did it not work in?
Flags: needinfo?(thepotch)
Just tried it (and failed) with vanilla 23.0a1 (2013-04-20) on Mac.
Flags: needinfo?(thepotch)
And with a fresh copy of Beta, it works fine. Seems like something in Aurora.
Perhaps the re-styling of <input type="file"> (#838675) has something to do with it?
[Sounds like it may be mac-only, then, given comment 1 vs. comment 2. Setting affected flag to indicate that this affects nightly]

potch: if you're up for some hunting it, https://github.com/mozilla/mozregression is a handy & fun way to track down exactly when this regressed.

(If you make an empty directory somewhere and run mozregression with "-p /path/to/that/directory", then it'll re-use that directory as your profile throughout the regression-tracking process, which will prevent you from having to re-authenticate each time.)
Version: unspecified → Trunk
(In reply to Daniel Holbert [:dholbert] from comment #5)
> potch: if you're up for some hunting it,

er "up for some regression hunting"
Hmm.  I can definitely reproduce on Mac.

Potch, if you don't get a chance to hunt the nightly regression range down, let me know and I can do it?
QA can likely get to this before potch/bz :)

Juan - do you have access?
Keywords: qawanted
QA Contact: jbecerra
Summary: Unable to upload receipt to our Health and Wellness provider → [Mac] Unable to upload receipt to our Health and Wellness provider
21 isn't affected per c3
Still trying to get credentials for the site (which I have never used) in order to follow the steps to reproduce to find the regression range.
It started happening between 3-27 and 3-28 on nightly 22: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=178a4a770bb1&tochange=962f5293f87f

There are several bug fixes that got merged from inbound on that day which seem suspicious, for example:

https://bugzilla.mozilla.org/show_bug.cgi?id=838695
Yup, seems very likely to be from one of Mounir's nsFileControlFrame-related changes that were merged that day -- i.e. something from this inbound push:
 https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=ed73c79342be

Mounir, any chance you can dig into this?
Flags: needinfo?(mounir)
I believe this should be fixed by my patch in bug 52500 but it has some test failures on Mac and I need to be back at the office to investigate the failures (my laptop isn't a Mac). Hopefully, it will be done at the end of last week.
Assignee: nobody → mounir
Depends on: input[type=file]
Flags: needinfo?(mounir)
OS: Mac OS X → All
Hardware: x86 → All
This should be fixed. I can't test given that the test case lives behind a login.
Status: NEW → RESOLVED
Closed: 8 years ago
Component: General → Layout: Form Controls
Resolution: --- → FIXED
Whiteboard: [fixed by bug 52500]
Mounir, what's the plan for getting this fixed on 22 and 23?

I can try to get you a testcase off the site if that would help.
Flags: needinfo?(mounir)
The patch in bug 52500 is waiting for an approval to land on aurora and beta.
Flags: needinfo?(mounir)
Is there a test account for enrollonline.com/mozilla available for verifying this bug fix?
Flags: needinfo?
Marking fixed on 23 since it is marked as such in bug 52500
Flags: needinfo?
Still need a test account for enrollonline.com/mozilla to verify this fix.
Flags: needinfo?
tchung should be able to hook you up with somebody in QA.
Flags: needinfo?
What is the test status here?
The HR site is still showing this as an open bug and directing employees to use other browsers. That's bad.

:tchung or mschifer perhaps?
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.