[B2G] [Dialer] Dialing a number without a network connected will navigate the device to an error message with a non-functioning button.

VERIFIED DUPLICATE of bug 866690

Status

Firefox OS
Gaia::Dialer
VERIFIED DUPLICATE of bug 866690
5 years ago
5 years ago

People

(Reporter: Allen Maxwell, Assigned: rudyl)

Tracking

({smoketest})

unspecified
ARM
Gonk (Firefox OS)
smoketest

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 unaffected, b2g18-v1.0.1 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 741533 [details]
Logcat of issue

Description:
If a call is placed without a network connection the phone will display an error message without a functioning "OK" button. The user can press the Home button and will be navigated to the home screen with a green bar across the top. If the green bar is selected user will be navigated to an empty screen.

Repro Steps:
1) Updated to Mozilla v1.0.1 Build ID: 20130424070201
2) Go to a location without network connection, or pull out sim.
3) Dial a phone number.


Actual:
An error message is encountered without a functioning "OK" button.

Expected:
The "OK" button functions and cancels the attempted phone call.

Environmental Variables
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/89796cc8d74c
Gaia: 42dad2d9a6026032f83897ae16caaf4719813a5d
Version #: 18.0

Notes:
Repro frequency: 100%
Test Suite Name: (e.g., Keyboard & Text-Handling)
UCID: (suite-smoketest)
https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-id=1298 
Q Analysts Test Team Priority: Priority Levels: Pri 1
No_Network_Connection.jpg
(Reporter)

Comment 1

5 years ago
Created attachment 741534 [details]
Screen Shots
(Reporter)

Comment 2

5 years ago
This issue is high impact. Recommend escalation to PR1.
Summary: [B2G] [Dialer] Dialing a number without being connected to a network will navigate the device to an error message with a non functioning button. → [B2G] [Dialer] Dialing a number without a network connected will navigate the device to an error message with a non-functioning button.
If this is on v1.0.1 we've got a TEF blocker here, definitely need to look into this further - can qa verify this is reproducible on both v1.0.1 and v1.1?
blocking-b2g: leo? → tef+
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
Keywords: qawanted

Comment 4

5 years ago
Issue still occurring on an Inari device running the following build from the v1.0.1 branch:

Build ID: 20130429070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/45aa5ba0ed53
Gaia: cf2d4136f0ebc66039637fdbeb72ed184dfbc0f2
Kernel Date: Feb 21

Everything is still happening exactly as stated in the initial writeup.

Updated

5 years ago
Keywords: qawanted

Comment 5

5 years ago
Hi Isblak,

This bug could be only reproducible on v1.0.1, not include v1.1.
Going to take a look.
Assignee: nobody → rlu
(In reply to Rudy Lu [:rudyl] from comment #6)
> Going to take a look.

Cool probably a missing uplift since it's not reproducible in master, and not in 1.1 either.
Created attachment 743670 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9488

Pointer to Github pull-request
Comment on attachment 743670 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9488

[Root Cause]
As the following comment pointed out, this case failed at an access to  mozMobileConnection.voice.network.mcc
https://bugzilla.mozilla.org/show_bug.cgi?id=839363#c6

And with the same bug, Bug 839363, landed on v1-train/master, this issue would not happen on those branches.

[Solution]
I am not sure if we want to uplift the whole patch for Bug 839363.
So here is the one-line patch to check mcc before using it.

Etienne,

Could you please review this?
Thanks.
Attachment #743670 - Flags: review?(etienne)
status-b2g18: affected → unaffected
Duplicate of this bug: 866740
Dupe this one to Bug 866690, since the patch there is r+ed, but still need to be uplifted to v1.0.1.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866690
Attachment #743670 - Flags: review?(etienne)
status-b2g18-v1.0.1: affected → fixed

Comment 12

5 years ago
confirming, this bug has been fixed in bug 866690

- attempting to make a call when there is no network (or no SIM) will bring the notification with a working "OK" button

Inari build info:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/f379dc8c9181
Gaia   ac293ce59acc3bede083fad1b973794fa8bf0253
Build  20130529070211
Version 18.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.