Strange behaviour on DuT after dialing when not attached to network

RESOLVED DUPLICATE of bug 865469

Status

Firefox OS
Gaia::Dialer
P1
critical
RESOLVED DUPLICATE of bug 865469
5 years ago
5 years ago

People

(Reporter: juanpbf, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
1.0.1 Cert2 (21may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 unaffected, b2g18-v1.0.1 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 743104 [details]
[1] ERROR_3 screenshot

Steps to Reproduce
1 - Enable "flight" mode (so you dettach from NW)
2 - Open dialer and dial any mobile number
3 - You'll be prompted a message stating that you must be attached to a NW to be able to dial a number

  --> so far so good

4 - Disable "flight" mode --> you will attach your operator's NW
5 - Open dialer and dial that same mobile number


EXPECTED RESULT
You should be able to dial and call to that number

ACTUAL RESULT
At this point, several errors appear:

- ERROR_1: You are prompted the same message as in step3 (and you shouldn't since the handset is attached to the NW
- ERROR_2: If you click in the "Accept" button, nothing happens (and the message should disappear when clicking that button)
- ERROR_3: If you press Home button, to return to main screen, a green bar remains at top of the screen (as though you had an ongoing call in place) [1]
- ERROR_4: If you press the green bar, you will just see an empty screen [2]
- ERROR_5: If you try to kill the Dialer app (by long pressing the home button), you can't (there is no "X" button to kill it) [3]
- ERROR_6: You are not able to receive or make calls

==> As a result, you must restart the handset
(Reporter)

Comment 1

5 years ago
Created attachment 743105 [details]
[2] ERROR_4 Screenshot
(Reporter)

Comment 2

5 years ago
Created attachment 743106 [details]
[3] ERROR_5 Screenshot

Updated

5 years ago
blocking-b2g: tef? → tef+
(Reporter)

Comment 3

5 years ago
More information:

When starting the handset with no SIM card, if you try to dial any number (including Emergency numbers), you can also reproduce this issue.

 --> This behaviour makes the bug even more serious since it involves Emergency numbers

Updated

5 years ago
Assignee: nobody → anshulj

Updated

5 years ago
Assignee: anshulj → cyang

Comment 4

5 years ago
Hi Juan, I'm not able to reproduce this. Which AU are you using to test? Have you tried using latest AU and retesting?
Flags: needinfo?(juan.perezbedmar)
(Reporter)

Comment 5

5 years ago
(In reply to Carol Yang from comment #4)
> Hi Juan, I'm not able to reproduce this. Which AU are you using to test?
> Have you tried using latest AU and retesting?
Sorry, I see I forgot to add details about the version used 

Tested on Ikura
  build ID:20130426165700
  build information:
  gaia commit:
  e25b349 Merge pull request #9273 from gasolin/issue-863126
  gecko commit:
  6dfd179 Bug 849757 - Part 4: xpcshell tests. r=vicamo, a=tef+
  AU:V1.01.00.01.019.085

BR
Flags: needinfo?(juan.perezbedmar)

Updated

5 years ago
Target Milestone: --- → 1.0.1 Cert2 (28may)
Can somebody reproduce this with a mozilla-ril build?
(would help narrow down the issue.)
Is this (partly?) a dupe of bug 865469?

Comment 8

5 years ago
I am able to reproduce the issue with no sim card. But with the sim card enabling/disabling the APM seems to work okay for me. So this issue seems like a duplicate of bug 865469 to me.

Updated

5 years ago
Assignee: cyang → nobody
(In reply to Anshul from comment #8)
> I am able to reproduce the issue with no sim card. But with the sim card
> enabling/disabling the APM seems to work okay for me. So this issue seems
> like a duplicate of bug 865469 to me.

Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 865469
status-b2g18: --- → unaffected
status-b2g18-v1.0.1: --- → fixed
You need to log in before you can comment on or make changes to this bug.