Intermittent test_delayNode.html,test_delayNodeWithGain.html,test_gainNode.html,test_scriptProcessorNode.html | Test timed out.

RESOLVED WORKSFORME

Status

()

defect
P2
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: RyanVM, Assigned: Ehsan)

Tracking

({intermittent-failure})

Trunk
mozilla23
x86
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=22176729&tree=Mozilla-Inbound

Rev3 WINNT 6.1 mozilla-inbound opt test mochitest-1 on 2013-04-23 22:27:07 PDT for push 787e5340d7af
slave: talos-r3-w7-061

22:53:05     INFO -  207146 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_delayNode.html | Test timed out.
22:58:36     INFO -  207149 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_delayNodeWithGain.html | Test timed out.
23:04:06     INFO -  207166 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_gainNode.html | Test timed out.
23:09:36     INFO -  207191 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_scriptProcessorNode.html | Test timed out.
23:09:36     INFO -  207192 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | 4 test timeouts, giving up.
23:09:36     INFO -  207193 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | Skipping 148 remaining tests.
23:09:37     INFO -  207194 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | /tests/content/media/webaudio/test/test_scriptProcessorNode.html finished in a non-clean fashion, probably because it didn't call SimpleTest.finish()
Blocks: webaudio
Depends on: 866189
Bug 866189 blocks me from trying to see if I can reproduce this locally.
Summary: Intermittent test_delayNode.html,test_delayNodeWithGain.html,test_gainNode.html,test_scriptProcessorNode.html | Test timed out. → Intermittent test_bug867174.html,test_delayNode.html,test_delayNodeWithGain.html,test_gainNode.html,test_scriptProcessorNode.html | Test timed out. | test_currentTime.html | AudioContext.currentTime should have increased by now
(In reply to TinderboxPushlog Robot from comment #27)
> RyanVM
> https://tbpl.mozilla.org/php/getParsedLog.php?id=22506934&tree=Mozilla-
> Inbound
> Android 4.0 Panda mozilla-inbound opt test mochitest-2 on 2013-05-02 07:40:30
> slave: panda-0724
> 
> 28637 ERROR TEST-UNEXPECTED-FAIL |
> /tests/content/media/webaudio/test/test_bug867174.html | Test timed out.
> 28641 ERROR TEST-UNEXPECTED-FAIL |
> /tests/content/media/webaudio/test/test_currentTime.html |
> AudioContext.currentTime should have increased by now
> command timed out: 2400 seconds without output, attempting to kill
> Remote Device Error: unable to connect socket: [Errno 110] Connection timed
> out
> Remote Device Error: unable to connect socket: [Errno 113] No route to host
> Remote Device Error: unable to connect socket: [Errno 111] Connection refused
> Remote Device Error: unable to connect socket: [Errno 111] Connection refused
> Remote Device Error: unable to connect socket: [Errno 111] Connection refused

Disabled the test: https://hg.mozilla.org/integration/mozilla-inbound/rev/b342f87552a3
Whiteboard: [leave open]
Summary: Intermittent test_bug867174.html,test_delayNode.html,test_delayNodeWithGain.html,test_gainNode.html,test_scriptProcessorNode.html | Test timed out. | test_currentTime.html | AudioContext.currentTime should have increased by now → Intermittent test_delayNode.html,test_delayNodeWithGain.html,test_gainNode.html,test_scriptProcessorNode.html | Test timed out.
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #29)
> Disabled the test:

How about disabling the rest?
Flags: needinfo?(ehsan)
https://hg.mozilla.org/mozilla-central/rev/b342f87552a3
Tests disabled.
https://hg.mozilla.org/mozilla-central/rev/93602e7a1551
Whiteboard: [leave open] → [test disabled on Android][leave open]
K, this is my last attempt to get some semblance of these passing on Android. If this doesn't work, I'm killing all of these on Android.
https://hg.mozilla.org/integration/mozilla-inbound/rev/6402e13dc9ba
Hmm, this is very strange.  Before today, these failures were quite low frequency...  I wonder what changed today which caused this much of a spike in the failure rates...
Flags: needinfo?(ehsan)
Please use android.json rather than makefile ifdefs to disable mochitests on Android (and similarly, b2g.json for B2G).
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #29)
> Disabled the test:
> https://hg.mozilla.org/integration/mozilla-inbound/rev/b342f87552a3

(In reply to Ryan VanderMeulen [:RyanVM] from comment #86)
> Tests disabled.
> https://hg.mozilla.org/mozilla-central/rev/93602e7a1551

(In reply to Ryan VanderMeulen [:RyanVM] from comment #110)
> K, this is my last attempt to get some semblance of these passing on
> Android. If this doesn't work, I'm killing all of these on Android.
> https://hg.mozilla.org/integration/mozilla-inbound/rev/6402e13dc9ba

Backed out in:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8dee87bfcb0f
https://hg.mozilla.org/integration/mozilla-inbound/rev/438a6c43dec8
https://hg.mozilla.org/integration/mozilla-inbound/rev/341ac326d3be
...to avoid conflicts with another backout + so this can reland using android.json.
The patch that I posted in bug 867174 fixes these failures:

https://tbpl.mozilla.org/?tree=Try&rev=7fc0d32b0920
Assignee: nobody → ehsan
Depends on: 867174
No longer depends on: 866189
Whiteboard: [test disabled on Android][leave open] → [test disabled on Android]
Posted patch Patch (v1)Splinter Review
Attachment #745701 - Flags: review?(emorley)
Attachment #745701 - Flags: review?(ryanvm)
Attachment #745701 - Flags: review?(philringnalda)
I'm confused, we're still hitting these timeouts on inbound per the above comments?
Comment on attachment 745701 [details] [diff] [review]
Patch (v1)

Personally, I would have just landed that without review.
Attachment #745701 - Flags: review?(ryanvm)
Attachment #745701 - Flags: review?(philringnalda)
Attachment #745701 - Flags: review?(emorley)
Attachment #745701 - Flags: review+
(In reply to comment #127)
> I'm confused, we're still hitting these timeouts on inbound per the above
> comments?

I just landed the patch a few hours ago.
Whiteboard: [test disabled on Android]
The above Windows inbound failures above were after your patch landed AFAICT.
(In reply to comment #131)
> The above Windows inbound failures above were after your patch landed AFAICT.

Could be, but those are different bugs.  To the best of our knowledge, the reason behind the Android failures should not exist any more.
Blocks: 869257
https://hg.mozilla.org/mozilla-central/rev/0477c9c2c0e2
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Blocks: 870065
Let's just call this one (the Android version) fixed and use bug 870065 going forward.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Mass moving Web Audio bugs to the Web Audio component.  Filter on duckityduck.
Component: Video/Audio → Web Audio
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 902775
Priority: -- → P2
Karl -- Do you believe this got fixed (since we haven't seen this in about 3 months)?
Flags: needinfo?(karlt)
Haven't seen the original issue with 4 test time outs on WINNT since August.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(karlt)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.