Intermittent Windows test_delayNode.html,test_delayNodeWithGain.html,test_gainNode.html,test_gainNodeInLoop.html | Test timed out.

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
The Android version of this was fixed in bug 865642, but we still see this occasionally on Windows (as noted towards the end of that bug).

https://tbpl.mozilla.org/php/getParsedLog.php?id=22741968&tree=Mozilla-Inbound
Reporter

Updated

6 years ago
Summary: Intermittent Windows test_delayNode.html,test_delayNodeWithGain.html,test_gainNode.html,test_scriptProcessorNode.html | Test timed out. → Intermittent Windows test_delayNode.html,test_delayNodeWithGain.html,test_gainNode.html,test_gainNodeInLoop.html | Test timed out.

Comment 1

6 years ago
roc have we had bugs where the MSG just stops working all of a sudden?  Benoit noticed that in a game he was working on (which was not using Web Audio) the sound playback would suddenly stop for no apparent reason and would then resume after a while.  I suspect that kind of thing might result in random failures in Web Audio tests among others.  Note that this is just a theory at this point.  I have zero evidence.  :-)
Flags: needinfo?(roc)
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #1)
> roc have we had bugs where the MSG just stops working all of a sudden? 
> Benoit noticed that in a game he was working on (which was not using Web
> Audio) the sound playback would suddenly stop for no apparent reason and
> would then resume after a while.

How was MSG involved, then?
Flags: needinfo?(roc)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Comment 6

6 years ago
(In reply to comment #2)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #1)
> > roc have we had bugs where the MSG just stops working all of a sudden? 
> > Benoit noticed that in a game he was working on (which was not using Web
> > Audio) the sound playback would suddenly stop for no apparent reason and
> > would then resume after a while.
> 
> How was MSG involved, then?

The game was using <audio>.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #6)
> The game was using <audio>.

<audio> doesn't use the MediaStreamGraph.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Comment 60

6 years ago
Mass moving Web Audio bugs to the Web Audio component.  Filter on duckityduck.
Component: Video/Audio → Web Audio

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Depends on: 902775
You need to log in before you can comment on or make changes to this bug.