Closed Bug 866537 Opened 7 years ago Closed 7 years ago

Several extensions broke (in a way that breaks the browser) after bug 697319

Categories

(Firefox :: Extension Compatibility, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: ehoogeveen, Unassigned)

References

Details

(Keywords: regression)

Bug 697319 landing broke several extensions. Confirmed are MEGA EXTENSION [1], GMail Manager [2] and Browser Backgrounds [3]. When these extensions are enabled, it becomes impossible to open or close new tabs (and the error console), making the browser essentially unusable. I'm told that this is the result of bad programming in the extensions and that they could be easily fixed [4], though.

STR:
1) From a fresh profile, install any of the listed extensions.
2) Restart the browser, and notice that only a single tab is opened. Pressing the new tab button doesn't visibly do anything.
3) Try to close the browser - it will warn about closing multiple tabs.

[1] https://addons.mozilla.org/en-US/firefox/addon/meganz/
[2] https://addons.mozilla.org/en-US/firefox/addon/gmail-manager/
[3] https://addons.mozilla.org/en-US/firefox/addon/browser-backgrounds/
[4] http://forums.mozillazine.org/viewtopic.php?p=12826625#p12826625
Blocks: 697319
Confirmed here, disabling the Mega extension fixed it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 697319 was backed out due to this problem. Thanks for reporting it

http://hg.mozilla.org/integration/mozilla-inbound/rev/3b3d66182d26
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 866538
Duplicate of this bug: 866558
You need to log in before you can comment on or make changes to this bug.