Closed Bug 866652 Opened 9 years ago Closed 9 years ago

Crash in mozilla::layers::CreateTextureHostD3D9 with abort message: "not implemented" (OMTC enabled)

Categories

(Core :: Graphics: Layers, defect)

23 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED INVALID
Tracking Status
firefox22 --- unaffected
firefox23 --- affected

People

(Reporter: Virtual, Unassigned)

References

()

Details

(4 keywords)

Crash Data

Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::layers::CreateTextureHostD3D9(int, unsigned int, unsigned int) ]
It doesn't crash for me.
Does it happen in Safe Mode?
Hardware: x86_64 → x86
Summary: Crash in mozilla::layers::CreateTextureHostD3D9 with OMTC → Crash in mozilla::layers::CreateTextureHostD3D9 with abort message: "not implemented" (OMTC enabled)
I can't reproduce it in Nightly Portable with a clean new profile without any addons.
But after some diagnosing it further, I discovered that these crashes are caused by both settings set to true:
layers.async-video.enabled;true
layers.offmainthreadcomposition.enabled;true

https://crash-stats.mozilla.com/report/index/bp-0dc26e70-cb7b-415a-b5d1-e36952130429
Blocks: omtc
It also crashes for me with these both prefs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OMTC is not supported on Windows yet, so a crash is pretty much expected.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::layers::CreateTextureHostD3D9(int, unsigned int, unsigned int) ] → [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::layers::CreateTextureHostD3D9(int, unsigned int, unsigned int) ] [@ mozalloc_abort(char const* const) | NS_DebugBreak]
Hardware: x86 → All
(In reply to Nick Cameron [:nrc] [PTO until 20th May] from comment #4)
> OMTC is not supported on Windows yet, so a crash is pretty much expected.

True!

Retesting this as now OMTC landed on Windows shows that crashing didn't occur anymore.
Status: RESOLVED → VERIFIED
Keywords: crashreportid
You need to log in before you can comment on or make changes to this bug.