Only solicit Google Play feedback when the build came from the Play store

RESOLVED FIXED in Firefox 24

Status

()

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: akeybl, Assigned: Margaret)

Tracking

unspecified
Firefox 24
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec22+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Only solicit Google Play feedback when the distribution ID isn't 'yandex'. This will prevent confusion for people who don't have Google Play.

We may want to make this change for all non-standard distribution IDs.
We could either add code to the app to look at the distribution, or we could ship a preferences.json that disables the feedback from showing.

Adding code to the app might break for "campaign tracking" which would install from Play Store, but use a distribution id.

Let's consider the preferences.json approach.
Anyone with a Google account can review Firefox. I get the incongruity of the situation. Is there a reason we don't want these reviews?
(Assignee)

Comment 3

6 years ago
So do we want to prevent showing about:feedback altogether for these distributions, or have an alternate version of about:feedback, perhaps one that directs positive feedback to input.mozilla.org instead? If we do want an alternate about:feedback, we'll need some strings for that.

Not showing about:feedback would definitely be a quicker solution that we could uplift if necessary. However, if we do go with the preferences.json approach we'll need to move around the logic used to show about:feedback, since right now we do all that in java. Perhaps instead of calling loadUrlInTab, we could send a message to gecko saying we want to solicit feedback, then gecko can use that pref do decide whether or not to do that.

(In reply to Kevin Brosnan [:kbrosnan] from comment #2)
> Anyone with a Google account can review Firefox. I get the incongruity of
> the situation. Is there a reason we don't want these reviews?

I think it seems odd to ask for a google play store review if the user downloaded the app through a different store.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 802207
(Assignee)

Comment 5

6 years ago
Updating the summary to make this bug address the more general case.

In bug 802207, rnewman brought up the fact that we're prompting for feedback on nightly/aurora, which also don't come from the play store. For this case, we can use channel-specific build defines to avoid prompting for feedback.
Summary: Only solicit Google Play feedback when the distribution ID isn't 'yandex' → Only solicit Google Play feedback when the build came from the Play store
(Assignee)

Comment 6

6 years ago
Thinking about this more, instead of doing special things for when we want to *not* ask for feedback, is there any way for us to know a build came from the play store, and use that to decide whether or not to point to user at the play store?
Is this worth tracking?
OS: Mac OS X → Android
Hardware: x86 → ARM
(Assignee)

Comment 8

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #7)
> Is this worth tracking?

I think so, especially if we think we'll have more non-play store distributions in the future.
tracking-fennec: --- → ?
tracking-fennec: ? → 22+
(Assignee)

Comment 9

6 years ago
Created attachment 756699 [details] [diff] [review]
Don't prompt for feedback in distribution builds

This is the uplift-able solution to not prompt for feedback in distribution builds.

I was wondering if we know what the overhead is for loading one of these subscripts, and whether or not it would be worth just sticking this in browser.js instead.

If you want to test this, commenting out the |if (shouldShowFeedbackPage)| makes it easier.
Attachment #756699 - Flags: review?(mark.finkle)
(Assignee)

Comment 10

6 years ago
Created attachment 756707 [details] [diff] [review]
(Part 2) Only prompt for feedback on Beta and Release builds

I wrote this patch to address the issue in bug 802207, but thinking about this more, maybe we should just ignore this issue until we make an alternate about:feedback that sends positive feedback to input, since it's useful for Nightly/Aurora users to give us feedback.
(Assignee)

Updated

6 years ago
Depends on: 878173
Comment on attachment 756699 [details] [diff] [review]
Don't prompt for feedback in distribution builds

I think this is a good use of the lazy-loading system.
Attachment #756699 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 13

6 years ago
Comment on attachment 756707 [details] [diff] [review]
(Part 2) Only prompt for feedback on Beta and Release builds

I'll fix this Nightly/Aurora issue in bug 878173.
Attachment #756707 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/7f70a88cba03
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Margaret: can we do a better job of this via Bug 1220773?
Flags: needinfo?(margaret.leibovic)
(Assignee)

Comment 16

3 years ago
(In reply to Richard Newman [:rnewman] from comment #15)
> Margaret: can we do a better job of this via Bug 1220773?

Perhaps. We are working on moving about:feedback to a hosted web page (bug 1225676), but we'll still have client code to decide when to automatically open this page. However, would be nice if we could pass this install info as a parameter on that URL, and then the webpage could decide whether to solicit a review of just ask for feedback (something like bug 878173).

I'll file a bug.
Flags: needinfo?(margaret.leibovic)
You need to log in before you can comment on or make changes to this bug.