Transition JS code of the Mozilla-codebase to version-free JS

RESOLVED DUPLICATE of bug 1390106

Status

()

RESOLVED DUPLICATE of bug 1390106
6 years ago
10 months ago

People

(Reporter: bruant.d, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Might require static analysis to find all cases where JS-version specific is used in the Mozilla codebase.
If too numerous, might require automated rewriting.
(Reporter)

Updated

6 years ago
Blocks: 867609
(Reporter)

Comment 1

6 years ago
Probably need to wait for some ES6 sugar to land before being able to do that.
Depends on: 611388, 666399
for each() should be doable now, I guess.
As is harmony-style generators (i.e. function*)
Depends on: 925989
(Assignee)

Updated

4 years ago
Assignee: general → nobody
Depends on: 1083459
Depends on: 968038
Depends on: 1083499
Depends on: 1059843
To completely remove the version= parsing code from ScriptLoader we will have to finish this. I actually get very few matches for this on searchfox: https://searchfox.org/mozilla-central/search?q=%3B%5Cs*version%3D&case=false&regexp=true&path=
Hasn't this been fixed in Firefox 57? To be precise, in bug 1390106.
Flags: needinfo?(VYV03354)

Comment 6

10 months ago
Yes (and bug 1428745).
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Depends on: 1428745, 1417844
Flags: needinfo?(VYV03354)
Resolution: --- → FIXED

Comment 7

10 months ago
I confused this bug with bug 867609.
No longer depends on: 1417844, 1428745
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1390106
You need to log in before you can comment on or make changes to this bug.