Bug 867609 (1JS)

Retire JavaScript versions

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
6 years ago
11 months ago

People

(Reporter: bruant.d, Unassigned)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
For context and discussion:
https://groups.google.com/d/msg/mozilla.dev.tech.js-engine.internals/WRZsLHejpNw/hxVmn-vkcVIJ

Quoting Dave Herman bug 666399#c56 :
"The explicit versioning is Mozilla-specific, and is basically a failed
experiment; the overwhelming majority of the web doesn't use it. The
HTML5 zeitgeist and the "One JavaScript" (1JS) movement, meanwhile, have
moved away from opt-in versioning as an anti-pattern."

This bug is a meta bug. The process will be slow, require making sure that nothing breaks in the process. Dependent bugs will track that.
(Reporter)

Updated

6 years ago
OS: Linux → All
Hardware: x86 → All
(Reporter)

Updated

6 years ago
Depends on: 867612
(Reporter)

Updated

6 years ago
Depends on: 867615
(Reporter)

Updated

6 years ago
Depends on: 867617
(Reporter)

Updated

6 years ago
Depends on: 855665
(Reporter)

Updated

6 years ago
Blocks: 487070
Keywords: meta
Depends on: 988386
Priority: -- → P2
Assignee: general → nobody
No longer depends on: 988386
Alias: 1JS
No longer blocks: 487070
Depends on: 1103158
Depends on: 1173883
Depends on: 1192329
No longer blocks: 1146532
this doesn't depend on entire bug 1103158 but only bug 1083482 (legacy generator) and 1083470 (for-each)
no other legacy feature depends on JS version.
Depends on: 1083482, 1083470
No longer depends on: 1103158
Depends on: 1340937
Depends on: 1390106
See Also: → bug 591961
Depends on: 1412532
Depends on: 1412533
Duplicate of this bug: 874173
Duplicate of this bug: 529206
Duplicate of this bug: 1163938
Depends on: 1417844
Depends on: 1417895
What is left to close this bug?
Nothing. We no longer support versions internally and since bug 1428745 the DOM script loader ignores versioned scripts.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
(Reporter)

Comment 7

11 months ago
(In reply to Jan de Mooij [:jandem] from comment #6)
> Nothing. We no longer support versions internally and since bug 1428745 the
> DOM script loader ignores versioned scripts.

Setting dependency accordingly
Depends on: 1428745
(Reporter)

Comment 8

11 months ago
This is so cool :-)
Thanks to everyone who worked toward removing JavaScript versions!!
You need to log in before you can comment on or make changes to this bug.