Open Bug 868205 Opened 7 years ago Updated 4 years ago

Click-to-play pref (plugins.click_to_play) broken in SeaMonkey

Categories

(SeaMonkey :: General, defect, major)

defect
Not set
major

Tracking

(Not tracked)

People

(Reporter: mcsmurf, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 obsolete file)

To reproduce:
1. Fetch a current trunk build
2. Switch plugins.click_to_play to true
3. Observe that click-to-play is broken and plugins get enabled without click to play

We really need to watch our tests more closely, those have actually caught that problem (and run tests locally when changing such code).
Possible regression from Bug 854867 or Bug 860537, need to check.
So, might not be a regression from our code actually, but something in core changed and might require changes on our side.
This regressed between 2013-04-21 
build id: 20130421003001
http://hg.mozilla.org/mozilla-central/rev/0d50cb959c46

and 2013-04-28. 
build id: 20130428003001
http://hg.mozilla.org/mozilla-central/rev/9d8977cbbfc6

Unfortunately there were no nightly builds between those two revisions :/ (tree was red due to Bug 864256).
Eh, looks like Bug 549697 changed the way the pref works (currently the pref does not really have any effect). Also see Bug 866935 Comment 0 on that, currently the pref has to be true and the plugin enabledState has to be set to STATE_CLICKTOPLAY to enable click-to-play (this can be done by the new UI in the addons manager). Maybe a new pref will be added by Bug 866390 that will restore the functionality of the old CTP pref again.
I'm morphing this bug into fixing the existing tests and adding new tests.
Attached patch Update tests (obsolete) — Splinter Review
This fixes the existing tests for now, but something is still wrong with test12d. This might have to do with Bug 798278 (multiple plugin doorhanger UI), but not sure yet. In general the bug is that all plugins get activated in test12d, even though only the first plugin (and not the two instances of the second plugin) should be activated.
I will fix the tests in Bug 798278, too. This bug here is basically left open "for reference".
Depends on: 866390, 798278
Summary: Click-to-play broken in SeaMonkey → Click-to-play pref (plugins.click_to_play) broken in SeaMonkey
Attachment #745088 - Attachment is obsolete: true
Yeah, the experimental click-to-play feature changed behaviour. Nowadays its only effect is to enable the "Ask to Activate" option in plugins' detail view. By itself, and unless you take plugin-specific action, it will not have any other effect, and in particular it won't make all enabled plugins click-to-play anymore. This is not a bug, it's a change in the definition of an experimental feature in Core and/or Toolkit.

I agree to leave this bug report temporarily open, so that it will be caught by "simple searches" when attempting to report it again, and so avoid duplicates if possible; but I suppose that "when the dust settles" it will have to be RESOLVED INVALID.
Also see Firefox Bug 905084 - Fix "Activate this plugin" action in context menu.
You need to log in before you can comment on or make changes to this bug.