Closed Bug 868227 Opened 7 years ago Closed 7 years ago

[MMS][User Story] Attachment (pre-send) options

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

x86
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed)

RESOLVED FIXED
1.1 CS (11may)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed

People

(Reporter: danheberden, Assigned: greg)

References

Details

(Keywords: feature)

Attachments

(1 file)

45 bytes, text/x-github-pull-request
julienw
: review+
Details | Review
User Story:
After attaching an image #840044, a video #868225, or audio file #868190 I can tap that attachment (image/video thumbnail or audio icon) to be presented with a list of options to view/listen/play that attachment, replace that attachment, or remove that attachment.
Assignee: nobody → greg
Keywords: feature
Priority: -- → P1
Target Milestone: --- → 1.1 CS (11may)
Dan from a UX perspective 'replace that attachment' is the lowest priority of these functions. If time is tight it can be deferred.
Blocks: 840047
blocking-b2g: --- → leo+
Whiteboard: [NO_UPLIFT]
Depends on: 840069
I am assuming this bug includes making the buttons function, rather than just making the menu appear. In that case, https://bugzilla.mozilla.org/show_bug.cgi?id=840047 would be a duplicate of this one. I already have the work done for the menu to appear with non-functioning buttons, so I'm going ahead and making them work now.
Having trouble finding a mock / wireframe for the Preview, anyone able to point me in the right direction?

The replace feature is blocked by https://bugzilla.mozilla.org/show_bug.cgi?id=840044
(In reply to greg from comment #3)
> Having trouble finding a mock / wireframe for the Preview, anyone able to
> point me in the right direction?
> 
> The replace feature is blocked by
> https://bugzilla.mozilla.org/show_bug.cgi?id=840044

Pretty sure it's just firing the open MozActivity
Duplicate of this bug: 840047
Attached file pull request on github
Couldn't get this landed yesterday, I'm in office doing final code review changes and coordinating with :gnarf
:gnarf37 reviewed and let me know this was good to go, should be landed soon. is anything needed from me?
Flags: needinfo?(gnarf37)
Attachment #750689 - Flags: review?(gnarf37)
Attachment #750689 - Flags: review?(gnarf37)
Flags: needinfo?(gnarf37)
Flags: in-moztrap?
Comment on attachment 750689 [details] [review]
pull request on github

r=me for hash 20e4c1be5ae09b624f0c6a0afb2f3c41eb705203

go for it, thanks for the hard work. Any more tests before landing is fine for me too.
Attachment #750689 - Flags: review?(gnarf37)
Attachment #750689 - Flags: review+
master: f41344254e0ee3101480890a9f26deae083bfee7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 875457
Depends on: 871835
Whiteboard: [NO_UPLIFT]
v1-train: 66401e6
https://moztrap.mozilla.org/manage/cases/?filter-id=8435
https://moztrap.mozilla.org/manage/cases/?filter-id=8436
https://moztrap.mozilla.org/manage/cases/?filter-id=8437

Created test cases for issue, didn't see a UCID for the User story so marked the cases as "Messages-000".
Flags: in-moztrap? → in-moztrap+
QA Contact: dwatson
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.