Closed Bug 868950 (mmi-localization-pin) Opened 7 years ago Closed 7 years ago

[MMI] Localization of PIN/PIN2/PUK handling functionality

Categories

(Firefox OS Graveyard :: Gaia, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 874000
1.1 QE3 (26jun)
blocking-b2g leo+

People

(Reporter: sync-1, Assigned: ferjm)

References

Details

(Whiteboard: [TD-44891])

Attachments

(1 file)

38.19 KB, image/x-png
Details
+++ This bug was initially created as a clone of Bug #448666 +++
 
 SW127
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.092
 Firefox os  v1.0.1
 Mozilla build ID:20130430070201
 
 Created an attachment (id=401703)
 snapshot
 
 DEFECT DESCRIPTION:
 
  The prompt isn't translated.
 
  REPRODUCING PROCEDURES:
 
  1.Power on with SIM card,and the SIM card has FDN function
  2.Set system language as Polish/German
  3.Launch dialpad->input **04*Wrong old PIN1*new PIN1*new PIN1#/**042*Wrong old PIN2*new PIN2*new PIN2#->dial->the prompt still display in English(The old PIN you typed is not correct)==>KO1
  4.Launch dialpad->input **04*old PIN1*new PIN1*Wrong new PIN1#/**042*old PIN2*new PIN2*Wrong new PIN2#->the prompt still display in English(The PINs you typed do not match)==>KO2
  5.Launch dialpad->input **05*Wrong PUK1*new PIN1*new PIN1#/**052*Wrong PUK2*new PIN2*new PIN2#->the prompt still display in English(The PUK you typed is not correct Attempts Remaining:X)==>KO3
  6.Launch dialpad->input **05*PUK1*new PIN1*Wrong new PIN1#/**052*PUK2*new PIN2*Wrong new PIN2#->the prompt still display in English(The PINs you typed do not match)==>KO4
 
  EXPECTED BEHAVIOUR:
  KO1&KO2&KO3&KO4==>The prompt should display in Polish/German when system language is Polish/German.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:SW126+DT
 
  USER IMPACT:Medium
 
  REPRODUCING RATE:5/5
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #448666 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Clone from brother
Attached image snapshot
Clone from brother
These strings can't be found in the English files for translation of Gaia v1.0.1 (and also not in v1-train, and not at all in code on the master branch). Are these messages provided by the network provider?
IOT Block BUG,,Duplicate bug of 872929..
blocking-b2g: --- → tef?
Duplicate of this bug: 872929
I don't think this is a blocker. I think this is part of the Commercial RIL and maybe could be addressed for 1.1. Suggest we move it to leo triage.

Anshul, is this something that requires Gaia support too?
Flags: needinfo?(anshulj)
Whiteboard: [tef-triage]
Duplicate of this bug: 876587
We are looking to resolve this in commercial RIL by reading the strings from a string resource file. The strings would need localization however by l10 experts.
Assignee: nobody → cyang
Flags: needinfo?(anshulj)
triage with tef: not block for 1.0.1, move to leo?
blocking-b2g: tef? → leo?
blocking-b2g: leo? → leo+
Whiteboard: [tef-triage]
Depends on: 879032
Alias: mmi-localization-pin
Assignee: cyang → ferjmoreno
Summary: [Buri][Translation][German][Polish][PIN/PUK]The prompt isn't translated. → [MMI] Localization of PIN/PIN2/PUK handling functionality
Duplicate of this bug: 877026
Duplicate of this bug: 881519
Depends on: 883178
Blocks: 879750
No longer depends on: 883178
Depends on: mmi-result-pin
Whiteboard: [TD-44891]
Target Milestone: --- → 1.1 QE3 (24jun)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: mmi-result-pin
Please test on v173
You need to log in before you can comment on or make changes to this bug.