If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][inari] Flashing inari causes trouble of adding or sharing functionality in multiple apps (Commercial RIL 094)

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: nkot, Unassigned)

Tracking

({regression, reproducible})

unspecified
ARM
Gonk (Firefox OS)
regression, reproducible

Firefox Tracking Flags

(blocking-b2g:-, firefox23 unaffected, b2g18 unaffected, b2g18-v1.0.1 affected)

Details

(Whiteboard: [status: needs QA on vendor builds])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
The user is unable to add picture to a contact, tapping "Add Picture" button does nothing

Repro Steps:
1) Updated to Inari Build ID: 20130506070205
2) Open Contacts app
3) Select to create a new contact 
4) Tap "Add Picture" 

Actual:
Tapping "Add Picture" does nothing, user is unable to add picture to a contact

Expected:
Tapping "Add Picture" invokes the menu to add picture from Gallery or Camera

Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/ce67220b877d
Gaia: 1e598d8842920d9e0b1743dc6fe9390bd5f6e2df
Version 18.0
COM_RIL

Notes:
Repro frequency: 100%, 2/2 devices
Does not reproduce on Leo device flashed to v1.1.0 20130506070204 build
(Reporter)

Comment 1

4 years ago
Created attachment 745993 [details]
logcat

along with the issue described above was also unable to perform some other actions:
- add contact when sending email
- send SMS from Contacts app
- share files from Gallery ("Can not share this image file type" notification)

all symptoms reproduced on 3/3 devices,
flashing again to the same build fixed the issue...

attaching logcat for more information
(Reporter)

Updated

4 years ago
Summary: [B2G][inari][Contacts] Unable to add picture to a contact → [B2G][inari][Contacts] Flashing inari causes trouble of adding or sharing functionality in multiple apps
Seems it's a problem with web activities in general, not just contacts, changing the component to general as it's not a contacts specific problem.
Component: Gaia::Contacts → General
(Reporter)

Updated

4 years ago
Summary: [B2G][inari][Contacts] Flashing inari causes trouble of adding or sharing functionality in multiple apps → [B2G][inari] Flashing inari causes trouble of adding or sharing functionality in multiple apps

Updated

4 years ago
Duplicate of this bug: 869509

Updated

4 years ago
blocking-b2g: --- → tef?
Looks like activities are hosed.

Fabrice - Any ideas?
Flags: needinfo?(fabrice)

Updated

4 years ago
Keywords: regression, smoketest

Comment 5

4 years ago
logcat:
05-07 09:28:00.408: E/GeckoConsole(432): Content JS WARN at app://settings.gaiamobile.org/js/wallpaper.js:63 in onPickError: pick failed!
Regression range by date:

First busted - 5/6/2013
Last working - 5/5/2013
Somehow my comment from yesterday did not get added, but we saw inconsistent behavior with this testing yesterday on different devices. With two different devices with the exact same build, one Inari and one Ikura, on one device all the items listed in Comment 0 worked fine, while on the other device you could not add a picture, etc.
(Reporter)

Comment 8

4 years ago
Correction to regression range:

Last working build: 
Build  2013-05-03-070205
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3f3489356bbc
Gaia   3e232bce289c9e156d92553e752616cba284bc8f


First busted:
Build  2013-05-04-070201
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/b6848f2cbd2b
Gaia   59d8c2e750490679765b447e43bb77a80a3f9f39
http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/pushloghtml?startdate=2013-05-03&enddate=2013-05-04
comment 8 can't be correct. The push log has no changes to gecko during that time - only test automation changes.

Updated

4 years ago
status-b2g18: --- → unaffected
status-b2g18-v1.0.1: --- → affected
status-firefox23: --- → unaffected
Unagi, using Mozilla RIL - works using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/884ad1bbe24e
Gaia   1bac83700810f27e00a937e34e7c865da02e0215
BuildID 20130507070204
Version 18.0

I checked yesterday's Mozilla RIL build as well, and it worked there (050613).

I spot checked a Commercial RIL unagi build from 0507 and it did not work.
Tony spot checked a Mozilla RIL as well, and he confirmed it worked for him. He asked me to mark this bug QC confidential since it appears this issue is RIL specific. Adding Michael Vines and Anshul per Tony's request.
Group: qualcomm-confidential
Summary: [B2G][inari] Flashing inari causes trouble of adding or sharing functionality in multiple apps → [B2G][inari] Flashing inari causes trouble of adding or sharing functionality in multiple apps (Commercial RIL 094)

Updated

4 years ago
Flags: needinfo?(fabrice)
Assigning to Tapas to take a look
Assignee: nobody → tkundu
(In reply to Marcia Knous [:marcia] from comment #11)
> Unagi, using Mozilla RIL - works using:

One thing to note is that these builds are actually 1.1 builds, the correct information for 1.0.1 builds should be

Unagi (works with activities) Mozilla RIL
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/7e9e10889942
Gaia   29f5faf992aa2bacf6a9d500494093edd9472c69
BuildID 20130507070205
Version 18.0

Inari, with Commercial RIL (doesn't work with activities)
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/7e9e10889942
Gaia   29f5faf992aa2bacf6a9d500494093edd9472c69
BuildID 20130507070205
Version 18.0

Unagi, with Commercial RIL doesn't work with activities)
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/ce67220b877d
Gaia   1e598d8842920d9e0b1743dc6fe9390bd5f6e2df
BuildID 20130506070205
Version 18.0

The unagi Commercial RIL build from May 7th also doesn't work.

[snip]
Assignee: tkundu → nobody
Assignee: nobody → tkundu
Status: NEW → ASSIGNED
fwiw, i saw this reproduce against AU l01.00.01.019.094
Group: qualcomm-confidential

Updated

4 years ago
blocking-b2g: tef? → tef+
Assignee: tkundu → mschwart
I didn't see this bug mentioned in today's QA smoketest.  Does it still reproduce?  

FWIW, I don't see how the RIL could possibly be causing the behavior observed in this bug.
Allen, can the team double check if this is still happening in a recent 1.0.1 inari + commercial RIL build?  if not, lets close this bug.
(Reporter)

Comment 18

4 years ago
still seeing this issue when flashing inari to v1.0.0 with COM_RIL (2/4 devices)

Build  20130510070203
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/bbc0b0135f2c
Gaia   0da4aa20a755007d0b983dadd9e2a8252195c223

could not reproduce when flashing to Mozilla RIL build
Build  20130510070203
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/bbc0b0135f2c
Gaia   0da4aa20a755007d0b983dadd9e2a8252195c223
(Reporter)

Comment 19

4 years ago
there is a typo in comment 18, i was referring to v1.0.1 build not v1.0.0, apologize for that,

issue is still happening on more recent builds, testers had experienced it today with the following build

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/0b6bcb1f4175
Gaia   9648799c2e45917ff150fa9eef8aeac79a9ac008
Build  2013-05-15-07-02-03
Version 18.0
COM_RIL

Updated

4 years ago
Whiteboard: [status: needs patch]

Updated

4 years ago
Duplicate of this bug: 873210

Comment 21

4 years ago
This issue is occurring on the v1.1 as well.
Build: 20130516070206
Gaia: 08074c417f9e095168f38a449dabe0e2325b7353
Gecko: 4b5fe47ad76c

Testers are reporting the work around for is resetting the phone.
/settings/Device Information/more information/reset phone

Updated

4 years ago
Duplicate of this bug: 871069
We need to check if this happens on the vendor builds for this bug to remain TEF+.  If this only manifests on internal Moz builds then it doesn't matter much (for launch)
Assignee: mschwart → nobody
Keywords: qawanted
Whiteboard: [status: needs patch]
I remember getting similar behavior when using backup/restore and some activities or permissions changed, things somehow broke. Does it still happens after a reset-gaia ?

Updated

4 years ago
Whiteboard: [status: needs QA on vendor builds]
(In reply to Alexandre LISSY :gerard-majax from comment #24)
> I remember getting similar behavior when using backup/restore and some
> activities or permissions changed, things somehow broke. Does it still
> happens after a reset-gaia ?

we'll find someone in QA to test this on a recent vendor build.  QA typically wont do reset-gaia as you cant do that on a production build.

Comment 26

4 years ago
Tested on Inari device. V 1.0.1.
Build Identifier: 20130516003416
Git commit: 398c4852ae3e3316cbdf996d20ccee92...
Platform Version 18.0

Steps:
1) Open Contacts App
2) Select to Create a new contact 
3) Tap on "Add Picture" 

Expected:
Tapping "Add Picture" invokes the menu to Add picture from "Gallery" or "Camera"

Actual:
As expected. It works well

And also tested, and works well:
- Add contact when sending email (the email is sent ok)
- Send SMS from Contacts app (the SMS is sent/received ok)
- Share files from Gallery (can shared an image without error message)

Comment 27

4 years ago
"Added Commercial RIL used:"

Tested on Inari device. V 1.0.1.
Build Identifier: 20130516003416
Git commit: 398c4852ae3e3316cbdf996d20ccee92...
Platform Version 18.0

COM RIL: 105
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME

Comment 28

4 years ago
(In reply to Tony Chung [:tchung] from comment #25)
> (In reply to Alexandre LISSY :gerard-majax from comment #24)
> > I remember getting similar behavior when using backup/restore and some
> > activities or permissions changed, things somehow broke. Does it still
> > happens after a reset-gaia ?
> 
> we'll find someone in QA to test this on a recent vendor build.  QA
> typically wont do reset-gaia as you cant do that on a production build.

I tested this on the latest Vendor Build, 0/10 Repro Rate on this issue, I feel comfortable saying WFM at this point.

Comment 29

4 years ago
Saw this issue again this morning during the smoketest on the latest Inari build from the commercial 1.0.1 branch:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/a3a49f8d101e
Gaia: 42c448bf7baed154b20ead388de2fd9dd25936f6
Build: 20130521070210

All the typical symptoms still occurring.

Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Once again, I find it very similar to some bustages I got while dogfooding on my Nexus S, and that were resolved after reset-gaia (and I've been asked to test reset-gaia prior to report anything more ...). So, could you try it ?
I am not able to reproduce on my Ikura device using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/a3a49f8d101e
Gaia   42c448bf7baed154b20ead388de2fd9dd25936f6
BuildID 20130521070210
Version 18.0

I can add a picture in contacts, the picker comes up to pick a new wallpaper, etc.

I am checking the latest partner build as well.

Comment 32

4 years ago
As a note, please keep in mind that this issue appears to be VERY intermittent.  Occasionally you can get a successful flash on the first attempt, however there are also times when it can take up to 10 Flashes before a successful flash occurs.

Also note that the issues that occur after a flash fails, very greatly.  So having some of the issues appear fixed while having a few other bugs occurring due to a failed flash is not uncommon.
I also checked a recent vendor build and everything looks OK in that build:

Gecko 
Gaia   5f6e07492c4bda96608cb73c0755889ff3fa0b24
BuildID 20130518062231
Version 18.0
Tony - This issue seems to only be reproduced by qanalytics. Can you please work with qanalytics to determine whether there is an issue with the way that their devices have been flashed? 

As no partner testing as reproduced this issue, we're dropping tef+ but will add this to a watch list for our partners.
blocking-b2g: tef+ → ---
Flags: needinfo?(tchung)

Comment 35

4 years ago
This issue is still causing major issues for flashing.

Repro rate is approx 50% most times testers have to retry multiple times to get a good flash. 

If there is a proper way to flash the builds that we are not performing correctly, I would be interesting in learning it.

Comment 36

4 years ago
Resolving WFM as Mozilla QA cannot reproduce this issue.
Flags: needinfo?(tchung)
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
Reopening and renom'ing.   this is indeed concerning if we flash a partner build with this problem.

** Attaching the webapps.json file in case it helps with debugging.

STR:
1. install 1.0.1 Inari Nightly, with Com RIL AU 115
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/a3a49f8d101e
Gaia   09299399500b50de72cdd3b4365fc6455bbbb145
BuildID 20130522070210
Version 18.0
2. do any of the following:  Long press homescreen / settings > display > wallpaper > tap icon / contacts > add contact > Add picture...
3. Verify it never fires the file picker.  instead:

3 different errors:
05-22 15:19:59.595: E/GeckoConsole(384): Content JS WARN at app://homescreen.gaiamobile.org/gaia_build_defer_index.js:268 in onWallpaperError: pick failed!
----------------

05-22 15:23:38.309: E/GeckoConsole(426): Content JS WARN at app://settings.gaiamobile.org/js/wallpaper.js:63 in onPickError: pick failed!
----------------

05-22 15:19:26.903: E/GeckoConsole(455): Content JS ERROR at app://communications.gaiamobile.org/contacts/js/contacts_form.js:762 in anonymous: Error in the activity [object DOMError]


Expected:
- no file picker errors, file picker appears

Actual: 
- file picker fails
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Created attachment 752995 [details]
webapps.json file
renom'ing for blocking because if this is a flashing problem, i fear vendor builds could hit this too (but we can't confirm this just yet)

fabrice, any ideas?
blocking-b2g: --- → tef?
Flags: needinfo?(fabrice)
There's nothing unusual in logcat and in webapps.json. When people say they have to flash several times before they get a working build, it's flashing the same image right?
Flags: needinfo?(fabrice)
(In reply to Fabrice Desré [:fabrice] from comment #40)
> There's nothing unusual in logcat and in webapps.json. When people say they
> have to flash several times before they get a working build, it's flashing
> the same image right?

yep, reflashing the same exact image on the same phone.   it works, then it doesnt.

no one has seen this on a partner build yet, fwiw.
(In reply to Tony Chung [:tchung] from comment #41)
> (In reply to Fabrice Desré [:fabrice] from comment #40)
> > There's nothing unusual in logcat and in webapps.json. When people say they
> > have to flash several times before they get a working build, it's flashing
> > the same image right?
> 
> yep, reflashing the same exact image on the same phone.   it works, then it
> doesnt.
> 
> no one has seen this on a partner build yet, fwiw.

Once again, I'd say that I've had this spurious behavior sometimes when performing several rounds of ./flash.sh gecko && ./flash.sh gaia on my Nexus S and then restoring the indexedDB and webapps to the phone for dogfooding. Everytime I had those spurious behavior, a reset-gaia solved this and it was not surprising anyone that I had to do this.

Does it matches the way you reproduce it ?
Alex, this is not the kind of flashing they do here. This is about a full flash. If we fail to create the activities db at first start it's really bad, but I've never seen that happen yet.
Fabrice - can you try to reproduce and investigate comment 37? If you're unable to, we won't block (our partners haven't been able to repro).
Flags: needinfo?(fabrice)
Keywords: reproducible
I had it happen on today's 1.1 commercial RIL build.

Build ID: 20130524070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6f16cc15f916
Gaia: 26d9430df4cd670e46a208a6e4b6d77e4b27ed75
Version #: 18.0
I have not seen in any build from any partner for 1.0.1, so not a blocker for 1.0.1 at least
Whiteboard: [status: needs QA on vendor builds] → [status: needs QA on vendor builds] [tef-triage]
Yep, agreed. Not a blocker given that.
blocking-b2g: tef? → -
Whiteboard: [status: needs QA on vendor builds] [tef-triage] → [status: needs QA on vendor builds]
we couldnt reproduce on a latam partner build - 05282013.  given this is intermittent, and vendors can't reproduce, we'll blocking- this bug.  but lets keep it open since its been reproduced a few times on moz builds.
Still repros on Inari 1.1 commercial RIL.

Build ID: 20130625070217
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1

Comment 50

4 years ago
Please provide the AU version of the build you are using.
We do not have the tools to find the AU version.
Oh, the RIL version.  That's 01.01.00.019.138.
Flags: needinfo?(fabrice)

Updated

4 years ago
Keywords: smoketest
Tony - Does this issue still reproduce?
Flags: needinfo?(tchung)
No one has brought this bug up in the 1.3 and 1.4 timeframe, so im going to declare this bug wfm
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(tchung)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.