[meta] Implement CSS filters

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: gal, Unassigned)

Tracking

(Blocks: 2 bugs, {dev-doc-complete, meta})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
As discussed on dev-platform, the rough plan is to add CSS filter support to Moz2D. We will provide a (SIMD-accelerated) CPU path, and backends can overwrite that with backend-specific fast paths. The layers system will get a separate GL-based path for the same effects. This is a meta bug to track the work.
(Reporter)

Updated

4 years ago
Depends on: 869829
(Reporter)

Updated

4 years ago
No longer depends on: 869829
(Reporter)

Updated

4 years ago
Depends on: 869829

Updated

4 years ago
Blocks: 869496
I assume you mean the CSS filters as defined in the W3C Filter Effects[1] draft like "filter: blur(5px);", right?

Sebastian

[1] https://dvcs.w3.org/hg/FXTF/raw-file/tip/filters/index.html#FilterProperty
Both those and SVG filters, really.
Depends on: 878883

Updated

4 years ago
Depends on: 660196
Alias: iNerd
Why does that always happen :( ^
Alias: iNerd
Comment hidden (advocacy)

Updated

4 years ago
Depends on: 895182

Updated

4 years ago
Depends on: 896050

Updated

4 years ago
Depends on: 897392

Updated

4 years ago
Depends on: 898175

Updated

4 years ago
Depends on: 898361

Updated

4 years ago
Blocks: 904603

Comment 5

3 years ago
Is there any timeline/forecast for adding these css filters? Chrome/Safari/Webkit supports them since ages ago and they are much needed by so many developers around the world

Comment 6

3 years ago
Several people are actively working on this. Did you wish to join in and help them?

Comment 7

3 years ago
i wish i had the technical skills to help as i would for sure do it, i appreciate very much the generosity of everybody working on this, i will for sure be looking to help in testing this when it comes out, best wishes

Updated

3 years ago
Depends on: 948265

Updated

3 years ago
Blocks: 660196
No longer depends on: 660196
Keywords: dev-doc-needed

Updated

3 years ago
Depends on: 1057180

Updated

3 years ago
No longer blocks: 660196
Duplicate of this bug: 660196

Updated

3 years ago
Depends on: 1058753

Updated

3 years ago
Depends on: 1058756

Updated

3 years ago
Depends on: 1058765

Updated

3 years ago
Depends on: 1058776

Updated

3 years ago
Depends on: 1058779

Updated

3 years ago
Depends on: 1058783

Updated

3 years ago
Depends on: 1058794

Updated

3 years ago
Depends on: 1058798

Updated

3 years ago
Depends on: 1058801

Updated

3 years ago
Depends on: 1058807

Updated

3 years ago
Depends on: 1058809

Updated

3 years ago
Depends on: 1059493
No longer depends on: 1059493

Updated

3 years ago
Blocks: 913153
Keywords: meta
Summary: Implement CSS filters [meta] → [meta] Implement CSS filters

Comment 9

2 years ago
Now that bug 1057180 is fixed, marking the META bug fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.