Closed Bug 87018 Opened 21 years ago Closed 20 years ago

Offline: Download & Syncing multiple/subscribed newsgroups doesn't work the first time as not all mesgs/newsgroups are downloaded.

Categories

(SeaMonkey :: MailNews: Backend, defect)

x86
Windows 95
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Future

People

(Reporter: sameerds, Assigned: Bienvenu)

Details

When using the download/sync command, mozilla does not seem to download all the
messages at a time - it will stop after an arbitrary number, so that I have to
select download/sync again and again.
Reporter: can you give us more details please?
 -Your exact Steps to replicate the problem? 
 -What build date you were using?
 -type of email: imap, pop, webmail, etc..
 -existing 4.x profile?
 -How many folders trying to download: one folder? two folders?

Is this with Mail or News Messages? Both?

Similar to one of these bugs: bug 80110 or bug 79033 ?


Steps to reproduce the problem:
1. Already subscribed to a number of newsgroups (8)
2. The newsgroups have a lot of unread messages
3. Go to File|Offline|Download & Sync now
4. Select the newsgroups to download
5. Click ok in the Download & Sync window
6. Messages start getting downloaded

I am using 20010617 with only Mozilla profiles, nothing imported from netscape.

I have seen the problem only with news, because that is the only place that I
sync for offline use. POP mail works perfectly for me.

Not like bug 80110, it has nothing to do with going offline in the middle of the
download process
Not like bug 79033 since there is no error message from the server.
Mozilla just stops downloading messages after what seems to be an arbitrary
number, and then I have to use the steps above all over again. It can even stop
in the middle of a newsgroup with no apparent relation as to which messages
might get downloaded before it decides to stop. I have not set any limits for
message downloads at all.

Using Commercial Builds
2001-06-21-09-trunk win nt 4.0
2001-06-21-08-trunk/ mac 9.0.4
2001-06-22-11-trunk/ linux 2.2, red hat 7.0

And following the steps to reproduce, I do see this problem.

It is arbitrarily what gets downloaded or not. Usually
the first newsgroup in your list gets downloaded. But after
that I did see where some messages in a newsgroup get downloaded
but others didn't. It would download 3 newsgroups then stop.
In linux test build, it stopped after 2 and it got hung (mouse
is currently a stop watch).

Works fine with like 1 newsgroup. Doesn't matter if you have
lots of messages in the newsgroup or only a few.

I'm not sure if this a "newsgroup" problem or an "offline" problem, David.

Some things that could possibly being giving us problems:
 -In order for me to test this, I had to subscribe to about
  5 or 6 brand new newsgroups. I know bug 84061 covers downloading
  brand new newsgroups. Could this possibly be affecting it?

  For testing purposes, I made sure I got all the headers. On some
  newsgroups I made all the messages 'read' while others all unread.
  I exited messenger and restarted it. And I got inconsistent
  results when trying to do a download and sync

- There is a known bug 86014 that has this pref set in the back end
  but you can't change the value on the front end. So if some of
  these news messages are > 50kb, they won't get downloaded.

  But you can't display the size in Messenger's thread pane for news messages
  like you can for reg. mail messages. So I can't tell if this is the
  reason why news messages aren't getting downloaded.

Changing status to new. 

Also changing the Summary line to be little more descriptive.

Old summary was: Mozilla does not download all messages at once.

  
Summary: Mozilla does not download all messages at once. → Offline: Download & Syncing multiple/subscribed newsgroups doesn't work the first time as not all mesgs/newsgroups are downloaded.
Status: UNCONFIRMED → NEW
Ever confirmed: true
adding nsenterprise keyword
Keywords: nsenterprise
adding nsenterprise-
Target Milestone: --- → Future
I'm also seeing this bug under Windows ME for 0.9.5 release. There is a workaround:
 1. select each newsgroup individually. 
 2. right click to get "properties"
 3. select the "offline" tab. 
 4. Select the "download now" button
 5. Wait for download to finish.
 6. Repeat for every group.

Obvioulsy very laborious if you take more than a few groups.

Can this be raised in priority? It basically means that offline newsgroups are
not available, and thus Mozilla is useless for any dialup news or batch
downloading of newsgroups
I've just checked on the latest Mozilla nightly (2001102403) and the problem is
still happening.
please try again - I think this is fixed now.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
using commercial trunk
2002-02-01-10-trunk/ nt 4.0
2002-02-01-08-trunk/ linux 2.2
2002-02-01-03-trunk/ mac 9.1

Tried downloading various newsgroups:
 -using migrated/non-migrated profile
 -some read mesg headers
 -some newly subscribed newsgroups
 -some large and small newsgroups
 -tried downloading at least 5 groups at once
 -w/mail being downloaded also

And no problems downloading newsgroups. it did not stop in
the middle or randomly download only certain newsgroups.
All newsgroups I selected for download use were downloaded
in the same session.

Will mark verified when I confirm on mac os x.
using 2002020418 trunk on mac 10.1.2

Able to download multiple newsgroups at once
(some brand new newsgrps, some had read mesg headers, some
just had headers imported, multiple sized newsgroups)
with no problem.

marking as verified.
Status: RESOLVED → VERIFIED
removed the item for this bug from the release notes for 0.9.9 and beyond,
because the bug is fixed now. Let me know if you think the item should be 
re-added.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.