If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Possible to drag text to Personal Toolbar Folder

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
17 years ago
6 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If you highlight some text you can then drag the text to the Personal Toolbar
Folder and this creates a link.
This is only be allowed if the text looks like a link ala http:// or ftp://

Currently I can highlight the text "gemal" and drag it to the Personal Toolbar
Folder and create a link that points to "http://gemal"
This seems just wrong.

Comment 1

17 years ago
yep, I also see this with build 2001062004 on Win2k (SP2).

Does seem a bit useless to allow it, but it doesn't hurt a whole lot.  It would
be nice for polish, though.

Jake

Comment 2

17 years ago
DnD isn't enabled on all platforms iirc so please don't report bugs as All/All 
unless you actually reproduced as such.
OS: All → Windows 2000
Hardware: All → PC

Comment 3

17 years ago
--> me
Assignee: ben → blake

Comment 4

16 years ago
>DnD isn't enabled on all platforms iirc so please don't report bugs as >All/All
unless you actually reproduced as such.
Confirmed in 2001071208 Mac trunk build.
Once those text are Drag and Dropped, the items can not be deleted. This is bad.
Even worse, texts can be drag and dropped from other applications in the case of
MacOS.
OS: Windows 2000 → All
Hardware: PC → All

Comment 5

16 years ago
Ironing out ptoolbar dnd in 0.9.4.

I can delete text items fine.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.4

Comment 6

16 years ago
In 2001072308 trunk for MacOS, deleting is working.

Updated

16 years ago
Target Milestone: mozilla0.9.4 → mozilla1.0

Comment 7

16 years ago
*** Bug 96195 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: mozilla1.0 → Future

Comment 8

16 years ago
*** Bug 103918 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
confirming with 2002060208 win2k, but is this a bug or a feature ?

Comment 10

15 years ago
Confirmed Win2K 20020826 - but it doesn't seem like a very useful feature to me,
having a link which goes nowhere. Also in my browser, it is possible to drag any
text, whether it looks like a link or not, and that creates an entry on the bar,
with no title.

Comment 11

15 years ago
Still there after bookmarks branch landing.

Comment 12

15 years ago
*** Bug 202627 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Blocks: 133604
Product: Browser → Seamonkey
IMO the function should simply do what it's told to do and not second guess whether it's a valid URL - URLs are too varied these days to make a useful guess (and that's all it would be  - a guess) 
Assignee: firefox → p_ch
Status: ASSIGNED → NEW
QA Contact: claudius → bookmarks
back peddling a second - in fact ignore what I said.

Using bookmark manager, if you supply a location of say xxx.yyy and click OK then manager often prepends the http:// for you.  IMO d&d text should behave as if you typed it into manager and do all the same checks and changes and additions.

OTOH, requiring http:// in the text of what is copied greatly limits the usefulness of the D&D function.  it's not like most examples of where this would be used that provider of the information (which is obviously plain text) will have included http:// ... and further, as noted above, bookmark manager doesn't require the user to provide it.

Comment 15

12 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody
this is wfm with a current Seamonkey trunk. You can't drop a text in the toolbar
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.