[Dialer] Information is not represented when making a call using contacts list

VERIFIED FIXED in 1.1 QE2 (6jun)

Status

P1
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: etienne)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

(Whiteboard: [TD-9655], MiniWW)

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
1. Title : Information is not represented when making a call using contacts list
2. Precondition : Saved contact // (ex) name : Test / number : 21113754
3. Tester's Action : Making a call 
4. Detailed Symptom : Contact information is not represented
5. Expected : Contact information is represented normally
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train : Reproduced
8. Gaia Revision : d5f7b2d3f7acc04c35abda8b001262d8912f9dfe
9. Gecko Revision : 0ab3418551bfcefe1e14633f8f2b0422707a4c2f
10 Personal email id : promise09th@gmail.com
(Reporter)

Comment 1

6 years ago
Created attachment 749178 [details]
Not represent information

This bug relates Bug 859185
(Reporter)

Updated

6 years ago
Whiteboard: [TD-9655]
(Reporter)

Updated

6 years ago
Flags: needinfo?
(Assignee)

Comment 2

6 years ago
Unable to reproduce this bug (with the exact same phone number).
Used the exact same steps as in the video.

Can you test again and close WORKSFORME if it works?
Flags: needinfo? → needinfo?(leo.bugzilla.gaia)
(Assignee)

Updated

6 years ago
Flags: needinfo?(promise09th)

Comment 3

6 years ago
Leo device is already repreduced this issue.
So, we check that this is real issue.
Flags: needinfo?(promise09th)

Comment 4

6 years ago
I check other device below version, this device also reproduce this issue.

Software : Boot2Gecko 1.1.0.0-prerelease
Gaia Commit: 0d5f55fef5b46b8a53b87daed9abe3b9a37ce3221369088022
Gecko Commit: ada3b9647e60742aacee32918596c0ae022df1cb

Please check this version.

Updated

6 years ago
Target Milestone: --- → 1.1 QE2
(Reporter)

Updated

6 years ago
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Updated

6 years ago
Flags: needinfo?(etienne)
(Assignee)

Comment 5

6 years ago
I tested with the gaia changeset 0d5f55fef5b46b8a53b87daed9abe3b9a37ce322 (the one given wasn't working) and still could not reproduce.

I wonder it this is mcc/sim related, I'll attach a patch adding some logging in order to figure this out.

Can you try again with this patch and attach the resulting logcat to this bug? Thanks!
Flags: needinfo?(etienne)
(Assignee)

Comment 6

6 years ago
Created attachment 752215 [details] [diff] [review]
Patch adding debug logs
(Reporter)

Comment 7

6 years ago
Created attachment 752484 [details]
Variants log

These numbers are saved in contacts.

But device shows only last number "01021113691".

Information of other numbers is not represented in call screen.
(Reporter)

Comment 8

6 years ago
(In reply to Leo from comment #7)
> Created attachment 752484 [details]
Variants log

These numbers are saved in
> contacts.

But device shows only last number "01021113691".

Information of
> other numbers is not represented in call screen.

device only shows information of number "01021113691".
(Assignee)

Comment 9

6 years ago
Hey Reuben, do you know if it's by design that the 13754 isn't matching 21113754?

I thought the "match" keyword worked pretty much like an "endsWidth".
Flags: needinfo?(reuben.bmo)
(In reply to Etienne Segonzac (:etienne) from comment #9)
> Hey Reuben, do you know if it's by design that the 13754 isn't matching
> 21113754?
> 
> I thought the "match" keyword worked pretty much like an "endsWidth".

Etienne, "match" only matches the full number, with the international and national formats. So "13754" will only match a contact if it has a telephone number of "13754" or say, "+5513754".
Flags: needinfo?(reuben.bmo)
Does this only repro if you dial the entire number manually?  For example if you dial the first few numbers, then select the autocomplete suggestion will it show the contact name correctly?
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 12

6 years ago
Created attachment 753679 [details]
Using Suggestion bar and contacts

When making a call using autocomplete suggestion and contacts, same result occurs.

I attach video.
Flags: needinfo?(leo.bugzilla.gaia)
(Assignee)

Comment 13

6 years ago
(In reply to Reuben Morais [:reuben] from comment #10)
> (In reply to Etienne Segonzac (:etienne) from comment #9)
> > Hey Reuben, do you know if it's by design that the 13754 isn't matching
> > 21113754?
> > 
> > I thought the "match" keyword worked pretty much like an "endsWidth".
> 
> Etienne, "match" only matches the full number, with the international and
> national formats. So "13754" will only match a contact if it has a telephone
> number of "13754" or say, "+5513754".

Good to know :)

So basically the SimplePhoneMatcher used in the Dialer app isn't compatible with the way the "match" requests work.
(The SimplePhoneMatcher sends a request for the shortest variant and then looks up the best match in the results.)

We probably want to remove the SimplePhoneMatcher anyway and trust the mozContacts API for the tricky matching (like the SMS app does).

But this won't be trivial, and might have severe implications for the Facebook contacts lookup.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 869060
(Assignee)

Comment 15

6 years ago
A leo+ bug was marked as a duplicate of this one BTW.
According to comment 13 and as it is also a duplicate of a blocker: Blocking.
blocking-b2g: leo? → leo+
Assignee: nobody → evanxd
Whiteboard: [TD-9655] → [TD-9655], MiniWW
Assignee: evanxd → gal

Comment 17

6 years ago
Etienne, are you working on this? This is part of the WW sprint.
(Assignee)

Comment 18

6 years ago
Created attachment 755134 [details] [diff] [review]
Proposed patch

We still need the SimplePhoneMatcher for the facebook lookup, but we're now sending the number directly to the mozContact API for match requests instead of one of the variants.

Good thing is, it makes the patch real simple.

Probably worth to QA properly though.
Assignee: gal → etienne
Attachment #755134 - Flags: review?(gal)

Comment 19

6 years ago
leo QA team, we have a proposed patch. Can you apply the patch and test it?
(Reporter)

Comment 20

6 years ago
I check the patch, it is working well. But, some cases should discuss. 

Save in contact : 01021113754 (name : test)
Call number : 1021113754

In this case, when making a call using number "1021113754", device find "test".
But, this relates phone matching algorithm. 

I already report Bug 871939. I think you watch this issue with Bug 871939.
(Reporter)

Comment 21

6 years ago
In addtion, when making a cll using number "021113754", device can't find any contact.
(Assignee)

Comment 22

6 years ago
So basically this patch delegates all the phone matching issues to gecko.

We should file platform bugs for the follow ups, but they will be fixed for the dialer and the sms app at the same time from now on.

Comment 23

6 years ago
Ok, cool. Lets land this and track the remaining issues in bug 871939.

Updated

6 years ago
Attachment #755134 - Flags: review?(gal) → review+

Comment 24

6 years ago
I am adding more tests for this to bug 871939.

Comment 25

6 years ago
etienne, can you please land this?
(Assignee)

Comment 26

6 years ago
https://github.com/mozilla-b2g/gaia/commit/2ca71e378a9930e166690df3298df8478080a4b8
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Uplifted 2ca71e378a9930e166690df3298df8478080a4b8 to:
v1-train: 56ebf9b4d6384b4ef39ac5ddcf1698162bd76936
status-b2g18: --- → fixed
Flags: in-moztrap?

Comment 28

6 years ago
Added test case in MozTrap: 
https://moztrap.mozilla.org/manage/case/8514/
Flags: in-moztrap? → in-moztrap+

Comment 29

6 years ago
Executed test case https://moztrap.mozilla.org/manage/case/8514/ and verified fixed on:
Device: Leo phone 
Build Identifier: 20130611074722
Update channel: leo/1.1.0/nightly
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d0562d20324
Gaia: 8c64e19b82d4e0490a7780232d3d6bd07d0ba9ec1370937291
Git commit info: 2013-06-11 07:54:51 
OS version: 1.1.0.0-prerelease

and

Device: Unagi phone 
Build Identifier: 20130611074722
Update channel: unagi/1.1.0/beta
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d0562d20324
Gaia: 8c64e19b82d4e0490a7780232d3d6bd07d0ba9ec1370937291
Git commit info: 2013-06-11 07:54:51 
OS version: 1.1.0.0-prerelease
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.