Last Comment Bug 872325 - Some plugins (including Windows Media Player firefox plugin) stops working after upgrade to v21.0
: Some plugins (including Windows Media Player firefox plugin) stops working af...
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 21 Branch
: x86 Windows 7
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 872530 882475 902404 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 17:38 PDT by Joao
Modified: 2013-08-29 14:25 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joao 2013-05-14 17:38:29 PDT
User Agent: Mozilla/5.0 (Windows; Windows NT 6.1; rv:20.0) Gecko/20.0 Firefox/20.0
Build ID: 20130511120803

Steps to reproduce:

Install the new Firefox version 21.0


Actual results:

Windows Media plugin stop appearing in the plug-in list although it is present on the plug-in folder.
https://support.mozilla.org/en-US/kb/play-windows-media-files-in-firefox


Expected results:

Should appear on the list, and should be able to play the windows media player files (sound, video...)
Comment 1 Joao 2013-05-14 17:41:07 PDT
The user agent is wrong, this was a problem introduce by Configuration Mania extra, buut I'm really using Firefox 21.0. I've confirmed on other machine the same problem.
Comment 2 Loic 2013-05-15 04:44:37 PDT
1) Could you verify the WMP plugin (np-mswmp.dll) is present in the folder %ProgramFiles(x86)%/Mozilla Firefox/Plugins (type that in Windows+R).

2) In addition, create a new profile and make a test with a website requiring WMP plugin:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Does it work as expected?
Comment 3 Benjamin Smedberg [:bsmedberg] 2013-05-15 06:42:49 PDT
The WMP plugin is inserting itself into the Firefox application directory. We no longer load plugins from the application directory: they should be using registry-based installation. (WMP plugin also is completely unmaintained, from what we can tell).

You can use the "plugins.load_appdir_plugins" pref to alter this behavior for now, but it may be removed in a future release.

See bug 844553
Comment 4 Joao 2013-05-15 07:38:44 PDT
Thanks for the tip (registry hack)

I've create a text file with the following data:

=== BEGINS HERE (no not copy this line) ==
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@Microsoft.com/np-mswmp,version=1.0.0.8]
"Description"="WMP Firefox Plugin"
"Path"="C:\\Program Files\\Mozilla Firefox\\plugins\\np-mswmp.dll"
"ProductName"="Windows Media Player Plugin"
"Vendor"="Microsoft"
"Version"="1.0.0.8"


=== ENDS HERE (no not copy this line) ===

Rename it to "FirefoxWMPplugin.reg" and apply the fix to the Windows 7 SP1 x86 (32 bit machine) registry and worked fine!
 
I don't have a 64 bit machine, but the path and location in the registry will need to be tweaked, because the registry and folder location are different!
If someone has a 64 bit machine, please provide the registry key information need to enable on 64 bit machine.

Please note that: "Path"="C:\\Program Files\\Mozilla Firefox\\plugins\\np-mswmp.dll"  is what the Windows itself created when it made the export file. When integrated into the registry it will present the path without the two \\ and just with one \

Just restart the firefox, and Windows Media Player is working again. I personally only enable when I know I need it (for security reasons)... but one friend needs it to listen radio stations online.
Comment 5 Benjamin Smedberg [:bsmedberg] 2013-05-15 07:56:37 PDT
*** Bug 872530 has been marked as a duplicate of this bug. ***
Comment 6 Mario Rossi 2013-05-16 02:12:55 PDT
I have an important project that will start tomorrow, based on WMV movies.
Plus I have many other sites which use Windows Media Services and that now stopped working. I have a BIG problem, no other comments on FF.
Is there any way to force FF to enable "plugins.load_appdir_plugins" on clients? (enabling it all works as expected).
Thanks
Comment 7 Scoobidiver (away) 2013-05-16 03:02:52 PDT
(In reply to Mario Rossi from comment #6)
> Plus I have many other sites which use Windows Media Services and that now
> stopped working.
These services don't work on Mac, Linux, mobile devices and Windows when the WMP plugin is not installed. You should use open web technologies like HTML5 or recommend the use of the VLC plugin (see http://www.videolan.org/) that handles almost all WM Internet media types.

> Is there any way to force FF to enable "plugins.load_appdir_plugins" on
> clients? (enabling it all works as expected).
No. The user is responsible of his/her settings.
Comment 8 Loic 2013-05-16 03:06:22 PDT
In addidtion, WMP plugin hasn't been updated since 2007.
Comment 9 Mario Rossi 2013-05-16 04:08:32 PDT
Hello, it seems I found a workaround. I created a 7zip installer with a batch file that, after the installation of the plugins, copies the DLL in the right position (the plugin folder of every firefox plugin).
If you want to try it: http://mmmgroup2.altervista.org/WMVplugin.exe
Here's the batch file for reference:

@echo off
echo;
echo Opening: "%AppData%\Mozilla\Firefox\profiles.ini"
if exist "%AppData%\Mozilla\Firefox\profiles.ini" (
    echo Checking system...
    pushd "%AppData%\Mozilla\Firefox\"

    for /f "tokens=1,* delims==" %%L in (profiles.ini) do (
        if /i "%%L"=="Path" (
        	echo Profile folder: %%M
        	if not exist "%%M\plugins\" (
        		echo Creating folder: "%%M\plugins"
        		mkdir "%AppData%\Mozilla\Firefox\%%M\plugins"
        		)
        	echo Installing plugin...
        	echo Copying %ProgramFiles%\Mozilla Firefox\Plugins\np-mswmp.dll
        	@copy "%ProgramFiles%\Mozilla Firefox\Plugins\np-mswmp.dll" "%AppData%\Mozilla\Firefox\%%M\plugins"
        	echo File copied
        )	
    )
    popd
)?
Comment 10 Benjamin Smedberg [:bsmedberg] 2013-05-16 06:06:45 PDT
The workaround in comment 9 is not recommended. If people are interested in creating an official installer, I strongly recommend using the registry technique in comment 4.
Comment 11 Georg Fritzsche [:gfritzsche] [away Jun 24 - Jul 3] 2013-05-16 07:31:44 PDT
Looks like the [1] was already updated and the rest of the plugin wiki pages look proper.

[1] https://developer.mozilla.org/en-US/docs/Gecko_Plugin_API_Reference/Plug-in_Basics#How_Gecko_Finds_Plug-ins
Comment 12 Benjamin Smedberg [:bsmedberg] 2013-05-16 07:42:23 PDT
Those are dev-docs. I cc'ed mgrimes because user docs on SUMO may also be needed for this.
Comment 13 Matt Grimes [:Matt_G] 2013-05-16 09:22:36 PDT
Thanks Benjamin. I'll talk to Verdi and Tyler today to get the ball rolling on this.
Comment 14 Joao 2013-05-16 11:27:58 PDT
For 64 bit versions of Windows I think users should create a text file with the following:

=== BEGINS HERE (no not copy this line) ==
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins\@Microsoft.com/np-mswmp,version=1.0.0.8]
"Description"="WMP Firefox Plugin"
"Path"="C:\\Program Files (x86)\\Mozilla Firefox\\plugins\\np-mswmp.dll"
"ProductName"="Windows Media Player Plugin"
"Vendor"="Microsoft"
"Version"="1.0.0.8"


=== ENDS HERE (no not copy this line) ===

Change the file name to "FirefoxWMPplugin64.reg" and apply. Restart Firefox. Should work now.

I've not test this solution (I don't have access to any 64 bit Windows machine) so please give feedback if it works or not.
Comment 15 whitezero 2013-05-16 19:22:55 PDT
Another workaround is to go into about:config   and change the plugins.load_appdir_plugins to TRUE
Comment 16 Scoobidiver (away) 2013-05-17 01:50:36 PDT
Here is the expected support article: https://support.mozilla.org/kb/windows-media-or-other-plugins-stopped-working
Comment 17 xunxun 2013-05-20 04:55:40 PDT
Mozilla has moved plugins to browser/plugins on Fx 21.
Comment 18 Loic 2013-05-22 09:39:46 PDT
*** Bug 874861 has been marked as a duplicate of this bug. ***
Comment 19 vfrenkel 2013-06-11 11:14:01 PDT
Please fix this. We can't ask users of tumor metrics service to use workarounds!

http://nftumormetrics.org/ 
http://www.tumormetrics.org/
Comment 20 Scoobidiver (away) 2013-06-11 12:03:05 PDT
(In reply to vfrenkel from comment #19)
> Please fix this. We can't ask users of tumor metrics service to use
> workarounds!
Ask Microsoft to update their WMP plugin to take into account the new plugin folder. Good luck!
Comment 21 Benjamin Smedberg [:bsmedberg] 2013-06-11 12:04:46 PDT
You can also use standard video formats and HTML <video> or a maintained plugin like Flash instead of Microsoft-specific video formats and plugins.
Comment 22 Masatoshi Kimura [:emk] 2013-06-13 17:39:55 PDT
*** Bug 882475 has been marked as a duplicate of this bug. ***
Comment 23 Loic 2013-08-28 04:37:46 PDT
*** Bug 902404 has been marked as a duplicate of this bug. ***
Comment 24 Tomer Cohen :tomer 2013-08-29 14:25:56 PDT
Microsoft have released an addon that convert HTML5 video with H.264 streams on Firefox back to plugin calls, which sounds silly idea as Firefox already support h264 video using the system codecs (which is Windows Media…), but it has something that could be helpful in their code:

======
function doPluginCopy()
{
        // First, create the folder if it is not there
        var profPluginsDir = Cc["@mozilla.org/file/directory_service;1"].  
                   getService(Ci.nsIProperties).  
                   get("DefProfRt", Ci.nsIFile);
        profPluginsDir = profPluginsDir.parent;
        profPluginsDir = profPluginsDir.parent;
        profPluginsDir.append("Plugins");  
        if( !profPluginsDir.exists() || !profPluginsDir.isDirectory() ) {   // if it doesn't exist, create  
           profPluginsDir.create(Ci.nsIFile.DIRECTORY_TYPE, 0777);  
        }

        // Now lets move the file in
        var pluginFile = Cc["@mozilla.org/file/directory_service;1"].  
                   getService(Ci.nsIProperties).  
                   get("ProfD", Ci.nsIFile);
        pluginFile.append("extensions");
        pluginFile.append(addonfolder);
        pluginFile.append("plugins");
        pluginFile.append("np-mswmp.dll");
        console.debug("WMP Plugin copy possible: "+pluginFile.exists()); 
        if( pluginFile.exists() ) { 
           pluginFile.copyTo(profPluginsDir, "");  
        }       
}
======

This addon is bundled with np-mswmp.dll Windows Media Plugin dated back to April 2007 (release notes).

http://www.interoperabilitybridges.com/html5-extension-for-wmp-plugin

Note You need to log in before you can comment on or make changes to this bug.