[B2G][Hamachi] Cannot switch wifi on using settings on Hamachi device

RESOLVED DUPLICATE of bug 869246

Status

Firefox OS
Gaia
--
major
RESOLVED DUPLICATE of bug 869246
5 years ago
5 years ago

People

(Reporter: zac, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation])

(Reporter)

Description

5 years ago
Using
window.navigator.mozSettings.createLock().set("wifi.enabled", true);
to try to set Wifi enabled does not enable WiFi. 

Hamachi Engineering build:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/d40d1831ff41
Gaia   e2187565da22df0c85b2eb501ced4efd342b7bc2
BuildID 20130514230202
Version 18.0

After that, attempting to set WiFi manually the whole WiFi settings option apperas to be jammed, no networks are found. The device needs to be rebooted for WiFi to be usable again.

This is blocking UI test automation on Hamachi device.
(Reporter)

Comment 1

5 years ago
This seems to be true for setting other Settings aswell, for example cell data.
(Reporter)

Comment 2

5 years ago
That is 
window.navigator.mozSettings.createLock().set("ril.data.enabled", true);

Comment 3

5 years ago
Possibly a device binary incompatibility problem with our mozilla Gonk?

see related bugs for Leo:
https://bugzilla.mozilla.org/show_bug.cgi?id=859260
https://bugzilla.mozilla.org/show_bug.cgi?id=860548
Not sure about the answer to Comment 3.  It's possible.  Also possibly related:
bug 862951, bug 859993
(Reporter)

Comment 5

5 years ago
This is for Moz RIL (verified it just then).

Also seems to be for any attempt to set settings - volume, time, etc anything.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 869246
Wifi for this portion doesn't have to do with the RIL.

The reason for the wifi not working is due to an undefined MAC address.
(Reporter)

Comment 8

5 years ago
Thanks :nhirara!
You need to log in before you can comment on or make changes to this bug.