Closed Bug 872711 Opened 7 years ago Closed 6 years ago

Warning: Error in parsing value for 'border-bottom-left-radius'. Declaration dropped.

Categories

(Firefox Graveyard :: SocialAPI, defect)

23 Branch
defect
Not set

Tracking

(firefox22 unaffected, firefox23 affected, firefox24 fixed)

RESOLVED FIXED
Firefox 24
Tracking Status
firefox22 --- unaffected
firefox23 --- affected
firefox24 --- fixed

People

(Reporter: jaws, Assigned: jaws)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Timestamp: 5/15/2013 4:02:27 PM
Warning: Error in parsing value for 'border-bottom-left-radius'.  Declaration dropped.
Source File: chrome://browser/skin/browser.css
Line: 1370, Column: 29
Source Code:
  border-bottom-left-radius: none;


In the CSS:
.social-share-frame {
  background: linear-gradient(to bottom, #f0f4f7, #fafbfc);
  width: 330px;
  height: 150px;
  border-top-left-radius: none;
  border-bottom-left-radius: none;
  border-top-right-radius: inherit;
  border-bottom-right-radius: inherit;
  /* we resize our panels dynamically, make it look nice */
  transition: height 100ms ease-out, width 100ms ease-out;
}

border-top-left-radius and border-top-right-radius need a length unit, so 0 is probably what you want here.
Whiteboard: [good first bug][mentor=jaws][lang=css]
Hi Alex, thanks for offering to work on this bug!

To find the places that need this fixed, you can look at the following search results:

http://mxr.mozilla.org/mozilla-central/search?string=border-top-left-radius:+none;
Assignee: nobody → toman22
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
Assignee: toman22 → jaws
Attachment #757796 - Flags: review?(mixedpuppy)
Attachment #757796 - Flags: review?(mhammond)
Whiteboard: [good first bug][mentor=jaws][lang=css]
Comment on attachment 757796 [details] [diff] [review]
Patch

I only tested on osx, but looks good.
Attachment #757796 - Flags: review?(mixedpuppy)
Attachment #757796 - Flags: review?(mhammond)
Attachment #757796 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/a8e61d04f786
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Whiteboard: [qa-]
Duplicate of this bug: 901167
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.