[UX] UX Review/approve E.Me w/ Marketplace Apps (FFxOS 1.0.1 & 1.1)

RESOLVED FIXED

Status

Tracking
User Story
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: c8o, Assigned: ranbena)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
UX review of E.Me's recommended handling for Marketplace Apps Content on the FFxOS Devices 

There are two phases to implement marketplace apps in E.Me results on the FFxOS, one for 1.0.1 and a more advanced version for v1.1
- UX around apps installed on device could differ between the two phases

Other UX variants could still be unknown

Marketplace UX: Maria Sandberg
FFxOS UX Program Manager: Jaime Chen
FFxOS UX: __tbd_____
E.Me UX: _________
(Reporter)

Updated

5 years ago
Blocks: 873197
(Reporter)

Updated

5 years ago
Assignee: nobody → ran
(Reporter)

Updated

5 years ago
Blocks: 873167
No longer blocks: 873197
(Reporter)

Comment 1

5 years ago
From: Ran Ben Aharon <ran@everything.me>
Subject: Pre-release version
Date: June 13, 2013 1:23:28 PM PDT
To: Caitlin Galimidi <cgalimidi@mozilla.com>
Cc: Ami Ben David <ami@everything.me>, Joey Simhon <joey@everything.me>, Amir Nissim <amirn@everything.me>

Hey Caitlin,

As requested we have a pre-release version available for you guys to play around with.

It's on this branch. 
https://github.com/EverythingMe/gaia/tree/results


Let me know what's the most convenient way to build it on your devices. If you'd like, I can video myself with some use cases.

Features you can test:
Installed apps - as you type in the search box, matching installed apps will appear. Matches are made by app name and by related categories.
Examples:
Type "se" -> "settings" app.
Type "ma" -> "E-mail" "Here maps" "Marketplace"..
Type "vacations" -> "Here Maps" 
Type "social" -> "Facebook" "Twitter" (if installed)
Click on "Games" -> "Chess" "Paddle Game" (if installed)
Clicking an installed app takes you straight to it.

Marketplace apps - only on exact searches (typing and clicking "return", clicking on suggestion, on shortcut, etc.) download suggestions will appear. Matches are made by exact app name match and by category (not yet implemented).
Examples:
Search for "calculator" -> 3 different "Calculator" apps appear.
Search for "stopwatch" -> 3 different "Stopwatch" apps appear.
Search for "tetris" -> 2 different "Tetris" apps appear.
Deduplication - already installed apps won't appear as a download suggestion.

Clicking on a marketplace app should take you to the app page in the marketplace app (but currently doesn't - see below).

Most of the time Marketplace apps are accompanied by Marketplace query search app. Clicking on it should take you to Marketplace search results for that query (but currently doesn't - see below)

Not yet implemented:
Searching categories (i.e "Games") should suggest marketplace / preinstalled apps. Should be available early next week.

Bugs we're aware of
Sometimes installed app show a default image.
Sometimes you have to search a term twice for marketplace apps to appear.
Sometimes app deduping doesn't work.
Clicking a marketplace app doesn't react. Opened a bug.Same bug prevents opening Marketplace app with search results.
Some regressions - layout and interaction bugs (progress indicator position, swipe down for bgimage, scrolling...)

Let me know if you need anything.

Cheers, Ran
(Reporter)

Updated

5 years ago
Summary: [UX] UX Review E.Me w/ Marketplace Apps (FFxOS 1.0.1 & 1.1) → [UX] UX Review/approve E.Me w/ Marketplace Apps (FFxOS 1.0.1 & 1.1)
(Reporter)

Comment 2

4 years ago
Please review the updated E.Me UX and provide feedback to E.Me for their revisions.
Next UX iteration due



SCHEDULE: WORKING BACKWARDS
Final Approval : bug # 881064
15-Aug : code approved 

Development: 881063 
8-Aug : code submitted 
8-Jul - 8-Aug : development 

UX : 873543 
25-Jul : UX final
22-Jul : UX final review, last round feedback
>>>>>>18-Jul : E.Me UX updates complete <<<<<<<
>>>>>>8-Jul : UX Review, 2nd round feedback <<<<<<
25-Jun : UX Mozilla Initial feedback
Assignee: ran → jachen

Comment 3

4 years ago
Hi there-
Can I get a video of this build?

I'm really slammed and want to review this, but don't have the time to get this onto device. I'm asking Caitlin for help.

Thanks!
Jaime
Flags: needinfo?(cgalimidi)
(Reporter)

Updated

4 years ago
Flags: needinfo?(cgalimidi)
(Reporter)

Updated

4 years ago
Flags: needinfo?(ran)

Comment 4

4 years ago
I'll be meeting Ami tomorrow so hopefully I can see it live.

If, not, a video would still be great.

Thanks!
This will be discussed in a workshop with e.me, suggested dates are currently Aug 29-30.
(Reporter)

Comment 6

4 years ago
Aug 29 is way too late to finalize the UX. 
We'll have missed our deadlines for v1.2 by then.
Our UX is due to be final Jul 25

Jaime - you were supposed to see some UX updates from E.Me today. 
Did this not happen?
e.me presented a new proposal for the home screen, not specifically focusing on Marketplace results. The outcome of the meeting was that there will be a workshop with UX and product, probably on Aug 29-30 to agree on the design of the new proposal. Since Marketplace results will be a part of that, and the e.me designers will come for the workshop, it seemed appropriate to discuss all of it then.
(Reporter)

Comment 8

4 years ago
Jaime and Ran - 

The marketplace team needs to see video / screen shots of how Marketplace apps will be displayed in E.Me search results. 

My understanding is that the code has landed (910316), however, until the Marketplace team sees this functionality, we will keep the bugs opened and assigned to E.Me team. (881063)

How soon can we see these?
Flags: needinfo?(jachen)
(Reporter)

Updated

4 years ago
Assignee: jachen → ran

Comment 9

4 years ago
Ran is out on holiday, but I believe if you build Mozilla central nightly, the functionality should be there already.

Have you tried that yet?
Flags: needinfo?(jachen)
(Reporter)

Comment 10

4 years ago
Created attachment 818169 [details]
Movie file of Marketplace in E.Me results
(Reporter)

Updated

4 years ago
Assignee: ran → msandberg
Flags: needinfo?(ran)
(Reporter)

Comment 11

4 years ago
Maria - 
Does this look like the UX you'd approved w/ Jaime?
Are we "signed off" at least for this version?
(Reporter)

Updated

4 years ago
Flags: needinfo?(msandberg)
The design looks right to me but the behavior seems off. I believe the design we agreed on was:

Above the line:
1. local app results
2. marketplace app results, string "download x"
3. marketplace app with string "download more apps". 

- Tapping a result of type 2 should open app details page for x in the Marketplace app. 
- Tapping 3 should open search results page in the Marketplace app (for the original query). 
The video shows a different behavior for both of these points, we need to fix that. 

Bill Maggs also pointed out bugs that need to be addressed:
1. You need an exact search match to see apps; however, this does not seem to always work (try Zmaps) 
2. Still calls the browser, not the Marketplace app 
3. Duplication still happening
Flags: needinfo?(msandberg)
(Reporter)

Updated

4 years ago
Assignee: msandberg → ran
Regarding opening the marketplace app in context - I must say I don't see it happening on my device or simulator in "master". But, we can revisit this once the Bug 925806 is resolved.

Non exact searches are handled in Bug 925815.

Zmaps - opened a ticket for it Bug 928996.

Regarding deduplication, right now searching for "Twitter" will show the Twitter marketplace suggestion and the Twitter cloud app. Once the Marketplace app is installed, the cloud app and marketplace suggestion are deduped. This is by design.
Bill expected the cloud app to be deduped when the marketplace app was suggested. This should be discussed.
Depends on: 925806, 925815

Comment 14

4 years ago
Created attachment 821836 [details]
2013-10-24-16-49-34.png

Shows duplication of Facebook as downloadable Marketplace app and e.me web app.

Comment 15

4 years ago
Comment on attachment 821836 [details]
2013-10-24-16-49-34.png

Attachment shows the use case for an e.me search returning a Marketplace search result and an e.me search result for Facebook. Product sees the cost of the user seeing two Facebook icons without understanding the difference between them outweighing the possible benefit of the user being able to choose whether to install a permanent Marketplace app or having an e.me app experience that is short term. In this discovery use case this is especially true because the e.me app would not be "instant" --the user would have to sign into Facebook. It would be great if Ux could weigh in with an opinion.

Comment 16

4 years ago
Created attachment 824371 [details]
2013-10-29-21-34-05.png

Most important use case (Whatsapp search) looks good.

Comment 17

4 years ago
Created attachment 824372 [details]
2013-10-29-22-04-52.png

But on Nightly from 10-27, search for common app (Loqui) looks weird.

Updated

4 years ago
Flags: needinfo?(msandberg)
Flags: needinfo?(jachen)

Updated

4 years ago
Flags: needinfo?(jcarpenter)
(Reporter)

Updated

4 years ago
Depends on: 937691
(Reporter)

Updated

4 years ago
Depends on: 937694
It seems to me that we should try to minimize the amount of duplicates in general, and I would suggest using the Marketplace version when available. It's true that it will need to be installed (for now), but it's also true that it has gone through significant vetting and often partner deals to end up in the Marketplace in the first place. 

As a separate thought I think we are making definitions fuzzier when talking about an app as "less instant" because it has a sign-in flow. I don't think it will be worth the time to pursue a solution that will determine the "instant-ness" of an app and use that as a weight for sorting here. 

One path to mitigate some of this and other issues is for Marketplace to make apps available without installation. Hosted apps would be a great place to start with that, would love to talk more about how to fit that into the Apps roadmap and timing to align with FxOS.
Flags: needinfo?(msandberg)
(Reporter)

Updated

4 years ago
No longer depends on: 937694
Agree with Maria. It is unfortunate for the user that in order to avoid dupes, we need to make choice for them between an app that's "instant" but perhaps lower in quality, and an app that needs to be installed but may be a better experience. That's a state of affairs that we need to remedy. Better for the user, and much more webby.
Flags: needinfo?(jcarpenter)
(Yosef is experiencing bugzilla comment submission difficulties. This is what he says:)

Hi guys

Our position on this is that we shouldn't dedup a web version when there's a marketplace suggestions. If there's an installed app - sure, it's most likely superior to the web version. But we don't want to force the user to install an app when there's a web version available. A good example would be if a user searches for weather, and a publisher like AccuWeather has both a marketplace suggestion and a web app. Sure, the publisher prefers their app is installed, but the user just wants to quickly get the weather forecast.

As some of us suggested during the work week, there's the option to show just the web app, and notify the user inside the app that there's a better, downloadable version, essentially solving the duplication in the search results. Maybe we should start exploring this path more seriously.

But! I think we've got a little side-tracked from the real problem - the marketplace suggestions don't look different enough from the web app result. That's where the confusion comes from. I can imagine a few ways to differentiate the marketplace suggestions, adding enough cues for its functionality, but that has to be a whole different task that we tackle together.

Updated

4 years ago
Blocks: 938914
(Reporter)

Updated

4 years ago
No longer depends on: 925815
(Reporter)

Comment 21

4 years ago
I'm closing this bug with "silence as consent" from the FxOS UX team.
Assuming they have reviewed the E.Me handling of marketplace search results (given that v1.3 FxOS has shipped)


C
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jachen)
Resolution: --- → FIXED
(Reporter)

Comment 22

4 years ago
From: Jaime Chen <jachen@mozilla.com>
Subject: Re: Closing UX bug: E.me & Marketplace
Date: January 10, 2014 10:20:37 AM PST
To: Stephany Wilkes <swilkes@mozilla.com>
Cc: Caitlin Galimidi <cgalimidi@mozilla.com>

Yes, I believe we are "silent as consent". I believe Candice is setting a review for next week on Rocketbar, which will be the updated version of marketplace integration.

----
Jaime Chen
UX Manager & Design Strategist
Firefox OS, Mozilla




On Jan 10, 2014, at 10:19 AM, Stephany Wilkes <swilkes@mozilla.com> wrote:

I think that's fine. Of course, we have lots of ongoing conversations with E.me, but none that need to be documented in this bug.

Jaime, sound OK?

S.
You need to log in before you can comment on or make changes to this bug.