Marketplace integration in e.me search results needs to open marketplace suggestions in the marketplace app, not the browser

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: ranbena)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
If a user selects a marketplace suggestion in the search results, it needs to open in the marketplace app using a web activity, not the browser.

* If an app is selected, then the app details page for that app should be displayed in the marketplace via a web activity

* If download more apps is selected, then the search results with e.me search term should be displayed in marketplace via a web activity
(Reporter)

Updated

5 years ago
Depends on: 925804, 925805
(Reporter)

Updated

5 years ago
Blocks: 910302
Blocks: 873167
Blocks: 881063
No longer blocks: 873167
(Assignee)

Updated

5 years ago
Blocks: 873543

Updated

5 years ago
Assignee: nobody → amirn

Updated

5 years ago
Duplicate of this bug: 910332
Depends on: 930724
(Assignee)

Updated

5 years ago
Assignee: amirn → ran
Status: NEW → ASSIGNED
Created attachment 827646 [details]
Patch - redirect to github PR

Apparently, you have to "make production" in order for this to work
Attachment #827646 - Flags: review?(crdlc)
Comment on attachment 827646 [details]
Patch - redirect to github PR

Thanks a lot. 

PRODUCTION=1 make reset-gaia -> It works like a charm

Review some comments on github about lint errors
Attachment #827646 - Flags: review?(crdlc) → review+
Landed on master
https://github.com/mozilla-b2g/gaia/commit/768d28acb03ba803a56a00ecada6ae675f56359d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.