email body does not load

RESOLVED DUPLICATE of bug 1012222

Status

RESOLVED DUPLICATE of bug 1012222
6 years ago
4 years ago

People

(Reporter: arasbm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 751392 [details]
email_body_not_loading.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20130513 Firefox/22.0 (Nightly/Aurora)
Build ID: 20130513140514

Steps to reproduce:

- I setup E-Mail app to use my GMail account (using special application password for gmail two-step verification).
- when I enter the email app, I see a list of my emails. In the list I see sender, time and title of each email but no text from the body
- I then tap on any email in the list to try to view it



Actual results:

- when I tap an an email it will open. I can see sender in the header on top. I can also see from and to email addresses as well as the title. There is a spinner in place of the body and it seems to keep spinning indefenitly (I have left it for more than 30 min with no result)
- The WiFi icon shows connecrtivity with strong signal. I verified that I have a connection by opening the FF browser and leading a page. It loads slowly but there is connection


Expected results:

- I expect the see the email content

Comment 1

5 years ago
I have the exact same problem except I'm using a Cyrus IMAP server.

Comment 2

5 years ago
Exact same problem using the ZTE Phone with gmail. That's quite a bummer.

Comment 3

5 years ago
Well, I've ZTE Open as well, FFOS 1.01 with GMail account, and it used to work well, if I remember correctly, but it is much much worse now. 
Very frustrating, to be honest.
I think that only (complex) HTML emails are problematic.
Plain text mails are OK (most of the time), but for example emails sent from Twitter are failing to load completely (try them yourself) or Amazon Deals marketing offers.
You can now consider it as confirmed bug, IMHO...
Too many people complaining to be just coincidence...

Comment 4

5 years ago
I'm testing with two Google email accounts: one Gmail, and one Google Apps. Mails in the Gmail account appear to load fine, but mails in the Google Apps account exhibit this failure mode (recipients and subject show, but spinner never stops and body never shows up).

Both are configured as SMTP/IMAP using smtp.gmail.com & imap.gmail.com on default SSL settings, and an app-specific password to get around use of 2-factor authentication.

Testing on ZTE Open running a v1.2 branch build.

All I see in logcat output is this:

  I/GeckoDump( 3491): LOG: pushCard for type: message_reader

which also happens on the working account.

Comment 5

5 years ago
Same as bug 903696?

Comment 6

5 years ago
Probably.
I can confirm that average behavior of email client is better in FFOS 1.1 than was in 1.01 and I've greater change that email will display properly, alas, it is still far from as reliable as would most users expect...

Comment 7

5 years ago
I tried to do a quick debug poke; unfortunately it seems you can't currently use the remote debugger on certified apps...? So I just stuck some console.log()s in to see what gets run.

By default I just get this:

I/GeckoDump( 3730): LOG: pushCard for type: message_reader

With a bunch of extra console.log()s I can see that the message_reader card's postInsert method gets called, and it fetches a message body with the 'downloadBodyReps' option which fires off asynchronous fetch of the body contents.

The main body object comes back, without the reps downloaded, and we fall out of postInsert, leaving an 'onchange' event handler on the body object which is supposed to call the card's handleBodyChange method.

This never gets called, so we get left on the spinner display forever...


I've taken a brief look at the backend bits in main-frame-setup.js but I don't know yet how everything works in there, it looks a bit scary!

Comment 8

5 years ago
Same problem using activesync with zarafa server (z-push)

Comment 9

5 years ago
Same problem with imap on Dreamhost. ZTE Open. 

Can not eve load message bodies in emails sent to myself from the email app.

- Wes

Comment 10

5 years ago
Restart usually helps and it works for a while.
IMHO 1.1 is much less stable than 1.0 was and if not for better features, I'd downgrade, probably.
On 1.1 I'm restarting approx. 3-4 times a week, because of email or freeze reasons... :-(
Same on 1.3 (currently master + mozilla-central):

Often I see all the from/to/cc/title/time immediately, but the message body is just the spinner forever.

Sometimes none of the fields are populated.

Sometimes I notice the network activity indicator flashing as I initially open the email.

I've been seeing this forever (and probably reported already).

Per the comments above, it happens across many combinations of versions and devices and servers.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Please to help us Andrew. What information can we provide? What debugging steps can we do?
Flags: needinfo?(bugmail)
(In reply to Dietrich Ayala (:dietrich) from comment #12)
> Please to help us Andrew. What information can we provide? What debugging
> steps can we do?

Logcats are usually the easiest thing to provide.  For suggested steps, see:
https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo

Our 1.4 schedule is looking reasonably clear so we should have time to be able to go back and address all the corners we cut in the lead-up to 1.0.1 and 1.1 from a back-end perspective, which should greatly reduce instances of this error.

(In reply to Dietrich Ayala (:dietrich) from comment #11)
> Often I see all the from/to/cc/title/time immediately, but the message body
> is just the spinner forever.

This suggests that there was some type of network difficulty.  logcat will help
 
> Sometimes none of the fields are populated.

This means that you clicked on the message shortly after starting the app up and so the reader card was triggered using only the information in the cached HTML and the back-end had not yet started up.  Why the back-end appears to never start up is an interesting issue for the logcat.

> Sometimes I notice the network activity indicator flashing as I initially
> open the email.

That is us trying to fetch the body for you.
 
> I've been seeing this forever (and probably reported already).
>
> Per the comments above, it happens across many combinations of versions and
> devices and servers.

This is somewhat of a catch-all failure mode.  If we screw up and break while holding the folder mutex, we will never be able to fetch any bodies.  Network trouble?  This.

Mutex related issues will also be obvious if you leave the folder and come back to it and then we don't show you any messages in the folder.
Flags: needinfo?(bugmail)

Updated

5 years ago
blocking-b2g: --- → fugu?
Flags: needinfo?(styang)

Updated

5 years ago
blocking-b2g: fugu? → ---
Flags: needinfo?(styang)

Comment 14

5 years ago
I'm having the same problem with the ZTE Open. It happened with OS v1.0 and continues after v1.1

12-19 16:38:20.909 I/Gecko   (  536): WLOG: Mail universe/bridge created and notified!
12-19 16:38:21.209 I/GeckoDump(  536): LOG: Slice cache match, ignoring sliceSplice for accounts
12-19 16:38:21.419 I/Gecko   (  536): TCPSocket: content process: true
12-19 16:38:21.419 I/Gecko   (  536): 
12-19 16:38:21.419 I/Gecko   (  536): TCPSocket: window init: 4
12-19 16:38:21.429 I/Gecko   (  536): TCPSocket: startup called
12-19 16:38:21.429 I/Gecko   (  536): 
12-19 16:38:21.429 I/Gecko   (  536): TCPSocket: Host info: box464.bluehost.com:993
12-19 16:38:21.429 I/Gecko   (  536): 
12-19 16:38:21.429 I/Gecko   (  536): TCPSocket: SSL: ssl
12-19 16:38:21.429 I/Gecko   (  536): 
12-19 16:38:21.509 I/Gecko   (  114): TCPSocket: content process: false
12-19 16:38:21.509 I/Gecko   (  114): 
12-19 16:38:21.509 I/Gecko   (  114): TCPSocket: window init: undefined
12-19 16:38:21.509 I/Gecko   (  114): TCPSocket: startup called
12-19 16:38:21.509 I/Gecko   (  114): 
12-19 16:38:21.519 I/Gecko   (  114): TCPSocket: Host info: box464.bluehost.com:993
12-19 16:38:21.519 I/Gecko   (  114): 
12-19 16:38:21.519 I/Gecko   (  114): TCPSocket: SSL: ssl
12-19 16:38:21.519 I/Gecko   (  114): 
12-19 16:38:22.559 I/GeckoDump(  536): LOG: saveCacheCookie: 7966 in 4 segments
12-19 16:38:22.839 I/Gecko   (  536): WLOG: syncDateRange: 631152000000 null
12-19 16:38:22.839 I/Gecko   (  536): WLOG: Skewed DB lookup. Start:  631177200000 Mon, 01 Jan 1990 07:00:00 GMT End:  null null
12-19 16:38:24.399 I/GeckoDump(  536): LOG: saveCacheCookie: 7966 in 4 segments
12-19 16:38:25.659 I/Gecko   (  640): ###################################### forms.js loaded
12-19 16:38:25.679 I/Gecko   (  640): ############################### browserElementPanning.js loaded
12-19 16:38:25.749 I/Gecko   (  640): ######################## BrowserElementChildPreload.js loaded
12-19 16:38:28.249 I/Gecko   (  536): TCPSocket: content process: true
12-19 16:38:28.249 I/Gecko   (  536): 
12-19 16:38:28.249 I/Gecko   (  536): TCPSocket: window init: 4
12-19 16:38:28.249 I/Gecko   (  536): TCPSocket: startup called
12-19 16:38:28.249 I/Gecko   (  536): 
12-19 16:38:28.259 I/Gecko   (  536): TCPSocket: Host info: box464.bluehost.com:993
12-19 16:38:28.259 I/Gecko   (  536): 
12-19 16:38:28.259 I/Gecko   (  536): TCPSocket: SSL: ssl
12-19 16:38:28.259 I/Gecko   (  536): 
12-19 16:38:28.269 I/Gecko   (  114): TCPSocket: content process: false
12-19 16:38:28.269 I/Gecko   (  114): 
12-19 16:38:28.269 I/Gecko   (  114): TCPSocket: window init: undefined
12-19 16:38:28.269 I/Gecko   (  114): TCPSocket: startup called
12-19 16:38:28.269 I/Gecko   (  114): 
12-19 16:38:28.269 I/Gecko   (  114): TCPSocket: Host info: box464.bluehost.com:993
12-19 16:38:28.269 I/Gecko   (  114): 
12-19 16:38:28.269 I/Gecko   (  114): TCPSocket: SSL: ssl
12-19 16:38:28.269 I/Gecko   (  114): 
12-19 16:38:28.909 I/Gecko   (  536): WERR: Explosion while processing data TypeError: box.attribs is undefined
12-19 16:38:28.919 I/Gecko   (  536): WERR: Stack: ImapAccount.prototype._determineFolderType@app://email.gaiamobile.org/js/ext/mailapi/composite/configurator.js:3562
12-19 16:38:28.919 I/Gecko   (  536): walkBoxes@app://email.gaiamobile.org/js/ext/mailapi/composite/configurator.js:3693
12-19 16:38:28.919 I/Gecko   (  536): walkBoxes@app://email.gaiamobile.org/js/ext/mailapi/composite/configurator.js:3718
12-19 16:38:28.919 I/Gecko   (  536): ImapAccount.prototype._syncFolderComputeDeltas@app://email.gaiamobile.org/js/ext/mailapi/composite/configurator.js:3721
12-19 16:38:28.919 I/Gecko   (  536): processResponse@app://email.gaiamobile.org/js/ext/mailapi/imap/probe.js:749
12-19 16:38:28.919 I/Gecko   (  536): processData@app://email.gaiamobile.org/js/ext/mailapi/imap/probe.js:967
12-19 16:38:28.919 I/Gecko   (  536): ImapConnection.prototype.connect/<@app://email.gaiamobile.org/js/ext/mailapi/imap/probe.js:465
12-19 16:38:28.919 I/Gecko   (  536): EventEmitter.prototype.emit@app://email.gaiamobile.org/js/ext/mailapi/worker-bootstrap.js:10924
12-19 16:38:28.919 I/Gecko   (  536): NetSocket.prototype._ondata@app://email.gaiamobile.org/js/ext/mailapi/imap/probe.js:83
12-19 16:38:28.919 I/Gecko   (  536): NetSocket/routerInfo<@app://email.gaiamobile.org/js/ext/mailapi/imap/probe.js:43
12-19 16:38:28.919 I/Gecko   (  536): receiveInstanceMessage@app://email.gaiamobile.org/js/ext/mailapi/worker-bootstrap.js:9949
12-19 16:38:28.919 I/Gecko   (  536): receiv
12-19 16:38:28.919 I/GeckoDump(  536): ERR: onerror reporting: box.attribs is undefined @ app://email.gaiamobile.org/js/ext/mailapi/composite/configurator.js : 3562
12-19 16:38:34.009 I/Gecko   (  536): WLOG: searchargs:  NOT DELETED SINCE 1-Jan-1990
12-19 16:38:34.779 I/Gecko   (  536): WLOG: SERVER UIDS 6 60
12-19 16:38:35.159 I/GeckoDump(  536): LOG: saveCacheCookie: 11383 in 6 segments
12-19 16:38:35.769 I/Gecko   (  536): WLOG: FETCHED 0 known id 12 known srvid 29818 actual id 29410
12-19 16:38:35.789 I/Gecko   (  536): WLOG: FETCHED 1 known id 11 known srvid 29817 actual id 29662
12-19 16:38:35.799 I/Gecko   (  536): WLOG: FETCHED 2 known id 7 known srvid 29791 actual id 29769
12-19 16:38:35.799 I/Gecko   (  536): WLOG: FETCHED 3 known id 3 known srvid 29769 actual id 29791
12-19 16:38:35.829 I/Gecko   (  536): WLOG: FETCHED 4 known id 1 known srvid 29662 actual id 29817
12-19 16:38:35.829 I/Gecko   (  536): WLOG: FETCHED 5 known id 0 known srvid 29410 actual id 29818
12-19 16:38:35.849 I/Gecko   (  536): WLOG: Sync Completed! null days 6 messages synced
12-19 16:38:35.849 I/Gecko   (  536): WLOG: folder message count 13 dbCount 6 syncedThrough null oldest known 1386434754000
12-19 16:38:36.299 I/GeckoDump(  536): LOG: saveCacheCookie: 10538 in 6 segments
The log comment 14 was requested to be added by Rachel from the Helpdesk via SUMO; https://support.mozilla.org/en-US/questions/980630
(In reply to michael from comment #14)
> I'm having the same problem with the ZTE Open. It happened with OS v1.0 and
> continues after v1.1

Thanks for the log!  Any chance you're on linux (or a platform with the "openssl" binary available) and can follow the steps mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=943009#c12 to help us find out the folder hierarchy that's breaking for you?

Comment 17

5 years ago
Andrew, I sent the LIST information privately to the email address listed in the post referred to above.

Updated

5 years ago
Duplicate of this bug: 903696

Comment 19

5 years ago
For tracking purposes - 
Another user is reporting this issue in the SUMO forums: https://support.mozilla.org/pt-BR/questions/1005201

This user has a ZTE Open C v1.3 (with first update through Software Update app). Resetting the phone did not solve this issue. 

This user reports that he sees the "Blue Loading Circle" on every email that he tries to open.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1012222
You need to log in before you can comment on or make changes to this bug.