"Write a Review" button broken on Reviews Listing page

VERIFIED FIXED in 2013-05-23

Status

Marketplace
Consumer Pages
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: cvan, Assigned: basta)

Tracking

2013-05-23
Points:
---

Details

(Whiteboard: [fireplace], URL)

(Reporter)

Description

5 years ago
1. As an authenticated user, go to https://marketplace-dev.allizom.org/app/pulse/ratings
2. Click the "Write a Review" button.
3. Notice the console error:

   Uncaught Template render error: (ratings/write.html) [Line 2, Column 10]
   Error: Unable to call `_`, which is undefined or falsey include.js:6
Duplicate of this bug: 873983
My initial thought was that minification might something to do with this. I tried to repro this locally and I can't seem to even when running with local fireplace via zamboni.

As an aside for me if I don't comment out inapp_payments.js include.js doesn't load (due to $ being undefined), though I'm not sure if that's an unrelated settings issue? In any case with that out of the way this works normally and it works fine in fireplace directly too.
(Assignee)

Comment 3

5 years ago
Where are we even using inapp_payments.js? I feel like we don't need it and it should be removed from the bundle.

The original issue here might have accidentally gotten fixed when I fixed some race conditions this weekend. -dev might not have updated because -dev.
(In reply to Matt Basta [:basta] from comment #3)
> Where are we even using inapp_payments.js? I feel like we don't need it and
> it should be removed from the bundle.
> 

Good question I can't see any references to it in fireplace.

> The original issue here might have accidentally gotten fixed when I fixed
> some race conditions this weekend. -dev might not have updated because -dev.
(Assignee)

Comment 5

5 years ago
It was caused by Underscore not being imported on the views/app/ratings page.

https://github.com/mozilla/fireplace/commit/88a2c7f771be0ee733525e56318038406920d0b7
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
This is verified and fixed. Thanks!
Status: RESOLVED → VERIFIED
Assignee: nobody → mattbasta
You need to log in before you can comment on or make changes to this bug.