Closed Bug 874888 Opened 7 years ago Closed 7 years ago

The privacy policy is incorrectly linked in about:rights

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 24
Tracking Status
firefox21 --- wontfix
firefox22 --- wontfix
firefox23 --- verified
firefox24 --- verified
fennec + ---

People

(Reporter: AdrianT, Assigned: Margaret)

References

Details

Attachments

(3 files, 1 obsolete file)

Attached image screenshot
Firefox Mobile 21 / Firefox Mobile 22 beta 2
Samsung Galaxy R (Android 2.3.4)

Steps to reproduce:
1) Load about:rights
2) Scroll down and tap on the "Firefox Privacy Policy"

Expected results:
The user is taken to the privacy policy page

Actual results:
Instead of being taken to www.mozilla.org/en-US/legal/privacy/firefox.html the user is taken to www.mozilla.org/en-US/legal/privacy/ which is just a placeholder page

Notes:
The link to the Privacy Policy is correct on about:
This is fixed on mozilla-23.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795588
There is no link in that section on about:rights on both Aurora 23.0a2 2013-05-22 and Nightly 24.0a1 2013-05-22
Also looking over bug 795588 the bug refers to about: this issue refers to about:rights
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I don't know that this bug is actually valid, since that page does link to our privacy policies. This link is to http://www.mozilla.com/legal/privacy/, which is the same URL used on desktop.

http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/aboutRights.xhtml#35
http://mxr.mozilla.org/mozilla-central/source/toolkit/content/aboutRights.xhtml#37
The link on mobile is www.mozilla.org/en-US/legal/privacy/ which displays the page from the first screenshot which is a placeholder and does not contain the privacy policy. www.mozilla.org/en-US/legal/privacy/firefox.html(the current link to the privacy policy on beta in about:) or http://www.mozilla.org/%LOCALE%/privacy/ (The page added in bug 795588 to about:) actually contain the text of the privacy policy. 
This bug also seems to affect Desktop. Furthermore it seems that on Desktop(FF21 release) just like on Nightly about:rights does not have the privacy policy linked where it should.
Karen, which link do you want? Also, put a ':' in your name.
Flags: needinfo?(krudnitski)
Keywords: productwanted
Please use the following link:  http://www.mozilla.org/en-US/legal/privacy/firefox.html
Flags: needinfo?(krudnitski)
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → +
Attached patch patch (obsolete) — Splinter Review
Attachment #756254 - Flags: review?(wjohnston)
Attached patch patchSplinter Review
Actually, let's make this https and mozilla.org.
Attachment #756254 - Attachment is obsolete: true
Attachment #756254 - Flags: review?(wjohnston)
Margaret - what is it that you're proposing to do with the link provided? (pass me the exact change you have proposed please and reasoning)
Flags: needinfo?(margaret.leibovic)
Attachment #756275 - Flags: review?(wjohnston)
(In reply to Karen Rudnitski [:kar] from comment #10)
> Margaret - what is it that you're proposing to do with the link provided?
> (pass me the exact change you have proposed please and reasoning)

Copying from the attached diff (you can click on the patch to view this):

-  ... href="http://www.mozilla.com/legal/privacy/" ...
+  ... href="https://www.mozilla.org/legal/privacy/firefox.html" ...

The reasoning is that I took the link you posted, and made it https, since we've been moving towards only using https for in-product links.
Flags: needinfo?(margaret.leibovic)
Thanks, Margaret (and never assume I will have the nerve to click on a patch ;-) - so I appreciate being hand held).

I am just ensuring there is no issue from legal, although suspect there isn't. I will inform back if they scream with a reasonable argument against, although can't imagine they would.

Karen
For the record, good to go with https (got a much quicker confirmation than expected). Thanks, Margaret, for looking out for stuff like this.
Thanks for checking to make sure I'm doing the right thing :)

And I will totally help you conquer your fear of looking at patches!
Attachment #756275 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/fd02958ae436
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
See Also: → 885941
Comment on attachment 756275 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): this isn't a regression, but we'd like to uplift it because FHR will be part of 23, and we want users to be able to access privacy policies easily
User impact if declined: privacy policies are incorrectly linked
Testing completed (on m-c, etc.): currently on m-c and aurora
Risk to taking this patch (and alternatives if risky): low risk, just updates a link URL
String or IDL/UUID changes made by this patch: n/a
Attachment #756275 - Flags: approval-mozilla-beta?
Comment on attachment 756275 [details] [diff] [review]
patch

Good catch, and in time for FHR - approving.
Attachment #756275 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified fixed on:
Build: Firefox for Android 23.0b8(2013-07-23)
Device: Samsung Galaxy R
OS: Android 2.3.4
Verified fixed on:
Device: LG Optimus 4X (Android 4.1.2)
Build: Firefox for Android 24.0b1(2013-08-07)
You need to log in before you can comment on or make changes to this bug.