Defect - The URL bar edit right-click context menu doesn't display

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: jimm, Assigned: rsilveira)

Tracking

Trunk
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=defect c=main_ui_reorganization u=metro_firefox_user p=1)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
str:

1) copy some text
1) right-click the new nav bar

expected:

context menu displays with "paste and go"

actual: no menu is displayed
Blocks: 859003
No longer blocks: 841214
Priority: -- → P1
Whiteboard: feature=defect c=tbd u=tbd p=tbd
Whiteboard: feature=defect c=tbd u=tbd p=tbd → feature=defect c=main_ui_reorganization u=metro_firefox_user p=0
Assignee: nobody → rsilveira
Status: NEW → ASSIGNED
Created attachment 755012 [details] [diff] [review]
Patch v1

MenuUI.showContextMenu() expected the target to be a browser or null for chrome. But it needs to be set for url bar context menu. Added a check to make sure target is a browser before calling msgBrowserToClient().
Attachment #755012 - Flags: review?(mbrubeck)
Attachment #755012 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/f57219a206a8
Whiteboard: feature=defect c=main_ui_reorganization u=metro_firefox_user p=0 → feature=defect c=main_ui_reorganization u=metro_firefox_user p=1
Blocks: 875024
No longer blocks: 859003
QA Contact: jbecerra
Summary: The urlbar edit right-click context menu doesn't display → Defect - The URL bar edit right-click context menu doesn't display
https://hg.mozilla.org/mozilla-central/rev/f57219a206a8
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
For testing and verification.
Flags: needinfo?(kamiljoz)
Went through the following "Defect" for testing  & verification and ran into a few small issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-01-03-09-38-mozilla-central/

Issue #1:

- If you "tap" on the "Navigation App Bar", the OSK appears and moves the "Navigation App Bar" above the OSK. If you then "right click" using the mousepad, the OSK will disappear but the context menu will still be displayed where the "Navigation App Bar" used to be while the OSK was present. It will appear like the context menu is just "floating" in the middle of the screen.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Tap on the "Navigation App Bar" and the OSK should appear and move the "Navigation App Bar" above the OSK
3) With your mousepad, right click on the "Navigation App Bar" to receive the context menu (notice the OSK disappearing and the context menu is left behind)

Issue #2:

- Once you have pasted something into the "Navigation App Bar" using the "tap & hold" method, pressing "Enter" will not direct you to the URL that you pasted. Even if you select the "Navigation App Bar" several times by tapping or using the mousepad, pressing "Enter" will not load the pasted URL in the "Navigation App Bar"

This issue only occurs when your tapping, it works fine when you right click, paste and then select "Enter" on your keyboard

Steps to reproduce the issue:

1) Open Firefox Metro (make sure you have something in the windows clipboard you can paste)
2) Tap and hold and then release, select "Paste" in the context menu
3) Try pressing "Enter" on your keyboard (nothing will occur)
4) Tap or use the mousepad and try selecting the "Navigation App Bar" again and then press "Enter" (notice that the website will not load)
Status: RESOLVED → REOPENED
Flags: needinfo?(kamiljoz)
Resolution: FIXED → ---
(Reporter)

Comment 6

6 years ago
(In reply to Kamil Jozwiak [:kjozwiak] from comment #5)
> Went through the following "Defect" for testing  & verification and ran into
> a few small issues. Used the following build:
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-01-03-09-38-
> mozilla-central/
> 
> Issue #1:
> 
> - If you "tap" on the "Navigation App Bar", the OSK appears and moves the
> "Navigation App Bar" above the OSK. If you then "right click" using the
> mousepad, the OSK will disappear but the context menu will still be
> displayed where the "Navigation App Bar" used to be while the OSK was
> present. It will appear like the context menu is just "floating" in the
> middle of the screen.
> 
> Steps to reproduce the issue:
> 
> 1) Open Firefox Metro
> 2) Tap on the "Navigation App Bar" and the OSK should appear and move the
> "Navigation App Bar" above the OSK
> 3) With your mousepad, right click on the "Navigation App Bar" to receive
> the context menu (notice the OSK disappearing and the context menu is left
> behind)

Filed bug as a regression on bug 857437, which is where we fixed the address bar positioning.

> Issue #2:
> 
> - Once you have pasted something into the "Navigation App Bar" using the
> "tap & hold" method, pressing "Enter" will not direct you to the URL that
> you pasted. Even if you select the "Navigation App Bar" several times by
> tapping or using the mousepad, pressing "Enter" will not load the pasted URL
> in the "Navigation App Bar"
> 
> This issue only occurs when your tapping, it works fine when you right
> click, paste and then select "Enter" on your keyboard
> 
> Steps to reproduce the issue:
> 
> 1) Open Firefox Metro (make sure you have something in the windows clipboard
> you can paste)
> 2) Tap and hold and then release, select "Paste" in the context menu
> 3) Try pressing "Enter" on your keyboard (nothing will occur)
> 4) Tap or use the mousepad and try selecting the "Navigation App Bar" again
> and then press "Enter" (notice that the website will not load)

I'm unable to reproduce this. Would you mind confirming, and if you can reproduce, file a new defect bug? I don't think it should block this bug though since this is just about context menu display, not functionality.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Sounds good Jim! I reproduced the issues several times on two different machines but will create new defects as these are functionality issues and not display problems like you mentioned. Used the following build for testing & verification for the following "Defect":

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-02-03-12-40-mozilla-central/

- Ensured that the context menu is not displayed when the clipboard is empty and there's nothing to paste (using both mousepad & touch)
- Ensured that the context menu appears on the awesome page when there's something in the clipboard (using both mousepad & touch)
- Ensured that the context menu appears when the user is on a webpage and there's something in the clipboard (using both mousepad & touch)
- Ensured that both the "Paste" & "Paste & go" appear every single time in the context menu (using both mousepad & touch)
- Ensured that the formatting & spelling is correct (for both mousepad & touch)
- Ensured that the above test cases also work in "Filled View" without any issues
Status: RESOLVED → VERIFIED
Went through the following "Defect" for iteration #9 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-25-03-12-38-mozilla-central/

- Went through the original test case added in comment 0 without any issues
- Went through the test cases added in comment 7 without any issues
Depends on: 895945
Tested on 2013-07-19 using latest nightly for iteration #10 regression testing, and I was able to see issue #1 in comment #5 (which is filed) and I filed bug 895945 along the way.
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130812030209
Built from http://hg.mozilla.org/mozilla-central/rev/87c1796bc46c

WFM
Tested on windows 8 using latest nightly for iteration-11. Followed steps provided in comment0 and got expected result(context menu displays with "paste and go").
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130826074752
Built from http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.