Last Comment Bug 875734 - Marketplace shows the "Offline Mode" page first time it is launched when there is no connection
: Marketplace shows the "Offline Mode" page first time it is launched when ther...
Status: RESOLVED FIXED
:
Product: Marketplace
Classification: Server Software
Component: Consumer Pages (show other bugs)
: 1.0
: x86 Mac OS X
: P1 normal (vote)
: 2013-05-23
Assigned To: Christopher Van Wiemeersch [:cvan]
:
:
Mentors:
Depends on:
Blocks: 875849
  Show dependency treegraph
 
Reported: 2013-05-24 05:13 PDT by Daniel Coloma:dcoloma
Modified: 2014-05-06 10:54 PDT (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screen grab of error screen to be put in place if no internet connection on first run (14.39 KB, image/jpeg)
2013-05-24 13:21 PDT, Caitlin Galimidi [:c8o]
jsmith: feedback+
Details

Description Daniel Coloma:dcoloma 2013-05-24 05:13:40 PDT
STR:

 - Flash a device
 - Don't configure any way to connect to Internet
 - Launch marketplace

RESULT:

 - Blue web page saying that the device is in Offline Mode is shown indicating that "in offline mode can't browse the Web".

EXPECTED: 

 - A friendly indicator that connection is required to use marketplace (it happens after a first successful connection)
Comment 1 Jason Smith [:jsmith] 2013-05-24 07:49:35 PDT
This is not a blocker at all. I understand Simon wants perfection, but we aren't holding a release for an error page on first run. For partner apps, this was deemed as cosmetic for a first run with zero user impact (in those cases, we even WONTFIX on that case, because we are not doing outreach for cosmetic issues). In fact, here's the criteria that is used severity on anything with offline:

- First run friendly offline error page - cosmetic, non-blocker
- Friendly offline error page during usage - recommendation, non-blocker
- Offline experience with app assets local (if possible) - important, blocker

As I've said before, we do not track tef blockers for marketplace issues at all. As such, clearing blocking flag.
Comment 2 Jason Smith [:jsmith] 2013-05-24 07:59:29 PDT
I also confirmed that the experience is perfectly fine post initial load. You get friendly offline error messages if the network is lost.
Comment 3 Jason Smith [:jsmith] 2013-05-24 08:01:21 PDT
This also works fine if the app launches with no network connection after previously having a connection on a previous run.
Comment 4 Caitlin Galimidi [:c8o] 2013-05-24 10:08:24 PDT
Marketplace will need to push a new package

Updated page can use current error message for hosted apps that has already passed TEF/MOZ acceptance


Error Page Details:
- Black Screen w/ Marketplace Logo : "Marketplace requires wifi or internet connection"

Steps:
- dev / fix (Wil's team)
- L10N Polish & Spanish - (Lucas Adamski? Jorge Villalobos?)
- regress / test (Krupa)
- Push (IT - Jeremy Orem, Jason Thomas)
- Create new build (Kevin Hu)
- Test build (Kevin Hu)

Risks:
- we don't usually push on Friday's - will require special approval up the flagpole (RICK / MMayo)
- it's friday of a long weekend - added risk for folks being out - we'll need 1 marketplace, 1 QA and IT folks "on-call" over the weekend (bribery?)


What are the strong / violent objections?
Risks I missed?
Comment 5 Caitlin Galimidi [:c8o] 2013-05-24 10:32:48 PDT
Can we / Should we reuse the already-in-place, friendly offline error message Jason refers to in comment 2?
Comment 6 Caitlin Galimidi [:c8o] 2013-05-24 10:41:28 PDT
In case we need Polish translation :

" Rynek wymaga połączenie z sieci WiFi lub internetu "

s/Rynek/Marketplace/ if we don't localize it

But Gandalf should review if we can catch him. :-)
Comment 7 Jason Smith [:jsmith] 2013-05-24 10:48:43 PDT
I'll file a different bug for pushing an updated marketplace packaged app to the device with this fix.
Comment 8 Caitlin Galimidi [:c8o] 2013-05-24 13:21:40 PDT
Created attachment 753948 [details]
screen grab of error screen to be put in place if no internet connection on first run
Comment 9 Caitlin Galimidi [:c8o] 2013-05-24 13:22:36 PDT
screen grab attached with updated copy / imagery
karen to grab TEF / Simon to approve
Comment 10 Jason Smith [:jsmith] 2013-05-24 13:25:01 PDT
Comment on attachment 753948 [details]
screen grab of error screen to be put in place if no internet connection on first run

Looks fine to me - that meets the requirements to my understanding.
Comment 11 Caitlin Galimidi [:c8o] 2013-05-24 13:31:30 PDT
Yeah!!!
Localized language already available
screen grab attached with updated copy / imagery
karen to grab TEF / Simon to approve
Comment 12 Karen Ward [:kward] 2013-05-24 14:10:29 PDT
(In reply to Caitlin Galimidi from comment #8)
> Created attachment 753948 [details]
> screen grab of error screen to be put in place if no internet connection on
> first run

The display message in attachment 753948 [details] was approved by Simon via email.
Comment 14 Caitlin Galimidi [:c8o] 2013-05-24 15:35:21 PDT
Y'all ROCK! Thank you muchly!!
Comment 15 Daniel Coloma:dcoloma 2013-05-24 15:38:23 PDT
Do we need to uplift this to v1.0.1?
Comment 16 Caitlin Galimidi [:c8o] 2013-05-24 16:24:21 PDT
jsmith - is there anything we need to do to ensure this marketplace packaged app gets updated in the new build? what is the bug you opened in comment 7... we are unclear if marking this tef? will get this into triage... advice?
Comment 17 Jason Smith [:jsmith] 2013-05-24 16:32:25 PDT
I opened the bug blocking this (bug 875849) to track the tef blocking work to land the updated package in the build.

I think we've got the flags set here right.
Comment 18 Christopher Van Wiemeersch [:cvan] 2013-05-24 17:36:11 PDT
BTW, this is what the final offline screen looks like localised in Portuguese:

http://f.cl.ly/items/3X3x2i3X372V2O2o1K0T/Screen%20Shot%202013-05-24%20at%203.49.14%20PM.png
Comment 19 Karen Ward [:kward] 2013-10-29 09:31:28 PDT
(In reply to Caitlin Galimidi from comment #8)
> Created attachment 753948 [details]
> screen grab of error screen to be put in place if no internet connection on
> first run

This was answered in May.  Bug is closed.
Comment 20 Karen Ward [:kward] 2013-10-29 09:39:28 PDT
(In reply to Caitlin Galimidi from comment #8)
> Created attachment 753948 [details]
> screen grab of error screen to be put in place if no internet connection on
> first run

Work was completed in May.
Comment 21 Karen Ward [:kward] 2013-10-29 09:41:31 PDT
(In reply to Caitlin Galimidi from comment #8)
> Created attachment 753948 [details]
> screen grab of error screen to be put in place if no internet connection on
> first run
This was answered in May.  Bug is closed.
Comment 22 Karen Ward [:kward] 2013-12-19 14:33:06 PST
(In reply to Caitlin Galimidi from comment #8)
> Created attachment 753948 [details]
> screen grab of error screen to be put in place if no internet connection on
> first run

This bug is closed.
Comment 23 Karen Ward [:kward] 2014-05-06 10:47:09 PDT
Comment on attachment 753948 [details]
screen grab of error screen to be put in place if no internet connection on first run

this bug is closed

Note You need to log in before you can comment on or make changes to this bug.