Closed Bug 876294 Opened 8 years ago Closed 2 years ago

IMAP Delimiter not escaped?

Categories

(Thunderbird :: Folder and Message Lists, defect)

17 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1512053

People

(Reporter: d.egger, Unassigned)

References

(Depends on 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Hi! I'm using an Dovecot 2.x Server with IMAP:
Hirarchy seperator is '$'.
Im also using the listescape Plugin.

I tried to create a folder name "Stuff/Example"


Actual results:

TB created a Folder "Stuff" with a ubfolder "Example".


Expected results:

A folder named "Stuff/Example" should have been created.

I tried the same with Outlook 13 -> Everything worked fine.

Please could someone check this?
(In reply to d.egger from comment #0)
> I tried to create a folder name "Stuff/Example"
> Actual results:
> TB created a Folder "Stuff" with a ubfolder "Example".
> Expected results:
> A folder named "Stuff/Example" should have been created.

(1) Tb passes requested string of "Stuff/Example" as-is to IMAP server.
  If you requested "Stuff/Example" when "Parent" is current folder,
  'create "Parent$Stuff/Example"' is requested to IMAP server
  because delimiter="$".
  This is correct when delimiter="/". This is also correct when
  delimiter="$" or ".", beccause "/" is never delimiter used by server.
  All is up to IMAP server.
i.e. 'Who created Folder "Stuff" with a subfolder "Example"' is server.

Because server is perhaps Linux, "/" is delimiter in file system at server. Your Dovecot perhaps creates directory named Parent/Stuff/,  and creates directory named Parent/Stuff/Example/ or file named Parent/Stuff/Example. It's Parent -> Stuff -> Example, so your Dovecot perhaps passes Mbox name of following to Thunderbird.
  "Parent", "Parent$Stuff", and "Parent$Stuff$Example".
  
Note:
If IMAP server of delemiter!="/" actually creates Mbox named "Stuff/Example" instead of "Mbox of Stuff and Mbox of Stuff$Example", Tb probably failss to handle it correctly, because "/" is also used as path delimiter of internal URL format path in Tb.

> I tried the same with Outlook 13 -> Everything worked fine.

After creation by Outlook, what Mbox name is passed from your Dovecot to Thunderbird and what Mbox name is shown by Tb?
(See bug 402793 comment #28 and get IMAP log, and check LSUB response and LIST response in log file.)
 folder
Oh, you look to have found bug 29926 already.
Depends on: 29926

This is the same problem as I am trying to fix in Bug 1512053.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1512053
You need to log in before you can comment on or make changes to this bug.