[Buri][3rd party app]Can't exit game pack after click home key, game keeps running at background

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: sync-1, Assigned: lstowasser)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [3rd Party][TD-47420])

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #451811 +++
 
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.121
 Firefox os  v1.0.1
 Mozilla build ID:20130527070203
 
 *DEFECT DESCRIPTION:
 
  1. Enter Game Pack->magic stone.
  2. Press home button to go to homescreen.
  3. You can here the game music.
  4. Enter the game again, you'll find the game is running when minimize.
 
 I know if bug 872177 is fixed, this problem would be ok.
 But bug 872177 is not fixed for v1.0.1
 So the "Game Pack" app should pause itself when visibility changes.
 
 *REPRODUCING PROCEDURES:
 
 *EXPECTED BEHAVIOR:
 The game should pause when minimize.
 *USER IMPACT:
 
 *REPRODUCING RATE:
 5/5
 ++++++++++ end of initial bug #451811 description ++++++++++

Updated

6 years ago
Component: Gaia → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Target Milestone: --- → Jun

Updated

6 years ago
Blocks: 871238
Target Milestone: Jun → ---

Updated

5 years ago
Duplicate of this bug: 885191

Updated

5 years ago
Whiteboard: [3rd Party][TD-47420]

Updated

5 years ago
Assignee: nobody → telin
Status: NEW → ASSIGNED

Comment 2

5 years ago
Reproduced on FFOS v1.2 on Keon Geeksphone device. Since the app home button does not work (bug 875950), there is essentially no way to pause any of the games.

Updated

5 years ago
Assignee: telin → lstowasser

Comment 3

5 years ago
Louis, can you please review and provide a fix date.  Thank you
(Assignee)

Comment 4

5 years ago
Is this bug about the broken home button or music playing in the background when the app is paused? There wasn't any background music for me on magic stone.
(Assignee)

Comment 5

5 years ago
Uploaded a fix
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.