Closed Bug 878442 Opened 11 years ago Closed 11 years ago

Add tree change mutations to the inspector actor

Categories

(DevTools :: Inspector, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 24

People

(Reporter: dcamp, Assigned: dcamp)

References

Details

Attachments

(1 file, 3 obsolete files)

      No description provided.
Blocks: 878443
Attached patch WIP 1 (obsolete) — Splinter Review
This is untested, but I think it should work.  Doesn't yet fake child list mutations for iframe loads, I'll probably save that for a followup.
Attached patch v1 (obsolete) — Splinter Review
With tests and the fixes needed to make those tests work.
Attachment #757037 - Attachment is obsolete: true
Attachment #757147 - Flags: review?(jwalker)
(oops, the child list changes will need to include numChildren updates for the nodes...)
Blocks: 878614
Attached patch v2 (obsolete) — Splinter Review
This version updates numChildren
Attachment #757147 - Attachment is obsolete: true
Attachment #757147 - Flags: review?(jwalker)
Attachment #757175 - Flags: review?(jwalker)
Attached patch v3Splinter Review
Improved documentation.
Attachment #757175 - Attachment is obsolete: true
Attachment #757175 - Flags: review?(jwalker)
Attachment #759495 - Flags: review?(jwalker)
Comment on attachment 759495 [details] [diff] [review]
v3

Review of attachment 759495 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/devtools/server/actors/inspector.js
@@ +1051,5 @@
> +   *   removed: array of <domnode actor ID> The list of actors *previously
> +   *     seen by the client* that were removed from the target node.
> +   *
> +   * Actors that are included in a MutationRecord's `removed` but
> +   * not in an `added` has been removed from the client's ownership

s/has been removed/have been removed/

@@ +1105,5 @@
>            mutation.incompleteValue = true;
>          } else {
>            mutation.newValue = targetNode.nodeValue;
>          }
> +      } else if (mutation.type === "childList") {

This is kind of a prove-i've-been-here comment. Wouldn't 'mutation' be a better name:

    for (let mutation of mutations) ....

Ignore at will.
Attachment #759495 - Flags: review?(jwalker) → review+
I used 'change' instead of 'mutation' because it seemed to small a change from 'mutations' by total percentage of characters.  But I kinda regret that now.

Enough patches would bitrot if I changed that now that I'd prefer a followup if we care enough.
(In reply to Dave Camp (:dcamp) from comment #7)
> I used 'change' instead of 'mutation' because it seemed to small a change
> from 'mutations' by total percentage of characters.

Boy did I mess that sentence up.

"mutation" vs "mutations" seemed harder to see the difference between than "change" vs. "mutations".  But I regret that, I think.
https://hg.mozilla.org/integration/fx-team/rev/cccfd3161714
Assignee: nobody → dcamp
Whiteboard: [fixed-in-fx-team]
No longer blocks: remote-inspector, 878443
https://hg.mozilla.org/mozilla-central/rev/cccfd3161714
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 24
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: