[socorro-crashstats] BadStatusCodeError: 500 in middleware

VERIFIED FIXED

Status

Socorro Graveyard
Middleware
--
blocker
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: stephend, Assigned: rhelmer)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
BadStatusCodeError: 500: on: http://socorro-mware-stage-zlb.webapp.phx1.mozilla.com/bpapi/signaturesummary/report_type/distinct_install/signature/EMPTY%3A%20no%20crashing%20thread%20identified%3B%20corrupt%20dump/start_date/2013-06-03T00%3A38%3A10/end_date/2013-06-06T00%3A38%3A10/

when hitting https://crash-stats-django.allizom.org/signature_summary/json_data?range_value=3&range_unit=days&signature=EMPTY%3A+no+crashing+thread+identified%3B+corrupt+dump&date=2013-06-06

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "crashstats/crashstats/utils.py", line 39, in wrapper
    response = f(request, *args, **kw)
  File "crashstats/crashstats/views.py", line 1557, in signature_summary
    end_date=end_date,
  File "crashstats/crashstats/models.py", line 234, in get
    return self.fetch(url % params, expect_json=expect_json)
  File "crashstats/crashstats/models.py", line 139, in fetch
    raise BadStatusCodeError('%s: on: %s' % (resp.status_code, url))
Brandon, was this introduced with bug 838251?
(Reporter)

Updated

5 years ago
Blocks: 789526
This works for me on stage.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

5 years ago
This is an individual report, and likely to change, given on the exception; check out https://errormill.mozilla.org/webtools/socorro-crashstats-stage/ for the full list of these 500 (and other HTTP status-code errors).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 4

5 years ago
Blocks the switch to PHP - rhelmer can you take a look?
Severity: major → blocker
(Assignee)

Comment 5

5 years ago
This looks very similar to bug 880087 - running it locally:

RequiredParameterError at /signature_summary/json_data: versions

If you modify the URL in comment 0 to add a "version" param (the view takes it as "version" for backwards-compat, and sends it to the model/mware as "versions") you can see that it works:

https://crash-stats-django.allizom.org/signature_summary/json_data?range_value=3&range_unit=days&signature=EMPTY%3A+no+crashing+thread+identified%3B+corrupt+dump&date=2013-06-06&version=ALL:ALL
Status: REOPENED → ASSIGNED
(Assignee)

Updated

5 years ago
Assignee: nobody → rhelmer
(Assignee)

Updated

5 years ago
Duplicate of this bug: 885868
(Assignee)

Comment 7

5 years ago
I compared the behavior of the old site, and it turns out /report/list should support being called with no version parameter. In this case both should assume this means "ALL".

r? https://github.com/mozilla/socorro-crashstats/pull/392

Comment 8

5 years ago
Commits pushed to master at https://github.com/mozilla/socorro-crashstats

https://github.com/mozilla/socorro-crashstats/commit/557b24fcd39b80ba400e17727c83be7011ad7762
fixes bug 880087 - versions should be optional for /report/list and signature summary

https://github.com/mozilla/socorro-crashstats/commit/c2d7809c4880d42b03eb6dcc2392000dc4312e81
Merge pull request #392 from rhelmer/bug880087-query-report-list-missing-version-param

fixes bug 880087 - versions should be optional for /report/list and sign...

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

5 years ago
Created attachment 767994 [details]
Post-fix screenshot
Product: Socorro → Socorro Graveyard
You need to log in before you can comment on or make changes to this bug.